You must be logged in to post messages.
Please login or register

RoN Tech Support
Moderated by alincarpetman

Hop to:    
Welcome! You are not logged in. Please Login or Register.21 replies
Rise of Nations Heaven » Forums » RoN Tech Support » Text Box Issue
Bottom
Topic Subject:Text Box Issue
KyleAmerica1718
Member
posted 04-04-12 08:50 PM EDT (US)         
I have looked all over the internet about this issue, found several others with a similar (or actually, the exact same) problem, but no solution.

First, I'll say i'm running on a Samsung laptop. Intel HD Graphics card, 8 GB of RAM, Windows 7 OS.

On the list of known issues, my Graphics card is not listed, either.

The issue is that in the game, the text boxes won't show up. This would be the resource box in the top left, the city names, any notifications about being attacked that appear in the top middle, the help text that happens when you mouse over a unit or building, and the scores in the bottom right. The game runs perfectly, i can play as much as i want, but with the text boxes being jittery and displaying incorrectly, it is hard to enjoy it. And the problem isn't just the text not showing up, but it's mostly broken, like it appears in bits and pieces.

This isn't my photo, but it is the EXACT same thing that's happening to me: http://www.flickr.com/photos/72630287@N05/6556600187/

Can anyone help? Any suggestions are appreciated.


Kyle
AuthorReplies:
Zapppa
Member
posted 04-05-12 01:02 AM EDT (US)     1 / 21       
A suggestion:

Go to the rise2.ini file and see what are the SYS, MEM, CPU, and GPU grade override settings. Mine are set to auto. If yours is set to auto then substitute with A, B etc and see if there is a change. The auto settings may not be a true reflection of your computer. (and it is an older game).

While there you can also disable the intro screen. (set SkipIntroMovies=1)
KyleAmerica1718
Member
posted 04-05-12 12:30 PM EDT (US)     2 / 21       
I tried every input from A through F and nothing changed at all; but i did disable the intro movies, so thanks!

If anyone has anymore suggestions, please help.

[This message has been edited by KyleAmerica1718 (edited 04-05-2012 @ 12:50 PM).]

Zapppa
Member
posted 04-05-12 01:24 PM EDT (US)     3 / 21       
Here is a link to Microsoft Support. (not for your problem but to find rise2.ini)
http://support.microsoft.com/kb/827813

However it appears to be hidden on your computer. So this may help:

It is in c:/users/%computername%/application data/microsoft games/rise of nations

If hidden, go to control panel | folder options, click view tab, and check view hidden files and folder and UNcheck Hide Protected OS files.

The rise2.ini file can be modified with notepad and are the initial settings to starting up Rise of Nations.

[This message has been edited by Zapppa (edited 04-05-2012 @ 01:30 PM).]

KyleAmerica1718
Member
posted 04-05-12 08:17 PM EDT (US)     4 / 21       
yeah, i had googled it after i posted it and had to unhide the files. Unfortunately, no luck with that. Thank you for the suggestion!
It's just hard to understand why a game would have a harder time loading correctly with better graphics cards.
Shaddy
Member
posted 04-06-12 04:32 AM EDT (US)     5 / 21       
Hi Kyle,

Have you found any luck with this issue?
I also have the same issue but none help to fix it.
My Laptop is HP Pavilion dm4-3001tx.

Shaddy
PalaceGuard
Member
posted 04-06-12 08:29 AM EDT (US)     6 / 21       
I saw this post from a while back... dunno if it'll help you, but check it out and see if it does:
Update:
Hey guys, I've found a solution: a program called SwiftShader which emulates a video card.
It introduces a few bugs like some textures are flickering, but tooltip boxes are finally visible and this is more important.
KyleAmerica1718
Member
posted 04-06-12 09:50 AM EDT (US)     7 / 21       
Shaddy, no i haven't found a solution.

Palace Guard, thanks for the idea, i'll try it out. Thank you!

EDIT: I tried it, downloaded a demo of the third one. I followed all the instructions in the ReadMe file and i looked up tutorials on YouTube, but i haven't had any luck.

[This message has been edited by KyleAmerica1718 (edited 04-06-2012 @ 07:08 PM).]

KyleAmerica1718
Member
posted 04-12-12 03:03 AM EDT (US)     8 / 21       
Okay, so still no solution as of yet.
But for anyone else having this problem, i have a very minor solution, it's still 100% annoying, but you can see.
If you move the text so that it's over something other than terrain, you can see.
Like, if you move the screen so the text appears above trees, a mountain or a building, instead of water or dirt, it will show. Change your text boxes to minimum detail so you can get what you need out of them, and expand the resources box in the top left to fix that part.

If anyone has a permanent solution (possible tested?) it would be appreciated!
Zapppa
Member
posted 04-13-12 08:42 PM EDT (US)     9 / 21       
Try changing the compatibility mode for RoN. Set it to XP and see what happens.

Right click RoN > Properties > Compatibility

There are also display settings that you can adjust as well.
VelvetClaw
Member
posted 04-14-12 09:23 AM EDT (US)     10 / 21       
Hello,

Have you tried running RoN using the BEST graphics card that you can? try the following: right-click patriots.exe, and then select "Run with graphics processor".

It's still annoying that mods won't run on my computer, for some reason or the other.

[img]http://vignette3.wikia.nocookie.net/interbellum/images/6/60/AXP_banner.png/revision/latest?cb=20150328191407[/img] [img]http://vignette2.wikia.nocookie.net/ronriseofkings/images/d/d6/Rkc_banner.png[/img] [img]http://vignette2.wikia.nocookie.net/kingsandconquerors/images/0/09/KChe_Banner_roma.png[/img]
KyleAmerica1718
Member
posted 04-27-12 02:55 PM EDT (US)     11 / 21       
Hi Guys,
Thanks for the posts.
I've tried all the compatibility options twice, and nothing changed.
VelvetClaw, what kind of computer are you using? When i right click patriots.exe, my options are: "Open, Run as Administrator, troubleshoot compatibility, send to bluetooth, edit with notepad++" then there's several antivirus options followed by the usual cut, copy, paste, etc. I've also searched all the options, but there isn't one about a graphics processor.
Alejandro17
Member
posted 05-13-12 05:48 PM EDT (US)     12 / 21       
I have the same issue anybody found solutions? playing on Windows 7 here also
LesCM19
Member
posted 09-25-12 05:28 AM EDT (US)     13 / 21       
Expanding the resources display in the top left corner made this go away for me. Lord knows why it fixes it but it did for me.

divide & conquer!!

Les
PalaceGuard
Member
posted 10-08-12 11:06 AM EDT (US)     14 / 21       
I just bought a new laptop (Toshiba Satellite, Windows 7) and I now have this same problem. All my text boxes are mismatched in size, and there is a black "gap" visual artifact with them.

It's pretty bizarre. Later on I'll give all these suggestions a try to see if they solve the problem. I may post a screenshot if it shows up properly.
Liljox
Member
posted 11-12-12 12:44 PM EDT (US)     15 / 21       
I made an account to just to show my solution. I went to the top left and expanded the resources and my text showed just like normal. It was very strange but it works and i suggest all of you try it to. I play with Intel HD Graphics just like all of you and it works for me which means it should work for you.
Az_Kasper
Member
posted 01-20-13 12:44 PM EDT (US)     16 / 21       
I made an account just to say this lol. Liljox is right, I just expanded all of the resource text on the top left of the screen and the text box at the bottom left started to show completely. Thank you so much Liljox!!!
Pulkit_C
Member
posted 12-15-13 10:12 PM EDT (US)     17 / 21       
HEY GUYS EVERYBODY I FINALLY FOUND A WORKING SOLUTION.
NO NEED TO DOWNLOAD ANYTHING.
Just follow the steps:
1. look at your resource panel at the top-left.
2. there will things to collapse and expand
3. Just Expand everything there
4. Thats it . It should fix the problem
creepongirls
Member
posted 02-12-14 08:59 PM EDT (US)     18 / 21       
Have you tried making the game run on windows 7 compatibility ? it fixed it for me
M o d
Member
posted 02-13-14 03:03 AM EDT (US)     19 / 21       
KyleAmerica1718,
does your laptop just have 1 grapics card? I had this issue with optimus-technology choosing the onboard instead of the Nvidia dedicated(or the other way around). manually override and select the other 1 resolved it for me.
newguy123
Member
posted 03-21-14 08:28 PM EDT (US)     20 / 21       
I love this game and I created an account just to reply to this thread.

M o d's solution WORKS without having to expand any boxes.

I think I know why too. I woke up this morning and to my annoyance I found that some random driver installed on my computer, and it didn't say what. It turned out that it was the new Intel HD 3000 driver, and my laptop was scheduled to install important updates automatically on the 21st. Well for some reason the new driver changed the defaults for some programs to run on the Intel drivers instead of my Nvidia card.

To FIX: Go to your Nvidia control panel (probably right click on the desktop) and go to "Manage 3d Settings". From there you can choose which card individual programs run on, or what all programs run on. I just changed the global settings to run on my Nvidia card and it is working like a champ now.
heidayu
Member
posted 03-20-17 03:31 AM EDT (US)     21 / 21       
Thank very much Pulkit_C, it works for me
You must be logged in to post messages.
Please login or register

Hop to:    

Rise of Nations Heaven | HeavenGames