You must be logged in to post messages.
Please login or register

Throne & Patriots Expansion Pack
Moderated by alincarpetman

Hop to:    
Welcome! You are not logged in. Please Login or Register.10 replies, Sticky
Rise of Nations Heaven » Forums » Throne & Patriots Expansion Pack » T&P version doubt
Topic Subject:T&P version doubt
posted 09-19-10 07:20 PM EDT (US)         

I recently started playing RON T&P over LAN with a friend of mine, but we are having a strange conflict of versions.

Basically we both upgraded our versions to the latest one via the auto-update feature inside the game. The 'About Rise Nations' option shows that the version is correctly installed on both systems.

But we are having a little problem in the LAN multiplayer section. On my computer, it says there that my version is and on his computer it says there that his version is This conflict is stopping us from joining games and playing over LAN, because there is a version mismatch error.

Before I opened this topic, I did some research on this issue and found 2 or 3 topics here at heaven about it, but I didn't understand them quite well. My doubts are:

- which one of those 2 versions is the official latest version for T&P? Is it

- If it is, why is his game saying he has in the About section? And how can I get to, why didn't the auto-update work to get to that version?

This is really confusing for me. Can someone explain this issue better here and help me solve it?

Thank you for reading.
Best regards
Galahad Berlin
posted 09-20-10 06:06 AM EDT (US)     1 / 10       

Well, the ist he latest version.

Here is the way to find out what version you have:

Create a multiplayer game. Have a look in the blue chat-screen. There you find the version you have. There is also a version number at the buttom, but that is irrelevant.

There are two reasons why you have different version numbers:

1. One of you has the gold version and the other one doesnt. I know some people where the gold version does not work with the normal (RoN+TP) version.

2. Maybe the updating did not work.
Reinstall the game and update again.
If that does not work, try this:

The one with the older version copies the content of the other ones Rise of Nations folder into his folder.

If i remember correctly, that worked at our latest LAN-session here.
posted 09-20-10 10:41 AM EDT (US)     2 / 10       
Thanks for the answer
But I'm still confused...
Well, the ist he latest version.
Hehe, you mean "is" or "isnt"?

Yes, that's true. I have Gold version and I get everywhere, including in the MP chat blue screen, and he has RON + RON T&P and he gets on that same screen, but everywhere else.

But I'm still confused. I want to know why this happens exactly, why we have different version numbers, why he gets and at different places and a more pure method of getting to the correct version than copying the entire folder content

I read on the other topics that this is related to a 'patch.rtp' file included in the installation CD, which the installer picks and applies and that avoids getting to, which gets me more confused too.

Can someone explain please?

Best regards

[This message has been edited by LightTree (edited 09-20-2010 @ 10:43 AM).]

Galahad Berlin
posted 09-22-10 07:21 AM EDT (US)     3 / 10       
Well, i mean "is".

"Ist" is the german word for "is" so i did not notice my mistake.

Why the god version and the real Tp version seem to have such problems i dont know.

I only know that copying the folder helps.

But the one with the gold version should buy the two cds seperately to play on his own.
posted 09-29-10 03:21 AM EDT (US)     4 / 10       
Thanks for your help

But, no one else knows more about this issue?? :S Please help...

posted 05-31-11 10:40 AM EDT (US)     5 / 10       
Ok..I think I figure this one out. I've bought a few days earlier the RON - gold edition. When you install this it's autopatching, so when you enter the T&P game, it seems all are good except when trying for a multiplayer game. You can't join and noone can join you either. I've looked for the last hours on forums, and found out 2 valid explination:
1. problems via router - if you don't have you will be fine, if you do, you can easily find solutions on web (what ports should be activated)

2. If first one doesn't work is that you the patching on the gold cd is bugged. So what to do, because the game thinks the patch is ok, so you can't update no matter what you do via game...
So you have to do a little modding for the game.
I) You go to install folder, then in Thrones and Patriots/data and you look for the file current_version.xml. You open it with notepad (<ROOT>
<VERSION current_version=""/>
</ROOT> )

You replace the part between " " with instead of

II) Start the T&P game. Now when you go to look for updates. it should start patching

III) After patch is complete it will require the cd, which you won't have because you have the Gold edition, not the original+expansion cds. So you explore the dvd go at RONX/UK (or the language you installed the game)/Files and copy the patriots.exe in your install directory

IV) Now the game should work in multiplayer
Galahad Berlin
posted 06-01-11 09:27 AM EDT (US)     6 / 10       

If that works - and it seems logic to me - this is a real breakthrough
posted 12-29-11 06:11 AM EDT (US)     7 / 10       
Hello friends!!!
i'm Gianluca from italy!
I have the same problem for updating the game to version 7...
I tried to change the "current version" in the T&P\data but the update not start..
I do not have the gold version of the game but i have RON+T&P
can you help me???

PS:sorry for my bad english
Galahad Berlin
posted 01-16-12 08:26 AM EDT (US)     8 / 10       
Hi Jack!

Reinstall the game.

After installing, RoN TaP, try to update again.
posted 08-28-12 12:46 PM EDT (US)     9 / 10       
I don't underestand a thing:
Is possibile to play on multyplayer with the gold edition? (I have the expansion but in a different disc)
Pimp Masterflex
posted 08-29-12 11:52 PM EDT (US)     10 / 10       
I have the Gold Version, and Ive been playing since 2009. Ive also reinstalled onto another computer in 2010, and worked fine as well at that time.

Your complaint is one of many, and I regret to inform you that a canonical solution does not exist at this time.

All I could say is try to hit "Check for Updates" on the main menu (and not on Multiplayer), and see if (by the luck of God) you are taken to an update.

This problem has grown, and I will have to contact some people who know better than I to see if there is a problem (because I have exhausted all my thought power on this issue)

Pimp approved, master class!
You must be logged in to post messages.
Please login or register

Hop to:    

Rise of Nations Heaven | HeavenGames