You must be logged in to post messages.
Please login or register

Game Modifications
Moderated by alincarpetman

Hop to:    
Welcome! You are not logged in. Please Login or Register.212 replies, Sticky
Rise of Nations Heaven » Forums » Game Modifications » Modeling Help Thread
Bottom
Topic Subject:Modeling Help Thread
« Previous Page  1 ··· 6 7 8 9  Next Page »
uthum876
Member
posted 06-06-10 02:24 PM EDT (US)         
Ok so I am going to start this thread so that any of us that are modelling can post our problems and questions here.

This is in the hope that any of our veteran modelers like ODA can drop by and answer some questions as I am beginner at Max too.

[This message has been edited by uthum876 (edited 06-07-2010 @ 03:13 AM).]

AuthorReplies:
Super7700
Member
posted 03-08-12 00:23 AM EDT (US)     176 / 212       
Do you mean hybrid as in mixing and matching models? If so, you should just make 1 model for one unit, with guns, sails, oars etc all part of that one model. Therefore you don't have to mess about with mixing and matching.

I don't remember the old carrack having different parts or anything, and I didn't use any modelling tools to implement a modified version of it (I mixed and matched the old and new carrack), so it doesn't appear to be particularly relevant to modelling.

~ Creator of Kings and Conquerors, a total conversion mod for Rise of Nations: Thrones and Patriots ~
VelvetClaw
Member
posted 03-08-12 08:21 PM EDT (US)     177 / 212       
Okay, a quick check on Wadis10's tutorials and other content has confirmed what I had been thinking about so far: RoN's models are all based off arbitrarily stacked 3d objects. This means that we could easily remove parts by simply rendering them as transparent.

I also found a good tut on boatbuilding, here: http://www.youtube.com/watch?v=7pe72yh-lkE&feature=related

[img]http://vignette3.wikia.nocookie.net/interbellum/images/6/60/AXP_banner.png/revision/latest?cb=20150328191407[/img] [img]http://vignette2.wikia.nocookie.net/ronriseofkings/images/d/d6/Rkc_banner.png[/img] [img]http://vignette2.wikia.nocookie.net/kingsandconquerors/images/0/09/KChe_Banner_roma.png[/img]
VelvetClaw
Member
posted 03-09-12 08:34 PM EDT (US)     178 / 212       
Okay, I encountered a really big problem.

I managed to create a hull for a large ship using vertices, but each time I attempted to convert it to an editable poly, the whole model vanishes completely, making it impossible to work on. Does anyone know what can be done about it?

[img]http://vignette3.wikia.nocookie.net/interbellum/images/6/60/AXP_banner.png/revision/latest?cb=20150328191407[/img] [img]http://vignette2.wikia.nocookie.net/ronriseofkings/images/d/d6/Rkc_banner.png[/img] [img]http://vignette2.wikia.nocookie.net/kingsandconquerors/images/0/09/KChe_Banner_roma.png[/img]
Super7700
Member
posted 04-06-12 10:29 PM EDT (US)     179 / 212       
I've just got a small question right now: how do I attach an ammo node to an object? This object has already been rigged and everything like that but I need to add an ammo node from which the unit can throw javelins.

~ Creator of Kings and Conquerors, a total conversion mod for Rise of Nations: Thrones and Patriots ~
Wadis10
Member
posted 04-07-12 06:48 AM EDT (US)     180 / 212       
I think you would have to re-physique it, but you can save the existing physique as a .phy file, then re-physique it with the extra node and simply reload the .phy file and everything should be correct.
Super7700
Member
posted 04-07-12 06:40 PM EDT (US)     181 / 212       
Why would I need to reload the physique file after I rephysique it? Also, how do I actually attach the node?

~ Creator of Kings and Conquerors, a total conversion mod for Rise of Nations: Thrones and Patriots ~
uthum876
Member
posted 04-07-12 06:56 PM EDT (US)     182 / 212       
At the top left of the program there is a button called "select and link", press it and click on the node and then drag a line from the node to the limb or part of your mesh's skeleton you want the node to link to. As far as I know you would always have to re-physique your mesh, however I must admit I haven't tried Wadis' method.

[This message has been edited by uthum876 (edited 04-07-2012 @ 07:21 PM).]

Super7700
Member
posted 04-07-12 08:57 PM EDT (US)     183 / 212       
This sounds a bit stupid, but when I created the dummy node it was red and when I attached it to the hand it was still red. However in the completed models I've seen the dummy node is blue. What do I need to do to make the node blue. Does it even matter?

I've also noticed that the ammo node only shows up in the select by name list when I have already selected it, yet this doesn't happen to the ammo nodes of other models.

~ Creator of Kings and Conquerors, a total conversion mod for Rise of Nations: Thrones and Patriots ~

[This message has been edited by super7700 (edited 04-07-2012 @ 09:02 PM).]

uthum876
Member
posted 04-07-12 10:59 PM EDT (US)     184 / 212       
The color doesnt matter at all. I dont understand your second question Super.

[This message has been edited by uthum876 (edited 04-07-2012 @ 10:59 PM).]

Super7700
Member
posted 04-07-12 11:26 PM EDT (US)     185 / 212       
Nevermind, I managed to get the node working by using your rigged peltast model and just replacing the mesh with my one.

~ Creator of Kings and Conquerors, a total conversion mod for Rise of Nations: Thrones and Patriots ~
uthum876
Member
posted 04-08-12 04:13 AM EDT (US)     186 / 212       
ok cool, I'll send you the archer tomorrow, the Peltasts look breath-taking!
Super7700
Member
posted 04-08-12 04:19 AM EDT (US)     187 / 212       
Thanks a lot! Fortunately I have two weeks of holidays so I've got plenty of time to get some more models done. If you could also email me those Egyptian buildings and also the Spartan Hoplite when you complete it, that would be brilliant. I need that cape for multiple models such as the hypaspist and Thracian peltasts (I'm not good at making things from scratch at all).

~ Creator of Kings and Conquerors, a total conversion mod for Rise of Nations: Thrones and Patriots ~
ColonelMolotov
Member
posted 04-18-12 02:41 PM EDT (US)     188 / 212       
Hi everyone,

I've been working on a twin-engine propeller plane, for A Wrong Turn, and am having a rather annoying issue.
Though I did manage to animate each propeller, and its works perfectly in 3DSmax, after exporting the file as a .BHa, only one propeller actually spins in-game. It seems like you can only animate the nodes one at a time, but then, how can I make both propellers spin simultaneously ?

Can anyone help me on that ?
VelvetClaw
Member
posted 04-25-12 07:06 PM EDT (US)     189 / 212       
Introducing to you....my first model!



Well, almost (-_-)

Does anyone know why this model got distorted so grotesquely?

The file (still unrigged) is located at http://forums.heavengames.com/redir/http://dl.dropbox.com/u/64188162/fusta-rigged.max - for this one, I only added 2 nodes, a firing node and a root node, which was the parent of the former, and little else. Is there something else I neglected? it seems that my model is tipped sternwise into the water, and that its oars and a great deal of its hull are pretty missing.

I also have another problem - while trying to link up the nodes, I discovered only a few were green - have I done something wrong when creating the model?

[img]http://vignette3.wikia.nocookie.net/interbellum/images/6/60/AXP_banner.png/revision/latest?cb=20150328191407[/img] [img]http://vignette2.wikia.nocookie.net/ronriseofkings/images/d/d6/Rkc_banner.png[/img] [img]http://vignette2.wikia.nocookie.net/kingsandconquerors/images/0/09/KChe_Banner_roma.png[/img]

[This message has been edited by VelvetClaw (edited 04-25-2012 @ 07:09 PM).]

uthum876
Member
posted 04-25-12 07:08 PM EDT (US)     190 / 212       
did u pick the rigid option under physique?
VelvetClaw
Member
posted 04-25-12 08:54 PM EDT (US)     191 / 212       
No, but now that you mention it, what is it supposed to do, and what is its relation to the above picture?

[img]http://vignette3.wikia.nocookie.net/interbellum/images/6/60/AXP_banner.png/revision/latest?cb=20150328191407[/img] [img]http://vignette2.wikia.nocookie.net/ronriseofkings/images/d/d6/Rkc_banner.png[/img] [img]http://vignette2.wikia.nocookie.net/kingsandconquerors/images/0/09/KChe_Banner_roma.png[/img]
hindos
Member
posted 04-25-12 09:15 PM EDT (US)     192 / 212       
Is it possible to use blender for moddeling? As I don't want to have two modeling programs.

Come join us at Project Ressurection: http://ron.heavengames.com/cgi-bin/forums/index.cgi
Rise from the ashes my fellow nations!
Super7700
Member
posted 04-26-12 01:56 AM EDT (US)     193 / 212       
Velvetclaw, if it is rigid, the vertices will stay where you placed them.

Hindos, only 3ds Max 4 and 5 are compatible with the exporter to the BH3 model files RON uses. The way you can get 3ds Max 5 is posted earlier in this thread.

~ Creator of Kings and Conquerors, a total conversion mod for Rise of Nations: Thrones and Patriots ~
Wadis10
Member
posted 04-26-12 02:22 AM EDT (US)     194 / 212       
All verticies must be green or it won't work. My first model did something similar and it was because some of the verticies were blue.

As for propellors, I'm not sure how you've done it but for the models in original RoN propellors are 'attached' to nodes on the aircraft model in unitgraphics. You should be able to use either the lancaster propellor or the ones availible in the fighter sections.

This is an example of what I'm talking about in the lancaster bomber entry:

<EXISTEVENT starttime="0" endtime="9999" anim="CHAR_WALK" type="LancasterProp0" node="8"/>
<EXISTEVENT starttime="0" endtime="9999" anim="CHAR_WALK" type="LancasterProp1" node="9"/>
<EXISTEVENT starttime="0" endtime="9999" anim="CHAR_WALK" type="LancasterProp2" node="10"/>
<EXISTEVENT starttime="0" endtime="9999" anim="CHAR_WALK" type="LancasterProp3" node="11"/>
<EXISTEVENT starttime="0" endtime="9999" anim="CHAR_SLOG" type="LancasterProp0" node="8"/>
<EXISTEVENT starttime="0" endtime="9999" anim="CHAR_SLOG" type="LancasterProp1" node="9"/>
<EXISTEVENT starttime="0" endtime="9999" anim="CHAR_SLOG" type="LancasterProp2" node="10"/>
<EXISTEVENT starttime="0" endtime="9999" anim="CHAR_SLOG" type="LancasterProp3" node="11"/>
<EXISTEVENT starttime="0" endtime="9999" anim="CHAR_DEFAULT" type="LancasterProp0" node="8"/>
<EXISTEVENT starttime="0" endtime="9999" anim="CHAR_DEFAULT" type="LancasterProp1" node="9"/>
<EXISTEVENT starttime="0" endtime="9999" anim="CHAR_DEFAULT" type="LancasterProp2" node="10"/>
<EXISTEVENT starttime="0" endtime="9999" anim="CHAR_DEFAULT" type="LancasterProp3" node="11"/>
<EXISTEVENT starttime="0" endtime="9999" anim="CHAR_ATTACK2" type="LancasterProp0" node="8"/>
<EXISTEVENT starttime="0" endtime="9999" anim="CHAR_ATTACK2" type="LancasterProp1" node="9"/>
<EXISTEVENT starttime="0" endtime="9999" anim="CHAR_ATTACK2" type="LancasterProp2" node="10"/>
<EXISTEVENT starttime="0" endtime="9999" anim="CHAR_ATTACK2" type="LancasterProp3" node="11"/>

I was trying to get this to work on a custom plane model previously, but I was unable to get the propellors to appear in the right places. It might have to do with the naming of the nodes or their hierachy.
ColonelMolotov
Member
posted 04-26-12 03:19 AM EDT (US)     195 / 212       
Just attaching propellers to the nodes is actually what we did in the current version of A Wrong Turn, but they are static and really don't look very convincing... The trouble is, how do you get them to spin ?

Since my last post, I made substancial progress in animation, I managed to animate different nodes simultaneously, and got the propellors nodes to spin, but infortunately, that is not the end of the issues. It seems the spinning animations are terribly disformed when exported in .bha files. Everything spins just fine in 3DS, but i gets all weird when I look at it in game. If I uploaded the 3DS files and the source code for the unit in game, could someone please take a look at it ? I am swamped in bug fixing and really can't figure out what causes this animation to go south like that.
VelvetClaw
Member
posted 04-27-12 06:30 AM EDT (US)     196 / 212       
Finally fixed it!



Chance spam from a Team Fortress 2 site provided me with the stuff I wasn't getting on to. So we've fixed our modelling blues...for now.

Alright, I tried Uthum's suggestion...and ended up with the same problem, again. I noticed however, that when I exported it, the number of vertices in the exported model suddenly increased, and I think this is the problem I am facing...does anyone have any idea what I can do to prevent it?

This is our progress so far:



As you can see, the model is now finished. We created a model containing three nodes for bones, mainly "root"; "galley_body" and "arrow_node", the latter serving as where arrows come out.
Vertex-link settings are set to "Rigid" with "no blending".

We then proceed to import a phy file, as specified in the YouTube tutorials:

[Image URL not allowed: http:-images.myspacecdn.com/images02/153/e059d69a3b5d4e919ffb8f22be7055ca/l.jpg]

Here's when the problem begins. Because the Churchill and the fusta have a different number of nodes, it is impossible to use the specifications of the physique file.

Attempting to soldier on merely crashes 3ds Max:



This really stinks. I can't believe that I've been whacking my head at this problem for 3 weeks without a single solution being found. I mean, look at it this way. It has NO moving parts. It is a simple, 400-500-poly model, with hardly any intricate design added to it. Even your pet hamster could build a craft this simple without any forethought, give or take a few weeks. So what is it that's preventing it from actually functioning and looking the way it's supposed to be? I've been following Wadis10's tutorials, but I discovered that there are just too many inconsistencies in it to be actually useful to anyone not building anything other than modern vehicles.

[img]http://vignette3.wikia.nocookie.net/interbellum/images/6/60/AXP_banner.png/revision/latest?cb=20150328191407[/img] [img]http://vignette2.wikia.nocookie.net/ronriseofkings/images/d/d6/Rkc_banner.png[/img] [img]http://vignette2.wikia.nocookie.net/kingsandconquerors/images/0/09/KChe_Banner_roma.png[/img]

[This message has been edited by VelvetClaw (edited 04-29-2012 @ 10:24 AM).]

VelvetClaw
Member
posted 04-29-12 09:09 AM EDT (US)     197 / 212       
Hello,

I noticed that although my model looks great, there are still some problems:

- Firstly, I realised that it's a very big model, that dwarfs many ships.
- Secondly, I haven't been able to make it fire from the front, as opposed from the side. I have made a galley in Thrones and Patriots fire its missiles from the bow, as opposed from the sides, but it's not working. Any ideas?
- The sails are one-sided, so as a result, the inside of the sails are transparent. If anyone can tell me what needs to be done to fix it' I'd appreciate it greatly.
- Lastly, the death animation is screwy. I suspect it's due to its size, but if anyone can give me any pointers on how to fix it, please let me known.

[img]http://vignette3.wikia.nocookie.net/interbellum/images/6/60/AXP_banner.png/revision/latest?cb=20150328191407[/img] [img]http://vignette2.wikia.nocookie.net/ronriseofkings/images/d/d6/Rkc_banner.png[/img] [img]http://vignette2.wikia.nocookie.net/kingsandconquerors/images/0/09/KChe_Banner_roma.png[/img]

[This message has been edited by VelvetClaw (edited 04-29-2012 @ 10:28 AM).]

ColonelMolotov
Member
posted 04-29-12 05:22 PM EDT (US)     198 / 212       
Regarding the size, just play around with the "scale" value in unitgraphics, and you will be able to tune it down as needed. Secondly, ships firing from the front and side can be dealt with flags in unitrules, just remove the "z" one and you should be good.
For the sails, I had the same issue, you should fix that directly in 3ds max, make sure you create them with a real 3D mesh, not, for exemple, a plane. Lastly, the default death animation is not suited for custom ships, you should create your own. I have, if you'd like I will send you the file.
VelvetClaw
Member
posted 04-29-12 06:38 PM EDT (US)     199 / 212       
Hello,

For the sails, must it be a two-sided mesh? also yes, please do send me a copy of your custom death animation.

There is something else I had to ask.

How do you get parts to disappear from units as they die? for my models, I was thinking of having the masts and the oars disappear from the ship before sinking/capsizing.

I will try to cut this model down to size. It needs to be at least a third smaller than what it is right now

[img]http://vignette3.wikia.nocookie.net/interbellum/images/6/60/AXP_banner.png/revision/latest?cb=20150328191407[/img] [img]http://vignette2.wikia.nocookie.net/ronriseofkings/images/d/d6/Rkc_banner.png[/img] [img]http://vignette2.wikia.nocookie.net/kingsandconquerors/images/0/09/KChe_Banner_roma.png[/img]

[This message has been edited by VelvetClaw (edited 04-29-2012 @ 06:46 PM).]

ColonelMolotov
Member
posted 04-30-12 04:08 AM EDT (US)     200 / 212       
Actually, now that I think about it, I think you already downloaded the custom death animation... just browse the "art" folder of A Wrong Turn, it's called croiseur_coule.bha
This should be faster than me sending you the file, because my internet access is really sucky right now.

Other questions : yes, the sails should two-sided, otherwise it won't work properly. Regarding disappearing parts, I think you would have to do that with animations, making some nodes go "under the surface of the map" in the blink of an eye, to give the impression they are disappearing. I never tried it, though, so I can't guarantee the result. It might end up looking weird !
« Previous Page  1 ··· 6 7 8 9  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Rise of Nations Heaven | HeavenGames