You must be logged in to post messages.
Please login or register

RoN Tech Support
Moderated by alincarpetman

Hop to:    
Welcome! You are not logged in. Please Login or Register.618 replies, Sticky
Rise of Nations Heaven » Forums » RoN Tech Support » Report Bugs here so they get fixed!
Topic Subject:Report Bugs here so they get fixed!
« Previous Page  1 ··· 7 8 9 10 11 ··· 20 ··· 25  Next Page »
posted 05-21-03 02:25 PM EDT (US)         
I've noticed people complaining about not being able to play Rise of Nations because of bugs, patch problems... etc.

So... here's what the community can do to help BHG solve these issues and get them fixed.

1. Give a brief description of the problem. For example:
Game doesn't patch.

2. Give a detailed system analysis of you computer specs. To make this easier for people to find out what they have, go here and download the Belarc Advisor at and/or just browse through your Device Manager.
For example:
1.8MGz Intel Pentium 4 (Win XP Pro. SP1 build 2600)
Dell OptiPlex GX240 MB with BIOS A03 03/01/2002
40GB Hard Drive with 21.85GB Free Space.
NVIDIA GeForce4 Ti4400 with driver 03/20/2003
(Optional) Cable Modem w/Firewall... etc.
Rise of Nations retail (English version) build
No mods, no cracks, no trainers... etc.

3. Give a more detailed description of the problem. For example:
When updating the patch through GameSpy, it will download 100% then bring me back to desktop and patch RoN until it reaches 37%, then it will stop and give me an "Invalid Patch File Error" and a "Retcode positive - 32769". I have the English version of the game.

4. Give reproduction steps on how to make it happen again. For example:
1. Launch the game.
2. Go to Multiplayer Game.
3. Go to GameSpy Internet Matchmaking.
4. Click "OK" when it says to upgrade to version
5. When the download is complete, log into GameSpy with your password.
6. Observe the game going to desktop and stopping at 37% during the patch process.

5. If it's a multiplayer game, be sure to specify if it was through GameSpy Arcade, GameSpy Internal, or LAN/IP. Then list the settings for the Multiplayer game. For example:
Teams of 3
Great Lakes
Large (5/6 player)
No Cannon Time
End Age: Gunpowder Age
Elimination: Conquest
Victory: Conquest
Tournament Play enabled.
3 Humans vs. 3 Computers (Moderate, Moderate, and Tough)
Nations in the game were:
Aztecs, Mongols, Chinese, Chinese, Egyptians, and Russians.

6. If it's a single player Quick Battle game, list the same steps as in #5. If it's a Conquer the World Single Player Campaign... list:
1. What your Nation is.
2. What difficulty setting you have.
3. What Age it was in.
4. What country you were attacking, and what battle type it was.
5. What build you're in... and what build you started your Campaign in. For instance, the retail is, and the patch is Did you start a campaign in the retail version and save the campaign... and then upgrade to the patch and load the campaign?

If you see your bug listed here already from someone else, just give your #2. Computer Specs.

[This message has been edited by Scrubs (edited 05-21-2003 @ 05:29 PM).]

posted 06-18-03 01:12 AM EDT (US)     201 / 618       
After a 2 patch I've got much more lag. It is now unplayable. Befor the patch there was no problem. Yes I reinstall the game 3 times.Yes I have the latest drivers. I disabled my networkcard, internet sharing.I've got 60-80 FPS in game. The gamespy chat is laggy too.
My specs:
XP 1800+,Gef 4200 Ti,512MB ram
ISDN 112k
posted 06-18-03 09:03 PM EDT (US)     202 / 618       
I have the same problem!!!

Member posted 05-22-03 12:50 PM EDT (US) 11 / 201
-----------------------------------------------------------I cant even play the game at all. It locks up between 30 seconds and about two minutes once started.
I am running DX9a and the latest Cat drivers(3.4) from ATi.
I have tried disabling sound acceleration and running with 16 bit colors with no luck. I have also follwed some other suggestions posted by others on this board. No luck whatsoever. I have uninstalled the game and ran a scandisk and Diskeeper on my hardrive and then reinstalled the game. Still the issues persists. Its a home built system.
Here are the specs.
Home Built
AthlonXP 2000 (Win XP Pro. Sp1 build 2600)
512MB Ram.
80GB WD Caviar SE with 68GB free.
Asus A7N8X Mobo (Nforce II Chipset).
ATi Radeon 9500pro 128Mb (Cat 3.4)
DX9A Installed.
Antec Case (430 Watt PSU)
Rise of Nations retail (English Version)
No mods,cracks or trainers.

I have not updated my chipset drivers yet even though there not that old. I read a post by someone saying that fixed there issues. I am in the process of doing that now. Any suggestions would be appreciated?
and I have this computer
PIII 1000
256mb ram
40gb HD
What can be this

posted 06-19-03 12:30 PM EDT (US)     203 / 618       
The only problem I am having is the shoreline grahics. Instead of the waves I see in the screen shots, I see white blocks. I have a installed patch 2 already (which fixed the ctw crash). my video chipset is SIS 650 and it is on board video, don't know if that is the problem, but if everything else works fine...


posted 06-19-03 02:21 PM EDT (US)     204 / 618       
Hi All,

I have been trying for the past 3 weeks to be able to play a complete game and been unsuccessful. I have not been able to play a quick game or the campaign based game.

I have been reviewing any and all tech support postings on this site and a couple of others. The game installs fine, starts up fine, but anywhere from 5 to 15 minutes into the game is locks up the entire system and I have to hard boot.

I regularly play Medal of Honor, Allied Assault and Spearhead, Age of Mythology, Microsoft's Rallysport, Soldier of Fortune II, and any other game that catches my eye. They all run fine, without any issues whatsoever.

I currently use a Athlon XP 2100, 1Gig Samsung (non-generic) RAM, no overclocking anywhere in the system, 400watt PS, more than adequate cooling in an aluminum case, a ATI Radeon 9700 Pro (retail) video card, Creative Labs Audigy 2 Platinum sound card (retail). I have 2 Western Digital 80GB hard drives hooked to a Promise PCI Raid controller in a Raid 0 config. No cracks, mods, anything. Just a straight retail copy of RON with patches.

I am running Windows XP Pro, SP1, Direct X 9.0a, I have tried 3 different versions of drivers for the Audigy 2, including the recently released Beta drivers. I have updated to Via4 drivers to the latest version for the support chipsets. I have tried two different versions of video drivers for the ATI Radeon 9700 Pro. I have installed both patches for the game, including uninstalling and reinstalling the game and then patching. I have tried the game with the no sound switch in the shortcut, disabled sound acceleration in the Direct X settings, set the memory parameters according to the tech documents, skipped the intro movies, and basically everything recommended on this site and the game simply does not give me more than 5-15 minutes. I have tried the recommendations on Microsoft's site regarding the Audigy splash screens and ATI Radeon cards.

I am a network engineer by profession and have literally supported several thousand desktops, OS's, accessories, servers over the years and I can't get this $50 game to work. I have read statements from people telling others that their power supplies aren't big enough, or cooling isn't adequate and other dubious advice. This is frustrating.

I can sympathize with BH Games programmers, as I am sure it is difficult to be compatible with all systems and hardware, but I must say that in 20 years of gaming I have never run across a game that I couldn't get to run and play ... until now. There seems to be an awful lot of people out there with the same issue. To those of you who say that these people must have something wrong with their pc's or have substandard equipment I would say you don't have enough understanding of systems to make those statements. Most of the people having problems have mid to high end systems.

The thing I guess that really torques me is that I just got done reading about the upcoming public beta of Patch 3 and not a word mentioned about the issues the rest of us loyal purchasers (especially those of us who have spents 20 or more hours troubleshooting this problem) are having - aka - not being able to complete a full game without a crash. I mean, come on, do you think we could get a patch so we can actually play the game before you worry about enhancing the product? I would like to see it enhanced so I can play!

I have never bothered to publicly post on any of the computer boards, except regarding business level networking issues, but this has got me very frustrated. Also, how about a little more interaction on this board with the BG personnel.

posted 06-20-03 01:47 PM EDT (US)     205 / 618       
Lucky guys who can return the game because it's nothing more than a VERY BAD beta version....

In Holland you just can't return them (or within 24 hours), because they think you might have coppied it... LIKE I WOULD WANT TO COPY THIS !!

say bye bye to you 49,95 euro's...

damn mickeysoft....

posted 06-20-03 04:21 PM EDT (US)     206 / 618       
I totally concur with Bilbo.

I too am in the software industry and this game is a first.

The following ganmes run fine on my system: MVP Baseball 2003, NHL 2003, NeverWinter Nights, Command and Conquer Generals, Empire Earth and others.

Why aren't the BH people responding to those folks who cannot even play a single game?

posted 06-20-03 07:00 PM EDT (US)     207 / 618       
Here's one unmentioned here before: I can't save a game.

Not CTW, not quick. The UI goes through all the steps, accepting my file name and so on, but never actually writes the data to the hard drive. Attempts to load show no file to load. CTW has no campaign to continue. Find finds no .sav files belonging to RON on any drive.

Running W98SE, P4 1.6 GHz on an Intel Mobo, 512 Mb DDR, yada yada - a solid midrange system; no hardware on the known problems list, latest drivers, DX9.0a, etc.

I've uninstalled and reinstalled multiple times and patched. Installed to the default directory and my own choice. Installed and run w/o McAfee A/V. Disabled write-behind caching. Run and installed with nothing in the background but Explorer and Systray. Increased swapfile to 1 Gb. Reinstalled the OS. I've done everything I can think of from over 20 years of PC repair, 5 years of game beta testing (for IM - remember them? ) and so on.

In short - I'm stumped! Hello, BHG? Don't make me come to Hunt Valley, now!

posted 06-20-03 09:58 PM EDT (US)     208 / 618       
1. Game crashes with CTW and game crashes after a while in single player quick battles

2. Intel pentium 4 1.7 Ghz
512 MB RAM

Video card is
ATI Technologies
Rage 128 Pro Ultra

Version Number is:
Unpublished Work Prerelease software
I played against Graham Somers at E3 2003, and he beat me soundly. However, he did reward me with this full version...

3. The CTW problem will let me choose a race, but it will crash sometime in the loading screen, my computer does not give me a reason why.

The single player quick battle bug happens at variable instances, but the time it takes to do two age upgrades is usually around the time the game crashes. The actual crash is the game completely freezing up, not letting me even access the desktop. My only solution is to reboot the computer.

To get past the freezing and actually complete a game, I have been resorting to saving the game every time I make advance an age, and quitting out of the game, restarting the game, and loading the quick battle...cumbersome, to say the least...

posted 06-21-03 10:30 PM EDT (US)     209 / 618       
Athlon XP 1600+
FIC FN11 Mobo
512 2100 ddr ram
40 gig hdd
lite-on cd-rom
Winfast Ti4400 GF4

The game freezes up when I try to quit.

posted 06-22-03 10:47 AM EDT (US)     210 / 618       
Im having the same problem as well.. Error "Microsoft Visual C++ runtime library runtime error! abnormal program termination "

So far I havnt read any solutions/patches to the problem. I wont bother including PC specs as it seems to be a common problem no matter what sort of system/operating system people are using.

Whitey Smalls
posted 06-22-03 12:01 PM EDT (US)     211 / 618       

My PC is multi-boot WinME/WinXP PRO. I can play the game fine using WinME.
The game will not start when I use XP Pro: Clean install of WinXP Pro with SP1 and DirectX 9.0a.
It gets up to 'Drawing Mini Map' and will do any of the following: Hang (unresponsive keyboard/mouse), reboot, corrupt video.
This behavior is the same regardless of patch2.
I have set ForceLowCPUBackgroundVid=1, which had no effect.
Have upgraded MOBO drivers to latest Hyperion 4-in-1 from
Have upgraded ATI drivers to catalyst 3.4 (which cause a crash on ME, have to use 3.2 there).

My PC is an HP Pavilion 8785C: Belarc reports (edited for what I consider relevant)--

1000 megahertz Intel Pentium III
32 kilobyte primary memory cache
256 kilobyte secondary memory cache
Board: ASUSTeK Computer INC. PEGASUS REV 1.xx (Apollo Pro 133)
Bus Clock: 133 megahertz
BIOS: Award Software, Inc. 2.00 07/26/2000

IDE-CD R/RW 8x4x32 [CD-ROM drive]

384 Megabytes Installed Memory
Slot 'DIMM 1' has 128 MB
Slot 'DIMM 2' has 256 MB
Slot 'DIMM 3' is Empty

RADEON 9600 PRO [Display adapter] (Catalyst 3.4)
Philips PSC706 Audio (1.89 WDM driver)

Standard Floppy Disk Controller
Primary IDE controller (dual fifo)
Secondary IDE controller (dual fifo)
VIA Bus Master PCI IDE Controller
VIA Tech 3038 PCI to USB Universal Host Controller

If there is anything more needed to diagnose/troubleshoot my problem please let me know.
Thanks for your help!

posted 06-22-03 07:54 PM EDT (US)     212 / 618       
OK, I'm about to give up. I've read through all the "fixes" and done them all, yet none seem to work.

Here are my computer specs:
Operating System System Model
Windows XP Home Edition (build 2600) Dell Computer Corporation Dimension 4550

Processor a Main Circuit Board b
2000 megahertz Intel Pentium 4
8 kilobyte primary memory cache
512 kilobyte secondary memory cache Board: Dell Computer Corp.
Bus Clock: 400 megahertz
BIOS: Dell Computer Corporation A01 09/17/2002
Drives Memory Modules c,d
39.99 Gigabytes Usable Hard Drive Capacity
30.47 Gigabytes Hard Drive Free Space

3.5" format removeable media [Floppy drive]

MAXTOR 6L040J2 [Hard drive] (40.03 GB) -- drive 0 256 Megabytes Installed Memory

Slot 'DIMM_A' has 256 MB
Slot 'DIMM_B' is Empty
Local Drive Volumes
Controllers Display Standard floppy disk controller
Intel(R) 82801DB Ultra ATA Storage Controller - 24CB
Primary IDE Channel [Controller]
Secondary IDE Channel [Controller] 32MB ATI Rage 128 Ultra [Display adapter]
Dell E151FPp [Monitor] (14.9"vis, s/n 6R64429UC16W, October 2002)

c: (on drive 0) 39.99 GB 30.47 GB free

Big Huge Games, Inc. - Rise of Nations Version

Problem Description:
Everything works fine up until CTW map loading. Immediately kicked to desktop with no error listed.

Iíve tried many recommended fixes, such as: Disabling the movie in rise2.ini
Installing patch 2
Clean Boot
Adjusted 32 bit and 16 bit, blah, blah, blah.

No Luck.

About ready to return the game, unfortunate because I did spend some time playing the tutorial and enjoyed it.

Thanks for any help.

Whitey Smalls
posted 06-22-03 08:21 PM EDT (US)     213 / 618       

What video driver version are you using for your ATI? The game crashes to desktop for me when I use Catalyst 3.4. I had to downgrade to 3.2 to be able to play. Perhaps you could try that? How do you have your swap file settings configured, Windows managed or fixed size?

posted 06-22-03 09:23 PM EDT (US)     214 / 618       
Not quite sure how to check on video driver version. Updated it after I had the problem with RoN. Date on most recent driver was 1/10/2002 and version was

When I was working on tutorials, after about an hour and a half I ran out of swap space. Upped it to the max of 768 Mb.


the grinch
posted 06-23-03 07:03 AM EDT (US)     215 / 618       
ERROR-Conquer the World- "gathering exception data"

I have reported this problem in the forum but am also doing it here just in case. Tutorials and quick battle work fine but when i select CTW campaign and chose my nation and get it to start loading the game crashes and the gathering exception data comes up and tells me to send problem to microsoft. I have seen loads of people with this problem. Do any of the BHG guys have a solution? Does it have anything to do with gamespy or direct X. After the game crashes i open up my dirext x diagnosis programme and the whole computer crashes.

My system- 5
33mhz pentium 3
Ati rage fury with latest drivers -(last driver made in october 2001)
128mb ram
windows 98

posted 06-23-03 09:10 AM EDT (US)     216 / 618       
i found little bug.
i build my second city, then i see that a ruin is just near my city, i get a new villager and put the waypoint just on the ruin. then my villager goes on the ruin but doesn't take it, i have to bring him off the ruin and then take it :|

recorded game:

posted 06-23-03 11:59 AM EDT (US)     217 / 618       
Hey all. Some quick notes:

Bilbo - there is an update on AMD's website that fixes a problem with AGP that can cause random lockups in our game. Several RoN users have had success with the patch. You can obtain it at:,,30_118_756_759^871^2367,00.html\
Hopefully it might help you out.

Everyone with older ATI cards that are crashing in CTW:
We have reproduced this problem and are looking into software/hardware fixes and workarounds. Something you can try, but I can't guarantee: try to find the latest motherboard AGP drivers for your computer and give them a try. In some cases DX9 reports an inability to use AGP texturing, which causes the older ATI cards to not support some actions we perform for CTW. Upgrading/installing correct AGP motherboard drivers will correct the problem for DX9, and sometimes the ATI drivers as well. I can't claim 100% success rate, but worth a shot in the meantime. If you try this and it does work, please post and let us know. You can tell if you have this problem by checking Start->Settings->Control Panel->DirectX->DXDiag and checking the 'display' tab. At the bottom will be several sections with buttons allowing you to Enable/Disable several graphics features. If 'AGP Texturing Acceleration' is listed as 'disabled' with no ability to enable it, a motherboard driver upgrade may help you out.

And again, please post if any of the above work for you. We are listening, and you're feedback is extremely helpful in getting everyone up and playing!


Big Huge Games
posted 06-23-03 01:39 PM EDT (US)     218 / 618       
The game is unplayable - in any game mode, SP or MP. The game will crash in 5-10 minutes from the start of the gameplay - always. It'll just lock up and a constant "beeee" sound leaves ringing, no error messages whatsoever.

Cold boot is the only way out. I have not encountered any similar problems with my setup. Every other game works flawlessly. This is just an example of bad coding. Maybe a segfault or a memory leak on certain systems, go figure.

If I were to decide, BHG should look into this immediately or their reputation will drop dramatically.

AMD Athlon XP 1700+
Soltek SL 75 KAV motherboard
Radeon 9500 pro 128mt
SB Live! Value
512mt PC133 memory (two spectek 128mb and one 256mb)
(and yes I've tried running it with a single 256mb module).
Maxtor D540X 80gb harddrive

Catalyst 3.4 drivers
SB Live! Drivers 5.12.0001.0252
DirectX 9.0a
Win2000pro with all relevant updates

I've tried all things imaginable, lowering the HW acceleration levels, -sw3dsound switch etc. Nothing works.

Please repair the game. It is very badly broken. I wonder why did you release a game that just does not work.

posted 06-23-03 04:49 PM EDT (US)     219 / 618       
Hi All,

I appreciate the link, Bfreitag, but it is dead. I do know the registry hack you are referring to for the AGP settings in Windows 2000 Pro, Windows 2000 Server, and Advanced Server. However, it does not apply to Windows XP Pro, which is what I am running. I had actually created a restore point and installed the AGP patch for AMD a few weeks ago and then uninstalled when it didn't fix anything, just to see what would happen.

I did want to share an interesting thing that happened. As you know from reading my prior post I lock up every time I play. Before the 2nd patch I would lockup from about 5-15 mins and the whole machine would screech and I would have to powercycle. After applying the 2nd service pack I would crash after about 3-5 minutes (every time) but now I would crash to the desktop, as opposed to staying in the program and crashing. Again, I would have to powercycle.

I noticed another user mention that he couldn't get the RoN running without crashing to the desktop under Catalyst drivers 3.40, which I was running, and he backreved to 3.20 and said he could run now without crashing. So I took an older set of drivers, 2.30 (not a typo) and played for 18 mins this morning before crashing (but not to the desktop). I am going to go back and try the 3.20 drives and see what I get.

If anyone else has any input on this I would love to hear it.


posted 06-23-03 04:52 PM EDT (US)     220 / 618       
I had a crash problem where RoN would crash between 3-60 minutes in every game while the mouse cursor still moved and the music still played. My specs are:

P4 2.8c
Radeon 9700 Pro
Creative Labs Soundblaster Audigy

All the latest drivers, etc., installed.

At first I thought it was a RoN specific problem as all other games I played did not crash (Medieval: Total War, Disciples 2, Galactic Civilizations, etc.). But when I recently tried to play Neverwinter Nights with the new expansion it also crashed consistantly, after 20-30 seconds (like Old Faithful) - made it easy to test.

Anyway, eventually I determined that the problem was my ATI Radeon 9700 Pro card, but this problem didn't manifest itself in my old computer because my old MB didn't support 8X AGP. Seems there is a problem with older revision ATI Radeon 9700 Pro cards (I had revision 11).. ATI will actually accept returns of these and replace them with a newer revision card. They have problems operating in some of the newer motherboards that support the 8X AGP. I just set my AGP to 4x and it works fine now.

I know there was at least one other person with a newer MB and CPU that had a Radeon 9700 Pro, that could have been the problem there too.

PS - catalyst 3.5 is out now also =)

[This message has been edited by Darkhosis (edited 06-23-2003 @ 04:56 PM).]

posted 06-23-03 09:33 PM EDT (US)     221 / 618       

'AGP Texturing Acceleration' is listed as 'enabled'. Just to let you know.

I'm going to give it some more time but don't want to blow $50. I assume I have 30 days to return the software - at least according to Microsoft.

"Microsoft North American Retail Product Returns
All North American retail Microsoft software comes with a 30-day, money back guarantee. Retail products can most easily be returned through the retailer where the product was purchased or directly to Microsoft. "

posted 06-24-03 01:46 AM EDT (US)     222 / 618       
MP bugs

Player 1
P4-2.66 Win XP Pro DX9a, 1GB Dual Channel Ram
Intel 865PERLL, Raid 2-SATA 160G Seagate
Leadtek GForce 5200 128mb
On board sound

Player 2
P3-800 Win XP Pro DX9a, 512 Ram
Intel 815EEA. 60G seagate
WinFast A340 TDH, 128mb
on board sound

Bugs List
Player 1
Quit to win, and Quit to restart often
Have tried uninstall, reinstall, restart, everything..
Happens randomly but consistantly, except one saved game which crashes all the time(tell me how to upload that file to you)
Crash in MP with Player 2 over internet.. cannot log back in after session(even after restart machine, and game).

Player 2
Quit to Win, and Quit to restart sometimes.
Tried everyting(adjust sound card setting, graphic setting..etc).
Get (Player disconnect "ungracefully" from Player 1)..
Wait screen comes up, and cannot restart game with Player 1

Wish List
Must have save game for MP games.
Fix for these randam quit problem

posted 06-24-03 05:55 PM EDT (US)     223 / 618       
Out of sync for us too. We are totally vanilla for mods. Straight game with patch 2 only. Meet or exceed all requirements to include direct x 9.a. Also we experienced the dropped games via the Internet 3 out of 4 times and we felt that we would suffer along until the sadly overlooked multiplayer save option materialized. But we had a LAN party this weekend and the same out of sync or "waiting for player" error occured--OVER THE LAN. I have a switch that manages data and throughput well, yet still the errors persist. I think the developers may not realize that the save option also takes the bite out of dropped games because then one can retrieve and continue a game from that point. The pain of a lost game and the lost time is significantly reduced with the save option. As I'm typing this I see in my search topics on the Internet numerous cries for resolution on this multiplayer save issue and the out of sync or player dropped errors. When can we expect a solution?
Ace Argon

posted 06-26-03 11:58 AM EDT (US)     224 / 618       
I will make a scenario (only changing unit attributes, no triggers), and it will play just fine until i save and load. Then all the changes i made are set back to default.

Also a lot of my unit graphics are mixed up. I will have horses instead of trucks,supply TRUCKS come out as wagons, and my citizens are stuck in the ancient age. I didn't have any problems with the tutorials or CTW (as far as graphics) and if i play from the ancient age on forward in a quick battle without saving and loading then the graphics work also.

AMD Athlon 1 ghz
Nvidia Geforce2 Ultra
512 mb Ram
Turtle Beach Santa Cruz Sound Card
30gb HD 3.5gb free
(all the latest drivers)

posted 06-26-03 08:32 PM EDT (US)     225 / 618       
I don't know whether this has been mentioned or not.. but please fix the game so that pressing "Alt+tab" during multiplayer doesn't disconnect me from the game.. This happens most of the time when I play MP. I have to alt+tab sometimes, and its annoying to see that my 45 minutes of game play has been a waste after it kicks me out.
« Previous Page  1 ··· 7 8 9 10 11 ··· 20 ··· 25  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Rise of Nations Heaven | HeavenGames