You must be logged in to post messages.
Please login or register

RoN Tech Support
Moderated by alincarpetman

Hop to:    
Welcome! You are not logged in. Please Login or Register.618 replies, Sticky
Rise of Nations Heaven » Forums » RoN Tech Support » Report Bugs here so they get fixed!
Topic Subject:Report Bugs here so they get fixed!
« Previous Page  1 ··· 10 11 12 13 14 ··· 20 ··· 25  Next Page »
posted 05-21-03 02:25 PM EDT (US)         
I've noticed people complaining about not being able to play Rise of Nations because of bugs, patch problems... etc.

So... here's what the community can do to help BHG solve these issues and get them fixed.

1. Give a brief description of the problem. For example:
Game doesn't patch.

2. Give a detailed system analysis of you computer specs. To make this easier for people to find out what they have, go here and download the Belarc Advisor at and/or just browse through your Device Manager.
For example:
1.8MGz Intel Pentium 4 (Win XP Pro. SP1 build 2600)
Dell OptiPlex GX240 MB with BIOS A03 03/01/2002
40GB Hard Drive with 21.85GB Free Space.
NVIDIA GeForce4 Ti4400 with driver 03/20/2003
(Optional) Cable Modem w/Firewall... etc.
Rise of Nations retail (English version) build
No mods, no cracks, no trainers... etc.

3. Give a more detailed description of the problem. For example:
When updating the patch through GameSpy, it will download 100% then bring me back to desktop and patch RoN until it reaches 37%, then it will stop and give me an "Invalid Patch File Error" and a "Retcode positive - 32769". I have the English version of the game.

4. Give reproduction steps on how to make it happen again. For example:
1. Launch the game.
2. Go to Multiplayer Game.
3. Go to GameSpy Internet Matchmaking.
4. Click "OK" when it says to upgrade to version
5. When the download is complete, log into GameSpy with your password.
6. Observe the game going to desktop and stopping at 37% during the patch process.

5. If it's a multiplayer game, be sure to specify if it was through GameSpy Arcade, GameSpy Internal, or LAN/IP. Then list the settings for the Multiplayer game. For example:
Teams of 3
Great Lakes
Large (5/6 player)
No Cannon Time
End Age: Gunpowder Age
Elimination: Conquest
Victory: Conquest
Tournament Play enabled.
3 Humans vs. 3 Computers (Moderate, Moderate, and Tough)
Nations in the game were:
Aztecs, Mongols, Chinese, Chinese, Egyptians, and Russians.

6. If it's a single player Quick Battle game, list the same steps as in #5. If it's a Conquer the World Single Player Campaign... list:
1. What your Nation is.
2. What difficulty setting you have.
3. What Age it was in.
4. What country you were attacking, and what battle type it was.
5. What build you're in... and what build you started your Campaign in. For instance, the retail is, and the patch is Did you start a campaign in the retail version and save the campaign... and then upgrade to the patch and load the campaign?

If you see your bug listed here already from someone else, just give your #2. Computer Specs.

[This message has been edited by Scrubs (edited 05-21-2003 @ 05:29 PM).]

posted 08-02-03 11:44 AM EDT (US)     276 / 618       
everything works perfectly in the game until ranomly It crashes to desktop. This might be anything from 1 minute into the game upto an hour.

My system is

AMD Athlon XP1700+
ABIT K7V333 motherboard
Onboard c-media
Win XP Pro
MSI Geforce4 Ti 4200 (128M)with driver 20/03/2003
512MB ram
80GB hard drive (over 60 free)
Rise of Nations retail (English version)
No mods, no cracks, no trainers... etc.

PS It crashes in all the tutorials too - in fact whatever option you go into
I absolutely love the game when its working but this is too big a pain to live with - please help!

[This message has been edited by mn8 (edited 08-02-2003 @ 12:49 PM).]

posted 08-04-03 10:17 PM EDT (US)     277 / 618       
Crashes before CTW even starts, I believe this is a very common problem.

When I try CTW, I get all the way to the "loading" menu. Then it gives me a strange "Exception!" menu, finds the exception, and eventually crashes to the desktop.

There's no way I should have to be screwing around with my registry and stuff to fix this. I'm an average computer user, this should be de-bugged pronto.

Pentium III, 128 mb RAM
20 gig hardrive
ATI 128 Rage Pro (btw, try updating the drivers for this AFTER you upload Divx9.0...took me 2 hours to get it to work)

posted 08-08-03 11:06 AM EDT (US)     278 / 618       
ikell -

The crash in CTW with ATI Rage 128 cards is a known problem, and will be addressed in the upcoming patch 3. we should be opening up a public beta of the patch very soon.

There is one workaround you can try to get you going in the meantime. If you click on Start->Control Panel->DirectX then click "DXDiag", then the "Display tab", check the setting at the bottom for "AGP Texture Acceleration". If this is disabled, and won't let you click 'Enable', an update of your motherboard AGP drivers may fix the problem. Try to find the latest drivers for your motherboard and install them. This might 'Enable' your AGP, which will generally get the ATI to not crash on some operations we use for CTW.

If the above is not the case, or doesn't work, or you aren't comfortable installing new mobo drivers, just hold tight a little longer. We rewrote some CTW bits to use a different method that is much more Rage 128 'friendly' just for this case. You can try out the beta once it goes public and let us know if it fixes your problem.


[This message has been edited by bfreitag (edited 08-08-2003 @ 11:07 AM).]

posted 08-08-03 11:11 AM EDT (US)     279 / 618       
manzarra -

Have you messed with the Nvidia control panel overrides at all? We've noticed that cranking up your aniso filtering higher than 8x can really play havok with our texture offsets. If you have, set everything back to default and you should be ok. I've seen a similar report about newer Geforce problems, and the control panel settings were to blame.

If it works, please post so others can benefit as well.


[This message has been edited by bfreitag (edited 08-08-2003 @ 11:12 AM).]

posted 08-08-03 01:29 PM EDT (US)     280 / 618       
First off I'd like to say thanks a lot to BHG for making a game that looks like its going to be a lot of fun, I always liked the idea of Empire Earth, but that was lame compared to RON. Its also really nice to see BHG programmers reading these forums, thanks folks

Unfortunately, I haven't been able to finish a game of RON due to blue-screen crashes accompanied by horrible fuzzy stuttering sound, requiring a reboot of my PC. This happens in the tutorials, the quick battle and in CTW, usually around half an hour to an hour in. Haven't tried multiplayer yet.

I am using the retail version because I haven't had time to download the 8+Mb patch on my dialup yet. The two errors reported on blue screen refer to 'IRQ NOT LESS THAN OR EQUAL' and 'dxg.sys'. By disabling hardware sound by altering the RON shortcut, I get the dxg bluescreen instead of the IRQ one :-/

My system:

WinXP Pro 2600/un-service-packed
AthlonXP 2000+
Asus A7V333 motherboard
1Gb DDR @ 266MHz
Leadtek Geforce4 Ti4600 running 41.09 detonator
Soundblaster Audigy (not sure which driver)

This PC is nice and stable, runs ALL other games without a hitch with the exception of C&C generals, in which 'A Serious Error' occurs when it starts to really go off in multiplayer.

I am going to test my DDR with goldmem, and try downloading the patch this weekend.

PLEASE if anyone can help or has a solution I would love to hear it, because I know Rise Of Nations is gonna ROCK!



posted 08-08-03 02:43 PM EDT (US)     281 / 618       
"This video card is not supported for use with Rise of Nations." - said my computer.

So can someone fix this problem?

HG Alumnus
posted 08-11-03 01:07 PM EDT (US)     282 / 618       
Ravenfire_72 if you haven't solved your problem I have the same video card and here's what I had to do turn off Hydra Vision so that it doesn't run in back ground. Uninstall RoN and then reinstall leave Hydra Vision turned off That will take care of your freezing problem. It's the good news now the bad news if you turn it back on you'll have to uninstall and reinstall RoN after turned Hydra Vision off again

Have had the game just one day and had to reinstall it 3 times after using different fixes to make the game run Now the dang thing has a new problem of crashing when closing down Believe it or not I do tech support on two other Heavens Games sites

"I have met the enemy, he is us". Pogo
posted 08-14-03 03:49 AM EDT (US)     283 / 618       
I've recently bought the game but I still canīt play with it. When I try to play, there are two animations and after that the game brings me back to the desktop with this message:
"Graphics services failed to initialize. Please make sure that your video card and drivers are correctly installed, and are compatible with Rise of Nations."

My system is:
- QDI Kudoz k7 1,6 GHZ
- Graphics Card: Hercules 3D Prophet 4500 64 Mb
- Windows 2000 Pro
- 512 Mb DDR

I've downloaded the latest drivers for my card and also installed the latest version of DirectX and still doesn't work.

What else can I do? Could you please help me?

Thanx a lot

posted 08-14-03 07:29 AM EDT (US)     284 / 618       
I cant run a conquer the World campain either. I click new campain,choose culture and difficulty, then the loading screen comes up (where it shows special units etc)and i'm back on the desktop. Sometimes the computer makes a whinig noise, sometimes black comes from the top of the screen and expands to the bottom (then im back at windows main menu) but of course, when I click eventvwr, there is no error: nothing.
my system,
AMD Athlon 1600+XP
Windows XP home edition
Hercules 3d Prophet 32/64mb Tv- Out
SOund Blaster Live soundcard
I have updated my VIA chipset, my Bios, My Prophet driver, my Kyro driver and even my monitor driver. I have clean booted the pc, played with graphic acceleration, changed resolutions, disabled the soundcard and modem..... omg.
All these suggestions (given to me by microsoft) did not make the slightest bit of difference. I tested it on another computer.
dunno exactly but:
3ghz+ (AMD or Pentium sorry)
XP professional
geforce 5
To cut a long a story short it worked.
I have a funny feeling that even when patch 3 comes out my game won't work. Maybe its just that I have tryed so much. I will however try when the patch comes out.
BTW MIcfosoft tech support is kinda rubbish. THey dont threat your problem uniqulely.
posted 08-16-03 07:33 PM EDT (US)     285 / 618       
I bought a copy for my nephew to run on his families 'E-Machine'. The problem is that it minimizes itself at odd intervals. The game doesn't seize or freeze up, simply minimizes. Other than that, it runs well. I've updated the video drivers and turned the intro movies off but still no dice. I looked around the net for a bit but can't find anyone else having the same problem.

Any help would be appreciated.

posted 08-17-03 12:38 PM EDT (US)     286 / 618       
I have a similar 'problem' with age of mythology. It always occurs when I click on the top right of thescreen as if there was an invisble minimize button. Luckily u never have to click right in the very corner so i am ok. THis might not b ur problem though.
posted 08-18-03 05:37 PM EDT (US)     287 / 618       
Well my system is a:

K7 600 AmD Atlon
128 Mb ram
Geforce 2 MX 200
Windows XP
Sound Blaster Live!
No crack,Trainers,Etc...
and nothing more peculiar

The problem is i start to play and in 10 minutes 1 hour the game return to desktop, it happends more in campaing mode or internet play, in single mode it be more estable.

Without the 1.02 upgrade the version 1.0 the system said Gathering exception data, with this patch no error appear only go to desktop. The geforce drivers and patches are downloading.

posted 08-19-03 09:55 AM EDT (US)     288 / 618       
@ Draxsr

Are you sure you aren't inadvertently hitting the Windows key on the keyboard? That will "minimize" the game and put you back on the desktop.

posted 08-19-03 08:00 PM EDT (US)     289 / 618       

I wish it were something that simple, but no. That's not it. I am thinking of having him pick up a new keyboard, but if it's not doing it with other apps (that respond to alt-tabbing) a stuck key is out of the question too. I'd love to blame it on the AMD chip that the E-Machine has.

Thanks anyway.

posted 08-20-03 01:30 PM EDT (US)     290 / 618       
Hi, My computer restarts after a few minutes of playing and when it turns back on tells me the system has recovered from a serious error and that the two files the error report will contain are:



I can delete the first, it doesnt make a difference and the second is "unavailable." It is not due to overheating and I have tried re-installing the game.

My computer is a 2.17GHz AMD Athlon XP 3000+ with a GeForce 5900 Ultra video card so it should'nt even know anything is happening. Thanks for any help, Ben.

posted 08-20-03 03:34 PM EDT (US)     291 / 618       
Right im really annoyed at this. I have the CTW problems that so many people have and now I have another one...........
I play for 10 mins, 20, 3hrs whatever but eventually it will happen, my PC jams. I click cntrl alt delete and al of a sudden a message comes up :
Windows has recovered a fatal system error; please restart to restore full function or summin like that.
Im am now on a Desktop with a crappy screen size and 4bit colour resolution. I cant change it from the control panel I restart my PC and all is OK. Im really pissed of coz it always happens online 2.
posted 08-21-03 06:01 AM EDT (US)     292 / 618       
I got CTW to work with my Rage 128 card!

I have had the usual CTD problem as CTW initializes since I got the game. I have tried everthing I have read on this board to get it to work. Well, I saw a good price on a Radeon 9600 Pro and decided to give it a try. I installed it following directions to remove the old video driver before installing the Radeon. The Radeon was real flaky and I had random lockups even on the Win2000 desktop. Maybe an issue with the VIA chipset AGP drivers, but that is another story.

Anyway, I put the old Rage 128 back in after uninstalling all the Radeon drivers and installed the newest Rage driver package available from ATI: v3279 I think. I had installed this before but had just put it over the old driver. CTW now runs like a champ! It seems that uninstalling the old driver before installing the new one made all the difference. I made no other changes. I suppose the Radeon install might have made some change that did not get uninstalled, but that seems unlikely.

Real interested to hear if this works for anyone else.

posted 08-21-03 01:13 PM EDT (US)     293 / 618       
Can anybody help me? Whenever I try to play the conquere the world campaigne, it starts to load then closes itself and brings me to my desktop, any advice?

[This message has been edited by j082987 (edited 08-21-2003 @ 01:15 PM).]

posted 08-28-03 10:31 PM EDT (US)     294 / 618       
before postying this i found the registry "fix" at amd using these forumns, BUT it did not work so...

i9 have been having this problem often... I played the game fine on my
PIII - 450
Dell Optiplex GX1
Nvidia PNY Verto PCI 32MB
256 100MHZ Ram
40 gig drive western digital
WinXP Pro
Daewoo Monitor
but as soon as i get another computer
Athlon K7 650 MHZ Slot A
Biostar MKE626B motherboard
640 MB 100MHZ RAM
Nvidia Geforce2 GTS 64MB AGP
same harddrive as in other machine
same version of windows XP PRO
same monitor

now it freezes during startup
i get the movies fine
get to the screen that says RON and my cursor changes
and then a little later on that same screen it freezes and i have to reboot

tried the force movie thing in an old thread about this, where you basically disable the movies... and it goes straight to a black screen and freezes

i have the newest drivers from nvidia, I tried upping to directx9.0b normal 9.0 from the cd, tried all new drivers for everything, tried older video drivers, clocked the temperature... 95 degrees whats odd is i know the guy before me who owned this computer and he played all kinds of games so... in fact he played the RON trial all the time

oh also tried with no win updates and all the updates, no service pack 1, and with service pack 1, in fact i've tried all kinds of combinations, rise updates etc.... it's eventually caused errors after awhile each time i'm trying to fix it and then i have to format and reinstall... this sucks, i've played alot of games, alot of buggy games, but NOTHING like this... and given the circumstances sigh

i was halfway into the game on a CTW mission... now?? notin'


posted 08-28-03 11:12 PM EDT (US)     295 / 618       

so i thought hmmm lets try somethin different
so i tested directx9.0 and on a test of direct3d it started the test first screen, rotating dx cube, spun around around... and then it froze, but i couldnt tell if uit had anything to do with my mouse... then i tried again no mouse moving, still it froze, updated to directx9.0b, and boom it froze, so it HAS to be direct3d or my videocard, which i doubt its my videocard... any suggestions? other of course than emailing direct x, to which i will get no response but thatrs okay


posted 09-01-03 12:32 PM EDT (US)     296 / 618       
more of an update... so i did all my driver updattes for everything possible, windows uodates, directx, my card all of it, and i realized after upgrading that my system freezes even on windows screensavers that use 3d and it didnt do this till i upgraded... but my system did freeze on games in fact... anything that uses direct3d... so now i cant do anything involving direct3d with this system... i cant get support from microsoft for directx... i looked all over for a support link... i dont know if its my card or what anyone who can help please help
posted 09-02-03 11:41 AM EDT (US)     297 / 618       
I'm having a similar problem as daoneandonlybest.

Can play the game for a variable amount of time (sometimes an hour, sometimes five minutes). The game will then crash to desktop with an error saying "Windows has recovered form a serious error, please reboot to restore full functionality." Windows has defaulted to a lower resolution and 4-color display but RON is still running in the background.

Odd thing - this only happened once I updated to XP. I've updated the drivers (Nvidia Geforce 2 Go). Unfortunaletly, laptop video card drivers are slow to update.


1.02 Gz P3
Geforce 2 Go (32 megs)
256 megs of Ram
RON retail English version

I know there have been other topics about this. Just hoping for a fix.

posted 09-02-03 05:11 PM EDT (US)     298 / 618       
First off I would like to say that I have played this game extensively on my friends computer, and I think it's awesome. When I bought the retail version however, it doesn't run at all on my system. I know it is an older system but it meets the requirements and should still run.

850 megahertz Intel Pentium III (Windows ME, build 4.90.3000)
Asus CUW-AM/MEW-AM 2.05 with BIOS: Phoenix Technologies LTD 2.05 09/12/00
30.00 GB hard drive with 22.49 GB free
Intel(r) 82810E Graphics Controller [Display adapter]
Rise of Nations retail (English Version
no cheats, trainers, etc

The problem occurs when I start the game up with the CD in the drive. The intro plays (although it is only played on the lower left 1/4th of my screen) then the screen goes black and a error message appears; "Exception!- GAthering Exception Data...." this message stays on the screen for about a min then the microsoft error report pops up and asks me if I want to "Send Error Report" or "Don't Send." I can view all the technical error information being sent to Microsoft, if that would help solve the problem.

I know that many people have encountered the "Exception" Error, or had the game suddenly quit on them; but I haven't read of anyone else who can't even get into the main menu of the game.

I suspect that it is because I have an "810 Intel Chipset," but was wondering if it could be something else. Also if it is only because I have the 810 chipset; are there any plans to fix this problem? I can't return the game to the store now, and really don't want to because I would really love to be able to play it. Any help would be greatly appreciated.


posted 09-07-03 12:06 PM EDT (US)     299 / 618       
Scrubs? r u still working on the jamming problem?
posted 09-12-03 12:09 PM EDT (US)     300 / 618       
hello can u hear me?????????????????????????????????????????????????????????? ????????????????????????????????????????????????????????????? ????????????????????????????????????????????????????????????? ????????????????????????????????????????????????????????????? ????????????????????????????????????
« Previous Page  1 ··· 10 11 12 13 14 ··· 20 ··· 25  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Rise of Nations Heaven | HeavenGames