You must be logged in to post messages.
Please login or register

RoN Tech Support
Moderated by alincarpetman

Hop to:    
Welcome! You are not logged in. Please Login or Register.618 replies, Sticky
Rise of Nations Heaven » Forums » RoN Tech Support » Report Bugs here so they get fixed!
Topic Subject:Report Bugs here so they get fixed!
« Previous Page  1 ··· 10 ··· 17 18 19 20 21 ··· 25  Next Page »
posted 05-21-03 02:25 PM EDT (US)         
I've noticed people complaining about not being able to play Rise of Nations because of bugs, patch problems... etc.

So... here's what the community can do to help BHG solve these issues and get them fixed.

1. Give a brief description of the problem. For example:
Game doesn't patch.

2. Give a detailed system analysis of you computer specs. To make this easier for people to find out what they have, go here and download the Belarc Advisor at and/or just browse through your Device Manager.
For example:
1.8MGz Intel Pentium 4 (Win XP Pro. SP1 build 2600)
Dell OptiPlex GX240 MB with BIOS A03 03/01/2002
40GB Hard Drive with 21.85GB Free Space.
NVIDIA GeForce4 Ti4400 with driver 03/20/2003
(Optional) Cable Modem w/Firewall... etc.
Rise of Nations retail (English version) build
No mods, no cracks, no trainers... etc.

3. Give a more detailed description of the problem. For example:
When updating the patch through GameSpy, it will download 100% then bring me back to desktop and patch RoN until it reaches 37%, then it will stop and give me an "Invalid Patch File Error" and a "Retcode positive - 32769". I have the English version of the game.

4. Give reproduction steps on how to make it happen again. For example:
1. Launch the game.
2. Go to Multiplayer Game.
3. Go to GameSpy Internet Matchmaking.
4. Click "OK" when it says to upgrade to version
5. When the download is complete, log into GameSpy with your password.
6. Observe the game going to desktop and stopping at 37% during the patch process.

5. If it's a multiplayer game, be sure to specify if it was through GameSpy Arcade, GameSpy Internal, or LAN/IP. Then list the settings for the Multiplayer game. For example:
Teams of 3
Great Lakes
Large (5/6 player)
No Cannon Time
End Age: Gunpowder Age
Elimination: Conquest
Victory: Conquest
Tournament Play enabled.
3 Humans vs. 3 Computers (Moderate, Moderate, and Tough)
Nations in the game were:
Aztecs, Mongols, Chinese, Chinese, Egyptians, and Russians.

6. If it's a single player Quick Battle game, list the same steps as in #5. If it's a Conquer the World Single Player Campaign... list:
1. What your Nation is.
2. What difficulty setting you have.
3. What Age it was in.
4. What country you were attacking, and what battle type it was.
5. What build you're in... and what build you started your Campaign in. For instance, the retail is, and the patch is Did you start a campaign in the retail version and save the campaign... and then upgrade to the patch and load the campaign?

If you see your bug listed here already from someone else, just give your #2. Computer Specs.

[This message has been edited by Scrubs (edited 05-21-2003 @ 05:29 PM).]

Lord Wrath
posted 02-11-05 12:54 PM EDT (US)     451 / 618       
Hi All
I have been getting two erros that consistently occur with TAP. It occurs in multiplayer and single player mode.
Error 1 Game stops during map generation. Halts at Bounding Volume Init and just hangs. CPU goes to 100% and I nned to kill the process and re-boot. Happens in multiplayer and single player.

Error 2 When playing, as soon as I fire a nuke the game will freeze. No error message, just hangs up. Requires a kill and re-boot to clear.

My PC Config follows

Operating System System Model
Windows XP Professional Service Pack 2 (build 2600) HP Pavilion 04 D7211L-ABA 7905 50000RE101BORAB
System Serial Number: US20254545 NA020
Processor a Main Circuit Board b
1.60 gigahertz AMD Athlon XP
128 kilobyte primary memory cache
256 kilobyte secondary memory cache Board: Asus Tech A7M266-M 1.06
BIOS: Phoenix Technologies LTD 3.34 09/04/2002
Drives Memory Modules c,d
300.07 Gigabytes Usable Hard Drive Capacity
150.49 Gigabytes Hard Drive Free Space

FvF-Inc CDDVD-2003-200x SCSI CdRom Device [CD-ROM drive]
3.5" format removeable media [Floppy drive]

WDC WD1200BB-22CAA0 [Hard drive] (120.03 GB) -- drive 0, s/n WD-WMA8C1102864, rev 16.06V16, SMART Status: Healthy
WDC WD1200JB-00CRA1 [Hard drive] (120.03 GB) -- drive 1, s/n WD-WMA8C2600983, rev 17.07W17, SMART Status: Healthy
WDC WD60 0AB-00BVA0 USB Device [Hard drive] (60.02 GB) -- drive 2 1024 Megabytes Installed Memory

Slot 'DIMM1' has 512 MB
Slot 'DIMM2' has 512 MB
Local Drive Volumes

c: (on drive 0) 120.02 GB 73.09 GB free
d: (on drive 1) 120.03 GB 28.16 GB free
z: (on drive 2) 60.02 GB 49.23 GB free

Network Drives
None detected

Standard floppy disk controller
Primary IDE Channel [Controller]
Secondary IDE Channel [Controller]
VIA Bus Master IDE Controller RADEON 8500 SERIES [Display adapter]
LGE L1920P [Monitor] (19.1"vis, January 2004)
LGE L1920P [Monitor] (19.1"vis, January 2004)
Bus Adapters Multimedia
FVDSCSI (2003) SCSI Host Adapter
NEC PCI to USB Enhanced Host Controller (B1)
NEC PCI to USB Open Host Controller
NEC PCI to USB Open Host Controller
VIA Rev 5 or later USB Universal Host Controller
VIA Rev 5 or later USB Universal Host Controller Creative Game Port
Creative SB Audigy 2 (WDM)
Communications Other Devices
1394 Net Adapter
1394 Net Adapter #2
RAS Async Adapter
Realtek RTL8139/810x Family Fast Ethernet NIC
Network Card MAC Address: 00:E0:18:55:FC:70
Network IP Address: / 24 OHCI Compliant IEEE 1394 Host Controller
OHCI Compliant IEEE 1394 Host Controller
APC Battery BackUP
American Power Conversion USB UPS
HID-compliant consumer control device
HID-compliant device
HID-compliant device
USB Human Interface Device
USB Human Interface Device
USB Human Interface Device
HID Keyboard Device
HP PS2 Keyboard (2K - 3)
USB Scroll Mouse
General Purpose USB Hub
Generic USB Hub
USB Composite Device
USB Mass Storage Device
USB Printing Support
USB Printing Support
USB Root Hub
USB Root Hub
USB Root Hub
USB Root Hub
USB Root Hub
Virus Protection
No details available
Installed Microsoft Hotfixes
S867461 on 9/29/2004 (details...)
M886906 on 2/9/2005 (details...)
S867460 on 9/29/2004 (details...)
M886903 on 2/9/2005 (details...)
Q328797 on 2/21/2004 (details...)
Q823718 on 8/21/2003 (details...)
Q832483 on 1/13/2004 (details...)
KB870669 (details...)
Internet Explorer
SP2 (SP2)
Windows Media Player
WM819639 (details...)
WM828026 (details...)
Windows Media Player (continued)
KB837272 (details...)
Q828026 on 10/4/2003 (details...)
Windows XP
KB811113[SP] on 8/26/2004 (details...)
KB834707 on 10/14/2004 (details...)
KB867282 on 2/9/2005 (details...)
KB873333 on 2/9/2005 (details...)
KB873339 on 12/15/2004 (details...)
KB885250 on 2/9/2005 (details...)
KB885835 on 12/15/2004 (details...)
KB885836 on 12/15/2004 (details...)
KB885884 on 10/14/2004 (details...)
KB886185 on 12/15/2004 (details...)
KB887472 on 2/9/2005 (details...)
KB887797 on 12/25/2004 (details...)
KB888113 on 2/9/2005 (details...)
KB888302 on 2/9/2005 (details...)
KB890047 on 2/9/2005 (details...)
KB890175 on 1/12/2005 (details...)
KB891781 on 2/9/2005 (details...)

Lord Wrath
posted 02-20-05 03:24 AM EDT (US)     452 / 618       
1. one file doesn't write properly
2. [I honestly have no idea what most of this info is, but I'll do my best]
Chip Type: Intel(R) 82852/82855 Graphics Controller
DAC Type: Internal
Memory Size: 64 MB
Adapter String:Intel(R) 82852/82855 GM/GME Graphics
Bios Info: Intel Video BIOS
Intel(R) Exteme Graphics Report:
Driver version:
Operating System: Windows NT* 5.1.2600 Service Pack2
DirectX* Version: 9.0
Physical Memory: 238 MB
Min. Graphic Memory: 15 MB
Max. Graphics Memory:64 MB
Graphics Mem. In Use:17 MB
Processor: x86
Processor Speed: 2394MHZ
Manufactured and Supported by:
Mobile Intel(R)
Celeron(R) CPU 2.40 GHz
2.39 GHz, 240 MB of RAM
Hard Drive: 22 GB of 40 GB used
Microsoft Windows XP
Home Edition
Version 2002
Service Pack 2
No mods, cracks, trainers, or anything...
3. RON won't install. I do not have the cd case because I keep all my cd's in a Vaultz cd case. I found out online that you can type any numbers into the CD-KEY slot, so i did. At 65% it writes a file in C:\Program files\microsoft games\rise of nations\tutorial1\. The file is a .wav file called bodacea_selected or something like that. After loading for about 5 min., It will say that the file is currently being used by another program or I may not have enough space on my hard drive.
4. 1 put in cd, 2 wait for autoplay,3select "install", 4 insert cd key ([12345][12345][12345][12345][12345]), 5 type in the C:\program files\ thing, 6 hit "next", 7 it begins its long, long, installation.
5. N/A
6. N/A

Sorry if this bug is already on this topic, but I didn't read the end of the first post until just now.

[This message has been edited by REDEX (edited 03-02-2005 @ 07:17 PM).]

posted 02-21-05 01:26 PM EDT (US)     453 / 618       
posted 02-21-05 02:04 PM EDT (US)     454 / 618       
There is no fix to this problem.

Best you can do is try updateing all your drivers for graphics, sound, network, motherboard and modem.

Failing that contact microsoft customer support as detailed in the back of the manual.

In either case, stop being an A HOLE. nobody here sold you the game. Nobody here need to anything for you and shouting and being abusing won't get the problem fixed. And FYI you are posting in the wrong thread, or were you too lazy to attempt to find a solution yourself in the other threads?

posted 03-02-05 07:19 PM EDT (US)     455 / 618       
was that last thread directed at me, or what?
posted 03-02-05 08:51 PM EDT (US)     456 / 618       
No, matrix283
posted 03-12-05 02:18 PM EDT (US)     457 / 618       
Answer to Nashi

I know it's been 2 months ago, but it's the first time I come on this forum.

If other people get the same problem as Nashi, I hope it might help ya.

If you have a nvidia card and the game get very slow when you are in the main menu (It's like almost impossible to click any option, taking over a minute to have the next menu), then downgrade your nvidia drivers.

I had the same problem, I spent almost 3 hours of testing drivers to find which could fix this problem, finally I found the series 52.xx to 56.xx. I installed the 56.72 and the game works fine since. Don't try 61.76, it won't work.

You can get old drivers on the nvidia ftp, directory windows.

Exalted Druid
posted 03-30-05 04:41 PM EDT (US)     458 / 618       
My apology if this is the wrong kind of bug to report here.

I think my bug is in the game programming itself. Napoleon campaign I'm attacking one of the little European country's mid map.

It's a unique scenario were I have an army and must capture production centers. Grain, Mines, Timber ect and cannot build any such myself. I take the 1st two cities easily then I get this pop up message.

General So & So in a brilliant move has gotten reinforcements do you wish to retreat or carry on. You are now very badly out numbered. If you retreat you receive 55 credits and a bonus card. I choose retreat get my credits, and then it says I have 5 armies to place. (Which is strange because I'm suppose to get a card not armies)

I go to place the 1st army at the end of my mouse and it disappears and I cannot do any thing else. The game is not locked up but it’s waiting for me to place the armies I don't have. I have run the scenario 3 times and got hit with the same bug each time. I cannot carry on.

Anyone else report this problem.

posted 05-14-05 00:23 AM EDT (US)     459 / 618       
I've been playing Rise of Nations for a long time I am more of a history fanatic than a gamer. I started to get bored with Rise of Nations and a few months ago I started working on a Bronze Age mod. Everything that I know about this is from trial and error. I have been very careful to make sure that I had backup copies of the original files. Things were going really well until I tested my Minoans and realized that the buttons for building the trireme and bark class ships were missing from the game menu. They were still there for fire ships and fishing ships. I tried playing as every nation and there were still no ship buttons. They are there in the scenario editor, though. The compuer nations could still build those ships, but I couldn't because I had no buttons. I went back into the program files and made sure that I didn't have any ships on X0 Y0 and on X1 and Y0. I didn't. I looked really carefully at all of the ships and X and Y coordinates. Everything was fine. I had never changed these to begin with. but I wanted to check just in case. I removed the modded unitrules.xml file and replaced it with the original. I went back into the game and I still had the same problem. Then I replaced all of my modded files (unitrules.xml, buildingrules.xml, techrules. xml, help.xml, and most of the tribes) with the original files. I went back to the game and I still had no buttons for ships. Then I made sure that I had all of the patches. I did. Then I deleted my profile and made a new one. I started a new game and had the same problem. After that uninstalled and reinstalled Thrones and Patriots. Still no ship buttons. Then I uninstalled and reinstalled Rise of Nations and Thrones and Patriots. Still no ship buttons. After that I decided to see if it was a problem with the slot that the triremes and barks were in or if it was with the buttons themselves. I moved the fire ship button and the fishing ship button over to X0 Y0 andX1 Y1. Then I moved the trireme and bark to X2 Y0 and X3 Y0. The fishing ship button and fire ship button appeared but the trireme and bark did not. I uninstalled and reinstalled both games once more just for good measure and it still didn't work. I have done everything that I can think and I have no ship buttons. I would greatly appreciate any knowledge or help you could give me that would help me solve this frustrating problem.
posted 05-14-05 05:01 AM EDT (US)     460 / 618       
After an uninstall, try deleting both these folders if they exist:

C:\Program Files\Microsoft Games\Rise of Nations


C:\Documents and Settings\(Yourname)\Application Data\Microsoft Games\Rise of Nations

posted 05-14-05 08:43 AM EDT (US)     461 / 618       
I did that.
posted 05-16-05 04:13 PM EDT (US)     462 / 618       
this isn't realy a bug but i don't feel like looking through the forums: where is the product key? is it on the disk? please help
posted 05-16-05 06:13 PM EDT (US)     463 / 618       
Mine is in the CD case above the disk holder (UK version) Orange sticker.
posted 05-20-05 11:54 PM EDT (US)     464 / 618       
As soon as I click on any kind of multiplayer mode, for example LAN/Internet, RON loads the menu, then begins to freeze and lock up. Eventually, it runs so slowly the only way to get out is to end task- but the program never completely freezes. This occurs with all firewall and Antivirus software deleted- and i'm having this issue on two different computers- but not my third.

My ancient win98 desktop will run it, but not my two new winXP SP2 laptops, which far exceed the system requirements. The only common link i can think of is that they both have McAfee internet security suite installed- but even when i prevent the program from starting, this same problem occurs.

It seems bizarre to me that this issue occurs in the menu, and not even in the actual game engine. I'm at a loss, and i'd really like to play this game in multiplayer, so if anyone has any solutions- i'd love to hear them.

[This message has been edited by AlexRiker (edited 05-20-2005 @ 11:57 PM).]

posted 05-21-05 07:56 AM EDT (US)     465 / 618       
There was a huge lag proplem in multi-player in unpached versions due to time syncronisiation issues. Is your copy patched? Also RoN doesn;t support multiple network adaptors so if you have multiple, try disabling the unused ones.
posted 05-22-05 01:48 AM EDT (US)     466 / 618       
Yes- it was patched- but i have fixed the problem. I had to uninstall McAfee Privacy service, and then it ran fine. That sparked a whole bunch of other issues, actually, but now RON works fine. Thanks anyway, though.
posted 06-07-05 08:32 PM EDT (US)     467 / 618       
Hi, im new at all of this video driver stuff but i installed the game and it freezes after 10-70 seconds after I start a game.
I have the following hardware:
S3 Prosavage DDR video card
40 Gig harddrive 13.5 Gigabytes free
Intel Celeron 1.70 Ghz
Directx 9.0
THe newest update for my video driver and the newest patch for RoN.
Im really frustrated and cant figure out whats wrong. I have also tried messing witht the video quality and resolution as well as rise2.ini tweaking. Anything you can say to help?
THanks Ike
posted 06-11-05 08:15 PM EDT (US)     468 / 618       
can anyone tell me where rise2.ini is located i've been looking for it. i have search ron files but cant seem to find it anywhere so please help!!!

[This message has been edited by Razor_sharp (edited 06-11-2005 @ 08:16 PM).]

posted 06-11-05 08:50 PM EDT (US)     469 / 618       
It's precise location depends on two things, your operating system and your patch version of Rise of Nations. For most players, running the latest patch on Windows XP you will find it here:

C:\Documents and Settings\(YourName)\Application Data\Microsoft Games\Rise of Nations\rise2.ini

posted 06-14-05 07:45 PM EDT (US)     470 / 618       
im running on windows xp i tried searching for rise2.ini but it wont show at all. i also looked it up on applications data but it aint there. the game version i have is gold edition of ron and im not sure if this has something to do with it. if anyone can help me find rise2.ini would be appreciated.
posted 06-15-05 07:57 AM EDT (US)     471 / 618       
Please help...........

My game crashes after 20 minute of gameplay or when creating a merchant. My system configuration is

1.5MGz Intel Pentium 4 (Win 2000. SP4)
40GB Hard Drive with 21.85GB Free Space.
Radeon 9000 Graphic Card
Vintron motherboard (VIA 845 Chipset)
Rise of Nations retail (English version)
No mods, no cracks, no trainers... etc.

posted 06-15-05 01:52 PM EDT (US)     472 / 618       
Razor, log on to gamespy through the in-game menu, multi-player. This should install a patch for you and move the rise2.ini file to where described. There is a rise2.ini file in proggram files\microsoft games\rise of nations but that becomes redundant when patched.

KULRATHI, first thing to do is update ALL your hardware drivers to manufacturers latest. Motherboard, sound and video. You can try using windows update but in my experiance you have to go to the hardware manufacturers website for the most up to date driver.

posted 06-16-05 10:39 AM EDT (US)     473 / 618       

I bought this game “Rise Of Nations Gold Edition” 5 days ago.
So far I have completed 2 out of 10 games because the game keeps resetting my computer.
I will be in the middle of a game and all of a sudden the computer does a restart !!!

I have tried shutting down all other applications and run the game
I have uninstalled and reinstalled the game
This happens either in single player quick game or single player campain.
And I DO mean pain...
I have not tried multi player yet as I am not going to do multi until I get the hang of single.

I have updated my video and audio drivers.

It seems that I get about 20-30 min into the game and CRASH back to desktop.

If I cannot get this POS game to stop crashing them I will return it!

Game Version is
My computer information is as follows:

Windows XP Professional Service Pack 2 (build 2600)
Processor a Main Circuit Board b
1.15 gigahertz AMD Athlon XP
128 kilobyte primary memory cache
256 kilobyte secondary memory cache Board: ASUSTeK Computer INC. A7V333 REV 1.xx
Bus Clock: 100 megahertz
BIOS: Award Software, Inc. ASUS A7V333 ACPI BIOS Revision 1014 10/03/2002
Drives Memory Modules c,d 160.06 Gigabytes Usable Hard Drive Capacity
25.41 Gigabytes Hard Drive Free Space

3.5" format removeable media [Floppy drive]

MAXTOR 6L040J2 [Hard drive] (40.03 GB) -- drive 0, s/n 362200727683, rev A93.0500, SMART Status: Healthy
ST3120026A [Hard drive] (120.03 GB) -- drive 1, s/n 3JT1TV8S, rev 3.06, SMART Status: Healthy 512 Megabytes Installed Memory

Slot 'DDR 1' has 512 MB
Slot 'DDR 2' is Empty
Slot 'DDR 3' is Empty
Local Drive Volumes
c: (NTFS on drive 0) 40.02 GB 7.37 GB free
d: (NTFS on drive 1) 120.03 GB 18.04 GB free

NVIDIA GeForce3 Ti 200 [Display adapter]
Princeton EO2010 [Monitor] (18.8"vis, s/n KNAB0100759, January 2001)

posted 06-16-05 11:09 AM EDT (US)     474 / 618       

I have just read this entire forum.

There is no help here so do not bother to read all the messages.

Do NOT bother to place a bug on this forum as no solutions are posted.

The only suggestions here are “update your drivers” and “you have old hardware”.

If you have good hardware and the latest patch and drivers
and the game still crashes or locks up forget it.

The bottom line:

Take the game back.
Do not buy another Microsoft Game Studios or Big Huge Games game.

Their games do not work, they cannot or will not fix them and
support does not exist.

posted 06-16-05 12:02 PM EDT (US)     475 / 618       
Not much help is given in this thread and it is not a support thread. It's a very old thread inteded to post bugs, not get support if your PC is old or crashes.

Also, help given here is volutary by other members that have nothing to do with Microsoft or Bigh Huge Games, it's called a community, have a think about that and save your mouthing off for Microsoft or Big Huge Games.

Also, FYI, out of date drivers is THE biggest reason why the game fails to work correctly, it's not a futile suggestion, in most cases it is the solution to the problem.

I realised that you had to wait 30 whole mintes with no reply. Perhaps next time you would consider posting in the appropriate place and having a little more patience.

Now have a read of this, there is a section on game crashes and hangs

Good luck.

[This message has been edited by War (edited 06-16-2005 @ 12:03 PM).]

« Previous Page  1 ··· 10 ··· 17 18 19 20 21 ··· 25  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Rise of Nations Heaven | HeavenGames