You must be logged in to post messages.
Please login or register

RoN Tech Support
Moderated by alincarpetman

Hop to:    
Welcome! You are not logged in. Please Login or Register.618 replies, Sticky
Rise of Nations Heaven » Forums » RoN Tech Support » Report Bugs here so they get fixed!
Topic Subject:Report Bugs here so they get fixed!
« Previous Page  1 ··· 10 ··· 18 19 20 21 22 ··· 25  Next Page »
posted 05-21-03 02:25 PM EDT (US)         
I've noticed people complaining about not being able to play Rise of Nations because of bugs, patch problems... etc.

So... here's what the community can do to help BHG solve these issues and get them fixed.

1. Give a brief description of the problem. For example:
Game doesn't patch.

2. Give a detailed system analysis of you computer specs. To make this easier for people to find out what they have, go here and download the Belarc Advisor at and/or just browse through your Device Manager.
For example:
1.8MGz Intel Pentium 4 (Win XP Pro. SP1 build 2600)
Dell OptiPlex GX240 MB with BIOS A03 03/01/2002
40GB Hard Drive with 21.85GB Free Space.
NVIDIA GeForce4 Ti4400 with driver 03/20/2003
(Optional) Cable Modem w/Firewall... etc.
Rise of Nations retail (English version) build
No mods, no cracks, no trainers... etc.

3. Give a more detailed description of the problem. For example:
When updating the patch through GameSpy, it will download 100% then bring me back to desktop and patch RoN until it reaches 37%, then it will stop and give me an "Invalid Patch File Error" and a "Retcode positive - 32769". I have the English version of the game.

4. Give reproduction steps on how to make it happen again. For example:
1. Launch the game.
2. Go to Multiplayer Game.
3. Go to GameSpy Internet Matchmaking.
4. Click "OK" when it says to upgrade to version
5. When the download is complete, log into GameSpy with your password.
6. Observe the game going to desktop and stopping at 37% during the patch process.

5. If it's a multiplayer game, be sure to specify if it was through GameSpy Arcade, GameSpy Internal, or LAN/IP. Then list the settings for the Multiplayer game. For example:
Teams of 3
Great Lakes
Large (5/6 player)
No Cannon Time
End Age: Gunpowder Age
Elimination: Conquest
Victory: Conquest
Tournament Play enabled.
3 Humans vs. 3 Computers (Moderate, Moderate, and Tough)
Nations in the game were:
Aztecs, Mongols, Chinese, Chinese, Egyptians, and Russians.

6. If it's a single player Quick Battle game, list the same steps as in #5. If it's a Conquer the World Single Player Campaign... list:
1. What your Nation is.
2. What difficulty setting you have.
3. What Age it was in.
4. What country you were attacking, and what battle type it was.
5. What build you're in... and what build you started your Campaign in. For instance, the retail is, and the patch is Did you start a campaign in the retail version and save the campaign... and then upgrade to the patch and load the campaign?

If you see your bug listed here already from someone else, just give your #2. Computer Specs.

[This message has been edited by Scrubs (edited 05-21-2003 @ 05:29 PM).]

posted 06-28-05 09:43 PM EDT (US)     476 / 618       
While playing my copy of Rise of Nation Gold Edition in quick battle and CTW mode, my graphich card resets and eventualy I get an exception eror notice.

Windows XP Professional Service Pack 2 (build 2600)
Processor: 1.73 gigahertz AMD Athlon XP
RADEON 8500 SERIES [Display adapter]
Rise of Nations Version

posted 06-29-05 02:14 PM EDT (US)     477 / 618       
Hi, can anybody help me on the mystery no-sound after the intro movie? The game works fine no problems at all, only without sound. i have tried Cobra's topic solution on this problem about installing the codec's but that does not help, i have installed them all and updated my audio drivers. The sound files are in C:Program files\Microsoft games\Rise of nations\sounds and they work inside the folder but do not respond in-game.
I love the game and desperatly want to resovle this problem.

Basic Specs:
E-Machines - Imperial Model
Realtek AC'97 Audio - Latest Driver
Intel Extreme Graphics - Latest Driver
1.8 Ghz intel celeron

posted 07-11-05 07:14 PM EDT (US)     478 / 618       
Ok well my mouse flickers on rise of nation gold edition, ive read threw most of the fourms that realate to my problem, I did the rise2.ini thing said on the first page of this tread, and it didn't work, ive also tried the display thing with the 16bit and the 32bit still didnt work, ive notice on the first tread you said you had a plan C scrub and i would like to know what it is. My system:

3.20 gigahertz Intel Pentium 4(Windows XP Home Edition Service Pack 2 (build 2600))
156.72 Gigabytes Usable Hard Drive Capacity
83.02 Gigabytes Hard Drive Free Space
128MB Ati Radeon X300 SE (checked for most reason driver today)
Rise of Nations Gold Edition(English)
No mods,cracks or anything to change rise of nation

posted 07-18-05 01:40 PM EDT (US)     479 / 618       
My friend's machine is having a real difficult issue and I don't know what to do with it. He had the original game and then the expansion that gave out on him. Now he's gone out and bought a Gold Edition with the same issue. Here's what it does:

He double-clicks on the shortcut and his pointer switches to the egg timer for a few moments and flashes back to a regular pointer. Sometimes a box appears and it reads something like the following statement. I'd have a screenprint but it comes and goes very quickly.

ScriptException Win32 Stublib
Error Code 1
Couldn't get the package encryption key
par 1:0
par 2:0
HRSEULT: 0x8002802F

I know it looks pretty complicated but I'm hoping someone out there can help. We're getting ready to go to Iraq and we on;y have a boradband connection to work on these issues for a while longer.

Much thanks up front. His machine is a really new iBuyPower laptop with a lot of high-speed components. Let me know if you need a whole lot more.

posted 08-07-05 04:32 AM EDT (US)     480 / 618       
Thank you first for your help.

I purchased the Gold version of RoN and made an auto update via the game.

When I am running the Napoleon scenario my computer crash showing the blue screen and saying that I have porblem with my S3 Savage IX 1014 card.

I have updated drivers for the card but it doesn't seems to be enough.

My config:

Operating System System Model
Windows XP Home Edition Service Pack 2 (build 2600) No details available
Processor a Main Circuit Board b
667 megahertz Intel Pentium III
32 kilobyte primary memory cache
512 kilobyte secondary memory cache No details available
Drives Memory Modules c,d
30.01 Gigabytes Usable Hard Drive Capacity
12.07 Gigabytes Hard Drive Free Space


IC25N030ATCS04-0 [Hard drive] (30.00 GB) -- drive 0, s/n CSL305DAH315EA, rev CA3OA71A, SMART Status: Healthy 256 Megabytes Installed Memory
Local Drive Volumes

c: (NTFS on drive 0) 30.01 GB 12.07 GB free

Network Drives
None detected
Users (mouse over user name for details) Printers
local user accounts last logon
Noi 6/28/2005 9:19:32 AM
Pierric 8/7/2005 8:18:33 AM (admin)
Sofia 6/18/2005 7:00:53 PM (admin)
Yoan 4/17/2005 11:31:25 AM
local system accounts
Administrator never (admin)
Guest 12/25/2004 8:12:37 PM
HelpAssistant 8/2/2005 1:40:34 AM
SUPPORT_388945a0 never

Marks a disabled account; Marks a locked account None detected
Controllers Display
Standard floppy disk controller
Intel(r) 82801CAM Ultra ATA Storage Controller-248A
Primary IDE Channel [Controller]
Secondary IDE Channel [Controller] S3 Graphics SuperSavage/IXC 1014 [Display adapter]
Bus Adapters Multimedia
Texas Instruments PCI-1420 CardBus Controller (2x)
Standard Universal PCI to USB Host Controller (3x) Crystal WDM Audio Codec
Communications Other Devices
Lucent Win Modem

Belkin 802.11g Network Adapter #2

Networking Dns Server:
Microsoft AC Adapter
Microsoft ACPI-Compliant Control Method Battery
IBM ThinkPad Fast Infrared Port
Standard 101/102-Key or Microsoft Natural PS/2 Keyboard
IBM PS/2 TrackPoint [Mouse]
IBM (ICH3) SMB Host Controller
USB Root Hub (3x)
Virus Protection [Back to Top]
No details available
Missing Microsoft Security Hotfixes [Back to Top]

All required security hotfixes (using the 07/12/2005 Microsoft Security Bulletin Summary) have been installed.

Installed Microsoft Hotfixes [Back to Top]
Internet Explorer 6
KB834707-IE6-20040929.115007 on 12/24/2004 (details...)
KB834707-IE6SP1-20040929.091901 on 1/17/2005 (details...)
Internet Explorer
SP2 (SP2)
Windows XP
KB811113[SP] on 1/17/2005 (details...)
KB834707 on 1/19/2005 (details...)
KB867282 on 2/13/2005 (details...)
KB873333 on 2/13/2005 (details...)
KB873339 on 1/19/2005 (details...)
KB883939 on 6/18/2005 (details...)
KB885250 on 2/13/2005 (details...)
KB885835 on 1/19/2005 (details...)
KB885836 on 1/19/2005 (details...)
KB886185 on 1/19/2005 (details...)
KB887472 on 2/13/2005 (details...)
KB887742 on 2/23/2005 (details...)
Windows XP
SP3 (continued)
KB888113 on 2/13/2005 (details...)
KB888302 on 2/13/2005 (details...)
KB890046 on 6/18/2005 (details...)
KB890047 on 2/13/2005 (details...)
KB890175 on 1/19/2005 (details...)
KB890859 on 4/16/2005 (details...)
KB890923 on 4/16/2005 (details...)
KB891781 on 2/13/2005 (details...)
KB893066 on 4/16/2005 (details...)
KB893086 on 4/16/2005 (details...)
KB893803 on 4/16/2005 (details...)
KB893803V2 on 5/22/2005 (details...)
KB896358 on 6/18/2005 (details...)
KB896422 on 6/18/2005 (details...)
KB896428 on 6/18/2005 (details...)
KB898461 on 7/21/2005 (details...)
KB901214 on 7/21/2005 (details...)
KB903235 on 7/21/2005 (details...)

I have run you belark software to get this list but did see the rise of nations sofware listed although it is installed.

Perhaps because I am in safe mode since the computer just crashed.

Hope you can help


posted 08-30-05 02:44 PM EDT (US)     481 / 618       
When I run Thrones and Patriots on Windows Server 2003, after the video intro the game crashes with the message, 'Gathering Exception Data.'

I know its kind of odd to run a game on Server 2003, but other games work fine.

Athlon XP 3000
1 GB Ram
256 mb Nvidia Geforce
Thrones and Patriots patched to the latest version.

posted 08-30-05 05:06 PM EDT (US)     482 / 618       
Server 2003 is the problem, but there is a solution, see this thread:,4866,0,all

posted 09-21-05 07:52 PM EDT (US)     483 / 618       
im having a problem since i upgraded my pc, whenever i alt tab out of ron t&p it crashes the game says gathering exception data, it doesnt do this if i alt tab out during the menu screens or anything, only during actual gameplay

amd athlon 64bit 2.2 GHz processor
2gig pc3200 ddr ram
ati radeon x800 256meg PCI-E
300gig maxtor plus 10 16meg cache 7200rpm

posted 10-27-05 06:53 PM EDT (US)     484 / 618       
My Problem:

1) When I play as the Americans, there unique
"Free Science Research" is not researched. Why am I not reciving my Science Research and how can I fix this? (Same Problem When Playing Online Too.)

posted 10-27-05 08:05 PM EDT (US)     485 / 618       
Hi GermanyX

For balance reasons, the Americans no longer get the free Science. To speed up the release of the last patch due to chronic instability troubles with patch 1, BHG wanted to do limited changes, so the help text (technically very hard to change this apparently) was not changed so the list of benefits that some nations get is a bit out of date.

PS don't bother reporting any more bugs in this thread. BHG really don't give a shit. Only I give a shit and they hate me because I am a winging bastard that doesn't lick their arse.

Post any issues you have in a separate thread in this forum and I will try to help.


BHG No.1 supporter
BHG No.1 critic

[This message has been edited by War (edited 10-27-2005 @ 08:06 PM).]

posted 12-10-05 11:32 PM EDT (US)     486 / 618       
Im Having this problem with the game and its beginning to really annoy me.


Unknown net command recieved!!
[Click RETRY to debug, Ignore to turn this message off and continue]

Safe to ignore: NO

I get this message after I create a multiplayer game and my freind joins and the game loads and just as it moves from the loading screen to the game it minimizes and the error comes up.

Help would be much appreciated.

Sys specs:

Radeon 9000 64mb
256mb of ram
os: win xp pro
intel Celeron 1.3 ghz

posted 12-11-05 07:22 AM EDT (US)     487 / 618       
A tricky one. Is this over LAN play?
Can you play on-line over teh internet through the gamespy lobbies okay?
Is it RoN standard or with the Thrones and Patriots expantion?
Is it just you getting this error or does everyone?

Here are a few thing to try:
Make sure your game has got the latest patch installed (everyone needs this).
Try to find an updated driver for your network card and for your motherboard. Find out the make and model of these then go to the manufactures website for the latest driver. Often the network card is built onto the motherboard so the latest m/b drivers will do.
If you are still having problems, try start>Run... then type dxdiag, see if this utility reports any errors in networking.
Try running with a different hosts.
Make sure nobody is running with any mods installed or with a "nocd" fixed exe to eliminate thos possibilities due to version conflicts.

posted 12-11-05 10:50 PM EDT (US)     488 / 618       
No its not over LAN play and I can play over LAN just fine. It happens when I make a game and my freind joins then as I said it crashes just after finishing loading. I cant join games on gamespy because it says my version is which is strange because ive updated to the latest version with the auto update.

My freind also gets the message when the game crashes. I dont have Thrones and Patriots installed. I am running with a nocd crack on.

posted 12-12-05 05:32 PM EDT (US)     489 / 618       
That is probably your problem, the NoCD cracks are not up to date with the patches as far as I know (certainly for T&P they are not). You need to restore the original exe and run off the CD
posted 12-12-05 05:33 PM EDT (US)     490 / 618       
Thanks for your help
posted 12-15-05 01:05 PM EDT (US)     491 / 618       
My Rise of Nations is crashing for no apparent reason whenever I complete a building, a unit or destroy something. Right before it finishes, it crashes to the desktop.

Update video card drivers
Latest patch applied

My system is above and beyond the minimum required. Can I get some help? The tutorial games worked perfectly fine, but a normal solo game will crash anytime it wants to, really. Any help?

posted 12-31-05 11:59 AM EDT (US)     492 / 618       
I was trying to play Rise of Nations: thrones and patriots, online (I do it through gamespy). However once I put in my password and username and e-mail, it just says connecting and never connects. Last night I could connect, however it wont work this morning. Any ideas guys?
p.s I just tried to get in, once more and this message came up: "There was a network error. You have been disconnected from Gamespy". How can I fix this?

[This message has been edited by Mordici (edited 12-31-2005 @ 12:11 PM).]

Captain Banana
posted 01-24-06 05:44 PM EDT (US)     493 / 618       
All right, a bunch of my friends and I have bought this game. However, some of us have some multiplayer issues, such as me.
I can host games perfectly, and everyone can get in. However, if I ever try to join a game, all the information bars such as
nation, difficulty, team, etc... don't always pop up. A minute later dialogue pops up saying everyone has left the game, and then a box pops up and tells me "Host has left the game. Cancelling game" and it bumps me back out into the lobby.
Can anyone help me!? Please!
posted 02-03-06 05:50 PM EDT (US)     494 / 618       
Here is my Issue:
Rise of Nations: Throne & Patriots will launch file, go thru the intro movie and then arrive safely at the menu. I'll choose Quick Battle, then choose my nation (any nation) and set the rules and what not. I will start the match and get to the screen overlooking your captital and few workers with the scout all ready to go, i will proceed to do anything, select worker/capitol/scout/tree/rock/fish/whatever and the game crashes out, and gives a "Gathering Exception Data" message. I have another system with by far less impressive specs and it runs fine. Interesting note on the problem is that in only happens with the T&P expansion installed. I have reloaded the OS and tried under SP1 with the same issue. I lowered the Hareware Acceleration to different levels and all with the same result. I also update all hardware drivers but alas with no luck.

System Specs for Problem PC:
AMD XP 3000+
160 GB + 40 GB HDD's
Nvidia Geforece FX 5500 256 MB DDR
Windows XP Pro w/ SP2

The working system specs:
AMD Thunderbird 950 Mhz CPU
512 Mb SDRAM
40 GB HDD w/29 GB Available
256 ATI Radeon 9550 with latest drivers
Windows XP Pro w/ SP2

I have changed out the video cards as well. Originally the system that currently works had a nvdia 128 MB vid card which did worked as well and it is a GATEWAY!!!!. This issue is completely confusing and sucks. Any Ideas?

[This message has been edited by Paxile2k (edited 02-03-2006 @ 05:52 PM).]

posted 02-03-06 10:58 PM EDT (US)     495 / 618       
by all drivers, did you mean sound and motherboard? Does the exception data gathering eventually lead to any more info? If so what does it say?
posted 02-06-06 01:13 PM EDT (US)     496 / 618       
yes i do mean all available drivers, sound, motherboard, video, monitors, harddrives, mouse, keyboard, ect. and clicking ok on the error just closes everything out, nothing else is displaying, and found nothing in the event logs on the system.
posted 02-06-06 04:19 PM EDT (US)     497 / 618       
Sounds a nasty one. It's quite possibly down to a timing issue with RAM or Video memory. If you know how you, you could try altering RAM timings in BIOS or changing your AGP settings to a lower multiplier. Try changing your desktop resolution to a different colour depth (eg. 16 bit colour).
posted 02-07-06 01:56 PM EDT (US)     498 / 618       
I have tried changing color depth, resolutions on both the game and in windows and still it crashed out, but RoN without T&P addon works perfectly, I am thinking there is a problem with T&P and a confict with the motherboard drivers, i know due to other issues i have to replace the Power supply and i am going to replace the motherboard due to other issues. I just can figure the issue out. No logs anywhere on the system.

[This message has been edited by Paxile2k (edited 02-07-2006 @ 02:06 PM).]

posted 03-22-06 06:45 PM EDT (US)     499 / 618       
When playing offline...conquer the the end of napoleon my game freezes...does not display statistics...just locks up after the last turn. Computer about two years old but powerful...lots of memory and juice.
posted 04-07-06 11:39 PM EDT (US)     500 / 618       
When I start the game, the three manufacturer and the actual game videos don not appear. Then when I get to the main menu, I can't select anything with the normal left click. I have to hold right click, then left click on something. After I selected something through this process, I cant do much from there. I've played RoN on this computer before, but then I had spyware problems, got rid of the spyware, then this happened. I installed a registry fixer, and still the same problem. any help would be great.
« Previous Page  1 ··· 10 ··· 18 19 20 21 22 ··· 25  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Rise of Nations Heaven | HeavenGames