You must be logged in to post messages.
Please login or register

RoN Tech Support
Moderated by alincarpetman

Hop to:    
Welcome! You are not logged in. Please Login or Register.618 replies, Sticky
Rise of Nations Heaven » Forums » RoN Tech Support » Report Bugs here so they get fixed!
Topic Subject:Report Bugs here so they get fixed!
« Previous Page  1 ··· 10 ··· 21 22 23 24 25  Next Page »
posted 05-21-03 02:25 PM EDT (US)         
I've noticed people complaining about not being able to play Rise of Nations because of bugs, patch problems... etc.

So... here's what the community can do to help BHG solve these issues and get them fixed.

1. Give a brief description of the problem. For example:
Game doesn't patch.

2. Give a detailed system analysis of you computer specs. To make this easier for people to find out what they have, go here and download the Belarc Advisor at and/or just browse through your Device Manager.
For example:
1.8MGz Intel Pentium 4 (Win XP Pro. SP1 build 2600)
Dell OptiPlex GX240 MB with BIOS A03 03/01/2002
40GB Hard Drive with 21.85GB Free Space.
NVIDIA GeForce4 Ti4400 with driver 03/20/2003
(Optional) Cable Modem w/Firewall... etc.
Rise of Nations retail (English version) build
No mods, no cracks, no trainers... etc.

3. Give a more detailed description of the problem. For example:
When updating the patch through GameSpy, it will download 100% then bring me back to desktop and patch RoN until it reaches 37%, then it will stop and give me an "Invalid Patch File Error" and a "Retcode positive - 32769". I have the English version of the game.

4. Give reproduction steps on how to make it happen again. For example:
1. Launch the game.
2. Go to Multiplayer Game.
3. Go to GameSpy Internet Matchmaking.
4. Click "OK" when it says to upgrade to version
5. When the download is complete, log into GameSpy with your password.
6. Observe the game going to desktop and stopping at 37% during the patch process.

5. If it's a multiplayer game, be sure to specify if it was through GameSpy Arcade, GameSpy Internal, or LAN/IP. Then list the settings for the Multiplayer game. For example:
Teams of 3
Great Lakes
Large (5/6 player)
No Cannon Time
End Age: Gunpowder Age
Elimination: Conquest
Victory: Conquest
Tournament Play enabled.
3 Humans vs. 3 Computers (Moderate, Moderate, and Tough)
Nations in the game were:
Aztecs, Mongols, Chinese, Chinese, Egyptians, and Russians.

6. If it's a single player Quick Battle game, list the same steps as in #5. If it's a Conquer the World Single Player Campaign... list:
1. What your Nation is.
2. What difficulty setting you have.
3. What Age it was in.
4. What country you were attacking, and what battle type it was.
5. What build you're in... and what build you started your Campaign in. For instance, the retail is, and the patch is Did you start a campaign in the retail version and save the campaign... and then upgrade to the patch and load the campaign?

If you see your bug listed here already from someone else, just give your #2. Computer Specs.

[This message has been edited by Scrubs (edited 05-21-2003 @ 05:29 PM).]

The Naminator
posted 07-26-07 04:37 PM EDT (US)     551 / 618       
Have you updated all the drivers?
Does it happens something similar with other games?

I stole this sign!

[This message has been edited by The Naminator (edited 07-26-2007 @ 05:13 PM).]

posted 07-26-07 04:44 PM EDT (US)     552 / 618       
- Updated Radeon 9250 CATALYST Driver,sound driver updated what else?
- never happend to me...

- It says:
Error signature
AppNameatriots.exe AppVer: ModNameatriots.exe

- even tried looking in here :

but it didn't help...

* EDIT : Never mind i've already figuerd it's my
Audio - Vinyl AC'97 Codec Combo Driver (WDM)...anyone know how to help me play while hearing sounds coz otherwise i'm playing simply speechless,10q

[This message has been edited by DannyGG (edited 07-27-2007 @ 04:16 AM).]

Turkish General
posted 07-28-07 01:56 AM EDT (US)     553 / 618       
*RoN Gold (it crashes in also)*

if you got gold edition,you just see RoN Gold in desktop.
in your RoN directory (e.g. C:\Program Files\Microsoft Games\Rise of Nations)there is a "thrones" app.try running it if u wanna play TP.If u wanna play vanilla ron,run "rise" app.if they dont work,try "patriots" and "nations".if they dont work,go to the place where u bought the CD and ask for them to change it.
posted 08-19-07 09:07 AM EDT (US)     554 / 618       
I have the mac version of the RoN gold edition. It won't run on my MacBook Pro. If I install the patch 1.0.1 it gives me a sound system error and won't launch. Without patching it will start but then crashes. Is there a fix for this?

Intel 2.16ghz
1.0GB ram
156GB free
Built-in sound and video
posted 09-27-07 07:43 PM EDT (US)     555 / 618       
hello, i am having a problem with trying to run rise of nations on a good enough pc.

Windows XP
AMD Athlon 2600+
512 mb ram
80 gb hdd
radeon 9550 latest drivers

after the intro video, i keep getting an error that i am running r.o.n. on 256 colors. But in fact I am running it at 32 bits. I also checked to see if the shortcut compatiblity had "play in 256 colors" checked and it wasnt.

so please help
The Naminator
posted 09-29-07 09:15 PM EDT (US)     556 / 618       
Did the game work fine before?
What version of drivers are you using?

Someone can give you better advice in the trouble shooting forum:

I stole this sign!
posted 10-05-07 06:51 PM EDT (US)     557 / 618       
Every time I start the game, an error pops up saying run time fatal error, MSXML 4.0 is not properly installed. i tried downloading msxml 4.0, but no luck.

I have windows Vista ultimate on a Operating System System Model
Windows Vista Ultimate (build 6000) EVGA 122-CK-NF68 2
System Serial Number: 1
Enclosure Type: Desktop
Processor a Main Circuit Board b
2.67 gigahertz Intel Core2 Quad
64 kilobyte primary memory cache
4096 kilobyte secondary memory cache Board: EVGA 122-CK-NF68 2
Serial Number: 1
Bus Clock: 266 megahertz
BIOS: Phoenix Technologies, LTD 6.00 PG 12/21/2006
Drives Memory Modules c,d
960.18 Gigabytes Usable Hard Drive Capacity
587.90 Gigabytes Hard Drive Free Space

Optiarc DVD RW AD-7170A ATA Device [CD-ROM drive]

NVIDIA STRIPE 745.22G [Hard drive] (800.17 GB) -- drive 0
WD 1600JB External USB Device [Hard drive] (160.04 GB) -- drive 1 2046 Megabytes Installed Memory

Slot 'A0' has 1024 MB
Slot 'A1' has 1024 MB
Slot 'A2' is Empty
Slot 'A3' is Empty
Local Drive Volumes

c: (NTFS on drive 0) 800.18 GB 476.45 GB free
e: (FAT32 on drive 1) 160.00 GB 111.44 GB free

Network Drives
None detected
Users (mouse over user name for details) Printers
local user accounts last logon
Daniel Moore 10/5/2007 5:27:01 PM (admin)
local system accounts
Administrator 11/2/2006 8:02:01 AM (admin)
Guest never

Marks a disabled account; Marks a locked account Microsoft Shared Fax Driver on SHRFAX:
Microsoft XPS Document Writer on XPSPort:

Controllers Display
ATA Channel 0 [Controller]
ATA Channel 1 [Controller]
Standard Dual Channel PCI IDE Controller NVIDIA GeForce 8800 GTS [Display adapter]
Sceptre X20WG-Naga [Monitor] (20.2"vis, December 2006)
Bus Adapters Multimedia
Microsoft iSCSI Initiator
NVIDIA nForce RAID Controller
NVIDIA nForce RAID Device (2x)
NVIDIA nForce Serial ATA Controller (3x)
Standard Enhanced PCI to USB Host Controller
Standard OpenHCD USB Host Controller Creative SB X-Fi
High Definition Audio Device
The Naminator
posted 10-06-07 00:11 AM EDT (US)     558 / 618       
Are you running RoN in xp mode?

I stole this sign!
posted 10-25-07 11:32 AM EDT (US)     559 / 618       
no i'm not running it in XP mode, only have Vista
and i've also updated the game, but no luck

[This message has been edited by infernesghost (edited 10-25-2007 @ 11:41 AM).]

The Naminator
posted 10-28-07 02:01 PM EDT (US)     560 / 618       
Run the games in xp mode.

I stole this sign!
posted 10-31-07 08:41 PM EDT (US)     561 / 618       
how do i do that naminator? i don't have my drives partitioned to run XP and i don't have a copy of XP
The Naminator
posted 11-01-07 02:38 PM EDT (US)     562 / 618       
Well, I still don't own Vista, but I know it has XP compatibility mode.
Search in Vista's trubleshooting pages.

I stole this sign!
posted 11-03-07 02:19 PM EDT (US)     563 / 618       
i found the xp compatibility, but still comes up with the same problem, msxml 4.0 not properly installed. i tried installing msxml 4.0 but there are like different little pieces i have to download and i don't know which one i need to download
The Naminator
posted 11-03-07 07:52 PM EDT (US)     564 / 618       
posted 11-05-07 05:11 AM EDT (US)     565 / 618       
When i go to open Rise Of Nations i get a message it says: "This video card is not supported for use with Ris Of Nations" i have an Intel(R) 82810E card what should i do?
posted 11-11-07 02:39 AM EDT (US)     566 / 618       
all this trouble to just play a game, that Microsoft should still support or at least help fix the problem.
posted 11-11-07 08:03 AM EDT (US)     567 / 618       
Hi !

I just bought RON 2 days ago. Very cheap in a game store as it is a relatively old game. It was just to check it out.

After installing, I had great fun. What a cool game ! until...

I tried to reload saved games. The game systematically crashed with the famous and very frustrating 'Gatehring exception data' box ( I Checked the net, I am not the only one it seems to have had the pleasure to meet such a box !)

AM running on XP. The ACER (ASpire 5601 AWLMi)lap top has the following features:
Dual core T2050, 1.6GHz, 533MHZ FSB, 2MB L2 Cache
ATI RADeon Mobility X1300 (DIRECTX version is 9.0c)
Basic soundcard

I applied all of the MS trouble shooting: No change whatsoever.

I have a second computer: An old desk top, AMD ATHLON 1800+ running with XP. 256+512 MB of RAM. NVIDIA card. a hoem Studio M-Audio sound card. Same story. It works fine untill I reload a saved game !!!

How is it possible that exactly the same problem occurs on two different computer with different configurations?

Note that I only tried playing in solo mode.

Please help as I love this game, and am so frustrated now !

Thanks in advance for your help! I hope your experience will help me in tasting the joys of a world conquest ! Looking forwards reading you.


posted 11-15-07 04:45 AM EDT (US)     568 / 618       
Hi, sorry for being a bit noobish, this is my first post and i know this has been discussed before but i can't find an answer that works.

My Problem

Game doesn't patch when updated through Rise of Nations Gold. It asks to download a patch called It downloads fine but it is the install that dosn't work. It gets up to 37% and then comes up with an error message. It usually gets up to 72% and says "Invalid Patch File Error" or if i try to patch it like it says on the BHG website ( says "Retcode Positive - 32769"

2.00 gigahertz AMD Athlon 64 X2 Dual Core (Windows Vista Home Basic build 6000)
Dell Inc Dimension C521 with BIOS Dell Inc 1.1.4 12/09/2006
1022mb RAM
159.94 Gigabytes Usable Hard Drive Capacity
103.50 Gigabytes Hard Drive Free Space
256MB ATI Radeon X1300PRO [Display adapter]
256MB ATI Radeon X1300PRO Secondary [Display adapter]
Rise of Nations Gold retail (English version)

When updating the patch through RON Gold, it will download 100% then bring me back to desktop and patch RoN until it reaches 72%, then it will stop and give me an "Invalid Patch File Error" and a "Retcode positive - 32769". I have the English version of the game.

1. Launch the game.
2. Go to Multiplayer Game.
3. Go to GameSpy Internet Matchmaking.

a. Launch the game
b. Click on Check for updates)

4. Click "OK" when it says to upgrade to version
5. When the download is complete, observe the game going to desktop and stopping at 72% during the patch process.

posted 11-20-07 07:44 PM EDT (US)     569 / 618       
i have a problem similar to the gathering exception data one. Except when i play, it could be between 2 hours or 2 minutes of gameplay, the game will quit to the desktop, and give me no explanation whatsoever. has this happened to anyone before?


Name: NVIDIA GeForce 7300 LE

Memory 1024 mb

Display: 1024x768

Processor: AMD Athlon 64 processor 3200+, 2 Ghz
Manwarrior Pt
posted 11-21-07 04:45 PM EDT (US)     570 / 618       
Hi everybody i need help with my rise of nations
I can t run the game and The computer show me a mensage
like this

BHS RTS run time fatal

Msxml 4.0 is not properly instaled

i have tried many things but i cant fix this thing
please some one help me
The Naminator
posted 11-22-07 03:29 PM EDT (US)     571 / 618       
Read post 564

I stole this sign!
Manwarrior Pt
posted 11-22-07 04:22 PM EDT (US)     572 / 618       
i have already tried

"The msi extension should be associated with "windows installer" and the association sometimes gets lost.

You can download a fix for that here

It may be that your whole windows installer is corrupted, I recall there is a way to repair that, let me know if you need that and I'll have a dig arounwnd"

when i download this fix it dont do nothing

please guys you are my last hope of playing raise of nations

war can you help me please

[This message has been edited by Manwarrior Pt (edited 11-22-2007 @ 04:29 PM).]

Manwarrior Pt
posted 11-29-07 04:02 PM EDT (US)     573 / 618       

Anyone can help me?
posted 12-01-07 09:37 PM EDT (US)     574 / 618       
1. Game starts, goes to main menu, displays button "Cannot create file state.dat. Please check disk space".

2. 1.50 gigahertz Intel Celeron M
240.05 Gigabytes Usable Hard Drive Capacity
136.09 Gigabytes Hard Drive Free Space
Windows XP Home Edition Service Pack 2 (build 2600)
1016 mb ram
Intel 915GM/GMS,910 GML Express

3. I start up Rise of Nations Gold, then, on the main menu screen, before I can do anything, a button pops up and says "Cannot create file state.dat. Please check disk space."

1. Launch the game.
2. Bypass the cinematics.
3. Then, at the main menu, it crashes.
Thanks guys for any help you can provide. I don't know what to do. Google and everything on it doesn't provide any help, so I guess it's pretty rare. I don't know what I can do if you guys can't help. Thanks!
Manwarrior Pt
posted 12-02-07 10:58 AM EDT (US)     575 / 618       
Good luck for you

No one helped me
« Previous Page  1 ··· 10 ··· 21 22 23 24 25  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Rise of Nations Heaven | HeavenGames