You must be logged in to post messages.
Please login or register

RoN Tech Support
Moderated by alincarpetman

Hop to:    
Welcome! You are not logged in. Please Login or Register.618 replies, Sticky
Rise of Nations Heaven » Forums » RoN Tech Support » Report Bugs here so they get fixed!
Bottom
Topic Subject:Report Bugs here so they get fixed!
« Previous Page  1 ··· 10 ··· 22 23 24 25  Next Page »
Scrubs
VIP
posted 05-21-03 02:25 PM EDT (US)         
I've noticed people complaining about not being able to play Rise of Nations because of bugs, patch problems... etc.

So... here's what the community can do to help BHG solve these issues and get them fixed.

1. Give a brief description of the problem. For example:
Game doesn't patch.

2. Give a detailed system analysis of you computer specs. To make this easier for people to find out what they have, go here and download the Belarc Advisor at www.belarc.com/free_download.html and/or just browse through your Device Manager.
For example:
1.8MGz Intel Pentium 4 (Win XP Pro. SP1 build 2600)
Dell OptiPlex GX240 MB with BIOS A03 03/01/2002
512MB RAM
40GB Hard Drive with 21.85GB Free Space.
NVIDIA GeForce4 Ti4400 with driver 4.3.4.5 03/20/2003
(Optional) Cable Modem w/Firewall... etc.
Rise of Nations retail (English version) build 01.13.04.1801
No mods, no cracks, no trainers... etc.

3. Give a more detailed description of the problem. For example:
When updating the patch through GameSpy, it will download 100% then bring me back to desktop and patch RoN until it reaches 37%, then it will stop and give me an "Invalid Patch File Error" and a "Retcode positive - 32769". I have the English version of the game.

4. Give reproduction steps on how to make it happen again. For example:
1. Launch the game.
2. Go to Multiplayer Game.
3. Go to GameSpy Internet Matchmaking.
4. Click "OK" when it says to upgrade to version 01.14.05.0902.
5. When the download is complete, log into GameSpy with your password.
6. Observe the game going to desktop and stopping at 37% during the patch process.

5. If it's a multiplayer game, be sure to specify if it was through GameSpy Arcade, GameSpy Internal, or LAN/IP. Then list the settings for the Multiplayer game. For example:
Teams of 3
Great Lakes
Large (5/6 player)
No Cannon Time
Custom
End Age: Gunpowder Age
Elimination: Conquest
Victory: Conquest
Tournament Play enabled.
3 Humans vs. 3 Computers (Moderate, Moderate, and Tough)
Nations in the game were:
Aztecs, Mongols, Chinese, Chinese, Egyptians, and Russians.

6. If it's a single player Quick Battle game, list the same steps as in #5. If it's a Conquer the World Single Player Campaign... list:
1. What your Nation is.
2. What difficulty setting you have.
3. What Age it was in.
4. What country you were attacking, and what battle type it was.
5. What build you're in... and what build you started your Campaign in. For instance, the retail is 01.13.04.1801, and the patch is 01.14.05.0902. Did you start a campaign in the retail version and save the campaign... and then upgrade to the patch and load the campaign?

If you see your bug listed here already from someone else, just give your #2. Computer Specs.

[This message has been edited by Scrubs (edited 05-21-2003 @ 05:29 PM).]

AuthorReplies:
The Naminator
Member
posted 12-03-07 00:18 AM EDT (US)     576 / 618       
Manwarrior thats more a problem of windows than RoN so try the main troublshooting forum:

http://www.heavengames.com/cgi-bin/forums/display.cgi?action=t&fn=11


Bllasae have tried launchong T&P or the normal RoN they are supposed to be located here:
C:\Archivos de programa\Microsoft Games\Rise of Nations
(I don't have the gold edition)

I stole this sign!
anubis679
Member
posted 12-18-07 06:46 AM EDT (US)     577 / 618       
I dont think this is a bug but it is a problem for me.

I recently downloaded some scenarios for RON from RON Heavens downloads section.

I unzipped them into the scenario folder under the RON directory.

But for some reason when I try to load them through RON I cannot see the load file. I can see the directories just fine but their isnt a .sce file to load for RON to see.

How do I fix this problem so I can play these scenarios?
H4N5
Member
posted 12-21-07 11:21 AM EDT (US)     578 / 618       
Same problem as ziplock67
When I try to load a saved game, RoN closes.

I don't have TaP
Windows Vista
1.8ghz Intel CPU
Geforce 6200LE
1024Mb RAM

Also, when I check the RoN version it says something like 0.0.0.0

-EDIT-

I reinstalled the game(choose reinstall in the unistall program) - No change

I uninstalled it completely, and installed it again - The version was 2.x.x.x (don't remember what it was exactly)

I tried to update, it asked me if I wanted to install version 2.4.x.x or something like that - Got an error about an invalid patch file -> version was again 0.0.0.0
So it is the same error as in the example, but I couldn't find the solution.

Also i found this webpage:
http://support.microsoft.com/kb/303032/en-us
It's about the closing error, when loading a saved game. I'm trying that out right now.

[This message has been edited by H4N5 (edited 12-22-2007 @ 06:12 AM).]

Nick990
Member
posted 12-24-07 02:19 PM EDT (US)     579 / 618       
I'm having a bit of a problem with RoN, suddenly. I've never had an issue before, yet when I tried to recently install it on my computer (I haven't had it on here in a while). There is not one file of any kind that concerns Rise of Nations on my computer at the moment, but every time I try to install it the same error message appears:

translated_string.xml not loaded file missing?

and then:

internal_string.xml not loaded file missing?

I've surfed the web a bit through a few forums, but I still can't seem to solve the issue. If anyone could help me I'd be extremely grateful, I would really like to play RoN again. Thanks.

[This message has been edited by Nick990 (edited 12-25-2007 @ 08:50 PM).]

The Naminator
Member
posted 01-08-08 03:15 PM EDT (US)     580 / 618       
In the original RoN version the fiel is loacted here:

C:\Program flies\Microsoft Games\Rise of Nations\data

The file is either corrupted or missing
A)you can search for it in the CD
B)reisntall the game

I stole this sign!
Nick990
Member
posted 01-11-08 09:17 PM EDT (US)     581 / 618       
That's my problem, the game is not on my computer at all. It hasn't been installed on here in a year or so. There is not one file located on my computer that has anything to do with Rise of Nations. When I go to install it, the error messages pop up. It won't even auto run, I need to go through my computer to get it working. So, there aren't any files on my computer that I can fix, replace, etc. Also, I obviously can't reinstall the game since there's no game to do so with. I've noticed quite a few with this similar issue, but all of them have the game on their computer already...I don't. It seems my issue is a tad unique, and irritating as a result. So, if you have any idea how to help me out, please do...I could use the help.
Reefa21
Member
posted 01-24-08 06:33 PM EDT (US)     582 / 618       
hello i have recently got myself a big ass widescreen hdtv. my computers workin perfectly on it and all other games run fine age of empires etc, normally by just lowering the resolution to 800 x 600 instead of 1024 x 768 to stop the flickering. But rise of nations has decided to be a bastard and not allow me to reduce the resolution any lower than 1024 x 768. any way to change this tried changin rise2.ini but dont work just came up with all the higher resolutions. I have a Radeon X800XT graphics card. Thx Reefa
The Naminator
Member
posted 01-26-08 12:02 PM EDT (US)     583 / 618       
Have you checked that Cd isn't dirty or scratch and to reefa the game isn't designed to run at 800x600.

I stole this sign!
Makesin
Member
posted 03-03-08 06:07 PM EDT (US)     584 / 618       
Hello, I have a text problem. Every button and some menus are without text and so the game is unplayable. I have the game installed a year ago and there was no problem.

I have RoN Gold without patches, mods etc., just clean game.
3GHz Intel Pentium 4 (Win XP Home SP2 build 2600)
1024MB Ram
NVIDIA GeForce FX 5900

I tried to install the game again, looked if fonts are ok but the problem is still there.

If you can't imagine, what's the problem, here are two images.
http://img227.imageshack.us/img227/4076/ron1vo0.jpg
http://img84.imageshack.us/img84/674/ron2vk8.jpg
Warrenf
Member
posted 03-17-08 05:14 PM EDT (US)     585 / 618       
Hi. I just went out and bought RON and the expansion pack T&P. I installed it fine but when I try to play I get the loading autoplay picture and then a window pops up with this message

"Rise of Nations has encountered a problem and needs to close. We are sorry for the inconvenience."

Then the game closes. The error signature or whatever is this if that helps.

AppName: patriots.exe AppVer: 3.2.3.2901 ModName: unknown
ModVer: 0.0.0.0 Offset: 00000000

My laptop should be able to play it. Here are the specs:

Operating System System Model
Windows XP Home Edition Service Pack 2 (build 2600) Hewlett-Packard Presario V3000 (EZ755UA#ABA)
Processor a Main Circuit Board b
1.60 gigahertz Intel Core Duo
64 kilobyte primary memory cache
2048 kilobyte secondary memory cache Board: Hewlett-Packard 30B2 61.40
Bus Clock: 667 megahertz
BIOS: Phoenix F.09 06/16/2006
Drives Memory Modules c,d

HL-DT-ST DVDRAM GSA-4084N [CD-ROM drive]
TE9248D XGU151K SCSI CdRom Device [CD-ROM drive]

HTS541080G9SA00 [Hard drive] (80.02 GB) -- drive 0 1016 Megabytes Installed Memory

Slot 'M1' has 512 MB
Slot 'M2' has 512 MB

If anyone can help or has had this problem before I would be very grateful. I love this game and it's sad that I can't play on my laptop.
El352nd
Member
posted 04-23-08 06:51 PM EDT (US)     586 / 618       
Hello, just recently reinstalled RoN and have run into an issue...

When I start up the game it plays the intro movies just fine, but when it gets to the first loading screen it will just freeze up, and give me a "Protection Error" message.
I have a retail copy of the game, so I dont understand why it is freezing and giving that error, on my older computer the game ran just fine.

My system specs are:

Model: Hp m7350n
Processor: Intel Pentium D Dual Core 2.8ghz
Ram: 2gb ddr2 sdram
Video: ati 512mb x1600
Storage: 250gb hard drive
OS: Windows XP media center edition

Edit: Also, I have no mods/expansions installed aside from Patch 3.

I read on Microsofts website that the "Safedisk" copy protection might need to be updated, so I downloaded their update and installed it, but it didnt fix this problem. I've also searched the web to no avail for the answer...

Any help or suggestions would be great!

El-

[This message has been edited by El352nd (edited 04-23-2008 @ 06:52 PM).]

NZRogeNZ
Member
posted 05-05-08 06:03 PM EDT (US)     587 / 618       
Hi I have RoN Gold with T&P. It is version 07.25.00.15705. I have updated it using the patch and although it updates it to ver 03.02.12.0800, when i try to use multiplayer over the LAN it still says it is using ver 07.25.00.15705. This measn i cant play my sone who has an original ver 03.02.12.0800.

Any suggestions?
Lungah
Member
posted 05-24-08 06:55 PM EDT (US)     588 / 618       
Hello, my problem is anytime I try and create a room for mutilplayer online people cant seem to make in into the setup screen. The number will go up for people in the room, but they just dont seem to make it thru. Now I have typed to some of them in the lobby and they tell me the same. That it just doesnt let them load into my created games lobby. So I can't ever set up teams or whatever and start the game. Now the game runs fine I never lag or anything and have a great computer and for the most part I can join into other peoples games no problem. Every now and then there will be a room that I try to log into and what happens to people trying to join my room will happen to me. It will just stay on connecting to room forever and will never actually load me into the room. Now it doesnt freeze up I can cancel the loggin and return back to the lobby. Please help me with this I have read up every where to try and fix it, but can't figure it out. thank you

You can email me at Lunagh13@gmail.com if you can give me any imformation to fix this problem. Would really appreciate it alot

[This message has been edited by Lungah (edited 05-24-2008 @ 06:58 PM).]

erikkukun
Member
posted 06-17-08 11:22 AM EDT (US)     589 / 618       
Massive FPS drops 10 minutes into playing RoN.

Hi there,

I'm playing Rise of Nations along with the Thrones and Patriots expansion installed. I am consistently getting the same issue over and over, no matter how I uninstall and re-install the game or uninstall Windows XP.

Here are my specs:

Dell Inspiron 6400/E1505 Laptop
1.7 GHZ duo core Intel.
ATI x1400 256 Meg Hypermemory card
2X 1Gig dual channel Kingston
100 Gig 5400 RPM laptop
Windows XP SP2 (installed after I uninstalled Vista)
Latest ATI 7.2, 7.4, 6.9 Catalyst installed and tried separately.

I scan regularly my machine for virii and spyware, so that's not an issue.

I have installed RoN before on the same machine a year ago, ran the game on HIGH and it ran flawlessly.

Now I am getting this issue:
1) Game installs perfectly.
2) Create CTW and select any random nation.
3) 5 minutes into the game, with HIGH settings, I am getting 59 frames per second.
4) 10 minutes into the game, the fps fluctuates and consistently drops.
5) 20 minutes into the game, the game drops to 20 fps.
6) When I start attacking a player, it will drop to 5-6 fps and become essentially unplayable.

I have no idea why this happens since my machine should be able to and has run this game flawlessly. I have tried installing all of the latest Catalyst drivers, even with Omega drivers. The issue remains.

I have tried reinstalling a clean copy of the game to no avail.
I have patched the game to 1.03 - no avail.
I have patched the game to 1.04 - no avail, same issue.

When I alt-tab to windows and check performance under the task manager, my cpu usage is at 100%. It then drops down to 54% and stays there.

I have tried modifying my page file - issue with dropped fps still remains.

I have tried disabling and unstalling my AV - doesn't work.
I have tried reverting to a previous version of ATI drivers - doesn't work.
Omega drivers don't work either.
With the ATI tool tray I have tried each and every customizable option (run everything high, AA, etc) still the fps drops continue.

The only obvious difference then when it ran flawlessly, and now, (albeit reformat of windows, etc) was that my machine was running it previously on 2X512 dual-channel ram.

Would this account for the issue?

ANY help would be highly, highly appreciated.

RoN is a excellent game and I'd love to be able to replay it if it weren't for this issue!

With my laptop I have played Call of Duty 2 and 4, Gears of war, Bioshock (med settings) and even Crysis (on low), so I know my machine is capable of running RoN.

Any and all help would be highly appreciated.

Thanks alot
brownryan97
Member
posted 06-29-08 08:01 PM EDT (US)     590 / 618       
um scrubs, for weeks I've been stressing because I've ordered the new gold edition,,, so i was psyched. i then downloaded both games the old rise of nations and the new one. the old rise of nations multilayer works fine, but i bought then new one because i liked the whole capital system. so i played the new one and everything went flawless but when i go into multilayer and play a game with people the game tells me connection failed. your game version(03.02.12.0800)does not match the sessions version(07.25.00.15705) please for someone who wants to play his new game could you help me? .
Cereal_Killa
Member
posted 09-11-08 06:20 PM EDT (US)     591 / 618       
lol i cant even update to 03.02.12.0800. i apply the patch and it gets to 72% and stops. "invalid patch file" "Retcode positive 32769" it says.

i can play fine on singleplayer and used to play fine on multiplayer too but now theres a new patch that wont install..

multiplayer used to be quite buggy. connections used to drop out and there were major problems getting all players from the hosting screen into an actual game, but @ least you could play some of the time.

now even that seems impossible..

Kiwi Clan http://kiwiclan.2.forumer.com/
[Live 4Eva or Die Tryin -CK]
Nederland
Member
posted 01-23-09 08:56 AM EDT (US)     592 / 618       
When i play RON for 30 to 60 Min ( or longer)
My laptop Shuts automaticlly down ..
And i down know whats the problem
iosubmihaitza
Member
posted 01-23-09 03:18 PM EDT (US)     593 / 618       
Enyone knows about sound loops in the game? This freezes my game even i disable sound.
esco79
Member
posted 01-26-09 00:09 AM EDT (US)     594 / 618       
i'm having the same problem as brownryan97. i get this error: your game version(03.02.12.0800)does not match the sessions version(07.25.00.15705)

my brother and i have both checked for updates and neither gets an update. which version is old and how do we update to the new one?

please help!!!
Red Revolution
Member
(id: master silver)
posted 01-27-09 05:22 PM EDT (US)     595 / 618       
Unistall game, reinstall game. My friend had a similar problem. A simple reboot of the game or reinstallation of the game worked for him when he couldn't update to T&P, so I would try reinstalling. Good luck and when you get it working go play online!

Amity/Enmity
halomonkey135
Member
posted 01-30-09 01:24 AM EDT (US)     596 / 618       
i'm having problems playing against another computer over LAN/Direct IP because it says we dont have the same version(but we both do(version 3.x.x.x(but i dont have the patch)))


i have tried patching both PC's, uninstalling and reinstalling both RON and RONTAP on both PC's and i have no idea what else to do!





Dell Inc. Vostro 1500

Windows XP Home SP2
Board: Dell Inc. 0WY040
Bus Clock: 200 megahertz
BIOS: Dell Inc. A05 02/03/2008
1.40 gigahertz Intel Core2 Duo
157.27 Gigabytes Usable Hard Drive Capacity
6.67 Gigabytes Hard Drive Free Space
PBDS DVD+-RW DS-8W1P [CD-ROM drive]
WDC WD1600BEVS-75RST0 [Hard drive] (160.04 GB)
2046 Megabytes Installed Memory
Slot 'DIMM_A' has 1024 MB
Slot 'DIMM_B' has 1024 MB
NVIDIA GeForce 8400M GS

[This message has been edited by halomonkey135 (edited 01-30-2009 @ 11:21 PM).]

Red Revolution
Member
(id: master silver)
posted 01-31-09 03:24 PM EDT (US)     597 / 618       
i dont have the patch
Try getting the patch for both, that would ensure that you definitely have the same version for each. The patch is free and you can get it simply by clicking on the gamespy matchmaker under multiplayer on the Thrones and Patriots expansion version. If you have normally RON then I don't know, but if you get the most recent patch for both that might make it work.

Amity/Enmity
vivalaryan54
Member
posted 05-30-09 08:10 PM EDT (US)     598 / 618       
My Problem:
Whenever I host a game (Rise of Nations Gold Edition), no one ever joins. I go to the lobby and look at my game and it will say 4/6 or a number like that. I put my mouse on the number and it says whoever is trying to join my room. I wait for a long time and no one ever appears in the staging room. This happens for every combination whenever I try to host a game. I can join games but I cannot host. Please help. Thank you. If Rise of Nations Heaven does not send an email alert when your question is answered could the answer be emailed to vivalaryan54@gmail.com
Thank You
wreslinga2
Member
posted 12-02-09 01:24 AM EDT (US)     599 / 618       
i have just installed ron and after the intro the following error pops up..
graphics services failed to initialized please make sure your video card and drivers are compatible with rise of nations

my pc has all the minimum requirements
i have intel dual core 2.2mzh...
2 gb ram
nvidea geforce 8400gs-512mb video card

all the games have been running perfectly.........please suggest a way to fix it.......
Crue Knight
Divine Favor
(id: Crusader Knight)
posted 12-02-09 01:03 PM EDT (US)     600 / 618       
wreslinga:

First go to: http://www.nvidia.com/Download/index.aspx?lang=en-us

Select your graphics card and install the latest driver.

Also install the latest version of DirectX: http://www.microsoft.com/windows/directx/default.mspx


EPIC MOD
IS EPIC!``?

Ex mod on: Spore - HG - RoN - RoL - N:TW
Check out my: DeviantArt - Steam
« Previous Page  1 ··· 10 ··· 22 23 24 25  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Rise of Nations Heaven | HeavenGames