You must be logged in to post messages.
Please login or register

RoN Tech Support
Moderated by alincarpetman

Hop to:    
Welcome! You are not logged in. Please Login or Register.618 replies, Sticky
Rise of Nations Heaven » Forums » RoN Tech Support » Report Bugs here so they get fixed!
Bottom
Topic Subject:Report Bugs here so they get fixed!
« Previous Page  1 ··· 10 ··· 23 24 25  Next Page »
Scrubs
VIP
posted 05-21-03 02:25 PM EDT (US)         
I've noticed people complaining about not being able to play Rise of Nations because of bugs, patch problems... etc.

So... here's what the community can do to help BHG solve these issues and get them fixed.

1. Give a brief description of the problem. For example:
Game doesn't patch.

2. Give a detailed system analysis of you computer specs. To make this easier for people to find out what they have, go here and download the Belarc Advisor at www.belarc.com/free_download.html and/or just browse through your Device Manager.
For example:
1.8MGz Intel Pentium 4 (Win XP Pro. SP1 build 2600)
Dell OptiPlex GX240 MB with BIOS A03 03/01/2002
512MB RAM
40GB Hard Drive with 21.85GB Free Space.
NVIDIA GeForce4 Ti4400 with driver 4.3.4.5 03/20/2003
(Optional) Cable Modem w/Firewall... etc.
Rise of Nations retail (English version) build 01.13.04.1801
No mods, no cracks, no trainers... etc.

3. Give a more detailed description of the problem. For example:
When updating the patch through GameSpy, it will download 100% then bring me back to desktop and patch RoN until it reaches 37%, then it will stop and give me an "Invalid Patch File Error" and a "Retcode positive - 32769". I have the English version of the game.

4. Give reproduction steps on how to make it happen again. For example:
1. Launch the game.
2. Go to Multiplayer Game.
3. Go to GameSpy Internet Matchmaking.
4. Click "OK" when it says to upgrade to version 01.14.05.0902.
5. When the download is complete, log into GameSpy with your password.
6. Observe the game going to desktop and stopping at 37% during the patch process.

5. If it's a multiplayer game, be sure to specify if it was through GameSpy Arcade, GameSpy Internal, or LAN/IP. Then list the settings for the Multiplayer game. For example:
Teams of 3
Great Lakes
Large (5/6 player)
No Cannon Time
Custom
End Age: Gunpowder Age
Elimination: Conquest
Victory: Conquest
Tournament Play enabled.
3 Humans vs. 3 Computers (Moderate, Moderate, and Tough)
Nations in the game were:
Aztecs, Mongols, Chinese, Chinese, Egyptians, and Russians.

6. If it's a single player Quick Battle game, list the same steps as in #5. If it's a Conquer the World Single Player Campaign... list:
1. What your Nation is.
2. What difficulty setting you have.
3. What Age it was in.
4. What country you were attacking, and what battle type it was.
5. What build you're in... and what build you started your Campaign in. For instance, the retail is 01.13.04.1801, and the patch is 01.14.05.0902. Did you start a campaign in the retail version and save the campaign... and then upgrade to the patch and load the campaign?

If you see your bug listed here already from someone else, just give your #2. Computer Specs.

[This message has been edited by Scrubs (edited 05-21-2003 @ 05:29 PM).]

AuthorReplies:
lolcatz31
Member
posted 12-02-09 05:38 PM EDT (US)     601 / 618       
certain graphics cards cannot play RoN. so if what crue said worked please let us know.

mewp: a word to describe awesomeness in its supreme form.

EoB Heraclies gets a hard-on from noobs.

Damn, you got me. I just wish I knew how to make quality threads like you do. -Blatant7
wreslinga2
Member
posted 12-03-09 02:06 AM EDT (US)     602 / 618       
i have downloaded the latest drivers and it installed perfectly........i can play cod:5 nut not ron????????
plz suggest dome other way........just bought the game recently............
lolcatz31
Member
posted 12-03-09 06:18 AM EDT (US)     603 / 618       
i dunno the website but check and make sure your graphics card is compatable with ron.

mewp: a word to describe awesomeness in its supreme form.

EoB Heraclies gets a hard-on from noobs.

Damn, you got me. I just wish I knew how to make quality threads like you do. -Blatant7
Crue Knight
Divine Favor
(id: Crusader Knight)
posted 12-03-09 12:15 PM EDT (US)     604 / 618       
Nvidia should be able to play RoN. (I have Nvidia)

I think I had a similar problem to yours when I played with my old ATI computer.
Did you try to change the resolution and color settings?

Also:
Try the following:

1) Use the RUN command to load DXDIAG.

2) Click on the DISPLAY Tab.

3) If Direct3D Acceleration is disabled, enable it. If Direct3D Acceleration is enabled, disable it, then enable it.

4) Click the TEST DIRECT3D button and test all three interfaces (7, 8, and 9).

Sometimes Direct3D Acceleration will say it is enabled, when in fact it is disabled. Disabling, then enabling clears the problem.
If all fails,
Try to go through this list: http://support.microsoft.com/kb/820089

That's all I have to give right now. I am sorry if it doesn't work and I will post if I find some more.
I know tons of people have graphical problems with RoN and I wish they could still try to fix it.


EPIC MOD
IS EPIC!``?

Ex mod on: Spore - HG - RoN - RoL - N:TW
Check out my: DeviantArt - Steam
Coldwar Warrior
Member
posted 02-22-10 09:15 PM EDT (US)     605 / 618       
ok? it fixed itself :S

[This message has been edited by Coldwar Warrior (edited 02-23-2010 @ 08:30 PM).]

mayathon
Member
posted 07-28-11 03:28 PM EDT (US)     606 / 618       
I have had Rise of Nations for about three years now. After a recent victory as the Egyptians, I became unable to use bonus cards during attacks and defenses in Conquer The World campaigns. Wonder of the world, treachery, and sabotage cards still work on the global map but cards like eureka and mercenaries are now useless. It should be noted that as a result of the above campaign, I have now completed CTW with each of the available nations.

I am using the original retail version (no updates/service patches) of RoN. Any attempts to use the provided in game updater leads to the game trying to download all of the patches at the same time, which causes RoN to become unplayable.

System Specs:
HP Pavilion dv6930us Laptop
Vista Home Premium SP 2 64-bit
4 GB Ram
Intel Core2 Duo processor T5750 @ 2GHz

[edit] I should have mentioned that these bugs only just occurred within the last 2 weeks and that they are the first bugs I've ever encountered in this wonderful game.

[This message has been edited by mayathon (edited 07-28-2011 @ 03:30 PM).]

frankdtank16
Member
posted 10-02-11 11:20 PM EDT (US)     607 / 618       
1. When I open up the main screen the pointer image doesn't move from the middle of the screen, but the mouse moves invisibly.

2. Windows 7 64-bit
4GB of RAM
Intel Core 2 Duo T9550 2.66 GHz
Rise of Nations retail (English version) build 01.13.04.1801

(edit) I forgot to add, I think it might have to do with Windows 7 64 Bit OS. I've had the game for a long time, and I never had any problems with it when I was running Vista Home Premium. Hope that helps.

3.
When I try to update the patch through GameSpy, it will download 100% then bring me back to desktop and patch RoN until it reaches 37%, then it will stop and give me an "Invalid Patch File Error" and a "Retcode positive - 32769". I have the English version of the game.

4.
Launch the game.
After the movies it goes to the main screen
Once it gets to the main screen the pointer stays in the middle of the screen even when I move the mouse. And I can't do anything further.

[This message has been edited by frankdtank16 (edited 10-02-2011 @ 11:30 PM).]

bongsound
Member
posted 03-18-13 07:34 PM EDT (US)     608 / 618       
1. Graphics Services failed to initialize

2. MB: Asus P7P55D-e lx
CPU: i3-540 3.8GHz
RAM: 4GB DDR3
GFX: Gigabyte 560, drivers-314.07
HDD: 230GB free

3. When I load RON the 3 short animations show then it
crashes to desktop and gives this error "Graphics services
failed to initialize..."

4. A: Launch game
B: Watch/Skip animation screens
C: Game Crashes and give error
gerarrdway
Member
posted 11-09-13 07:14 AM EDT (US)     609 / 618       
I am new,anyone experience this:
http://imgur.com/1bWjt1w


i already try everything(uninstalling,,reinstalling,etc,etc),every suggestion,even on microsoft sites about MSXML 4

my Rise of Nations always ended like that

Windows 7 64bit
Nvidia GT540M

[This message has been edited by gerarrdway (edited 11-09-2013 @ 07:15 AM).]

ali96hamad
Member
posted 03-25-14 09:26 AM EDT (US)     610 / 618       
Windows 8 (x64) (build 9200)
Install Language: English (United States)
System Locale: Arabic (Lebanon)
Installed: 25/11/2013 01:34:16 ?
Boot Mode: UEFI with successful Secure Boot LENOVO 20245 Lenovo G500s
System Serial Number: 3151150803459
Chassis Serial Number: CB22946577
Enclosure Type: Notebook
Processor a Main Circuit Board b
2.60 gigahertz Intel Core i5-3230M
64 kilobyte primary memory cache
256 kilobyte secondary memory cache
3072 kilobyte tertiary memory cache
64-bit ready
Multi-core (2 total)
Hyper-threaded (4 total) Board: LENOVO 31900003WIN8 STD MLT
Serial Number: CB22946577
Bus Clock: 100 megahertz
UEFI: LENOVO 7BCN21WW(V1.05) 04/18/2013
Drives Memory Modules c,d
976.23 Gigabytes Usable Hard Drive Capacity
855.57 Gigabytes Hard Drive Free Space

MATSHITA DVD-RAM UJ8C2 [Optical drive]
Microsoft Virtual DVD-ROM [Optical drive]

ST1000LM024 HN-M101MBB [Hard drive] (1000.20 GB) -- drive 0, s/n S2SMJ9CD428371, rev 2AR20002, SMART Status: Healthy
hi everybody first i installed the game on my xp computer clicked on the registery and then the game worked now on my windows 8 laptop i did the same thing i clicked on the registery and every time i trie to run the game they say error running game please first install the game from cd when i click on version file they say somthing like thrones and patriots is not recogniezed as an iternal or external command from an other cd i installed in an other folder rise of nation and then rise of nations worked in the first folder but thrones didnt then i downloaded a patriots.exe file from the internet and had replaced the old one by him but still the same thing please first install game from cd please help me solving this problem

[This message has been edited by ali96hamad (edited 03-25-2014 @ 09:30 AM).]

MrMew
Huskarl
posted 03-26-14 00:46 AM EDT (US)     611 / 618       
I once had a tank moving with the sound of galloping for its movement, does that count? Only happened once.

Time of Tea
Still in the Dark Age
Don't be a melodramatic clown. ~Mr Wednesday
ali96hamad
Member
posted 04-04-14 11:14 AM EDT (US)     612 / 618       
please help
view page 25
Terikel Grayhair
Imperator
(id: Terikel706)
posted 04-08-14 02:55 AM EDT (US)     613 / 618       
Hail Ali,

Sounds like a Windows problem. Have you tried a compatibility setting?
If it worked on XP, but not on Windows 8, then maybe setting the compatibility to XP might fix it.

I do not use Windows 8, so I cannot help more than that. Sorry. Maybe somebody else can pitch more ideas?

|||||||||||||||| A transplanted Viking, born a millennium too late. |||||||||||||||||
|||||||||||||||| Too many Awards to list in Signature, sorry lords...|||||||||||||||||
|||||||||||||||| Listed on my page for your convenience and envy.|||||||||||||||||
Somewhere over the EXCO Rainbow
Master Skald, Order of the Silver Quill, Guild of the Skalds
Champion of the Sepia Joust- Joust I, II, IV, VI, VII, VIII
ali96hamad
Member
posted 04-22-14 02:14 AM EDT (US)     614 / 618       
i changed compability and nothing worked please help
sellavie
Member
posted 11-05-14 01:38 PM EDT (US)     615 / 618       
Hello there,

I have an IMAC 21,5 bought end 2013. I have bought rise of nations through steam. Now i would like to play RON through cross over games(mac), but i get this message when i start up the game:

BHG RTS run time FATAL
Could not initialize DirectX! Please make sure your system supports Direct X 10 or higher!
(click retry to debug, ignore to turn this message off and continue)

Can someone please help me with this? I Tried to install direct X9 with cross over and steam. But i probably need x10, but that is not in the supported list of cross over. I try to find it on the web, but i have no succes.

Thank you in advance
Terikel Grayhair
Imperator
(id: Terikel706)
posted 11-06-14 03:07 AM EDT (US)     616 / 618       
DirectX version 11.2 is the latest, and was shipped with all new computers that had Windows Vista or later pre-installed.

DirectX 9.0c was the highest used by XP, from 10.0 you needed Vista or better because of the new software requirements that Vista introduced.

I do not know if MAC has something comparable, but seeing how DirectX is a Windows program and Windows and Macs do not get along, I think you need to contact a MAC specialist (or Google it yourself).

Sorry for the bad news.

|||||||||||||||| A transplanted Viking, born a millennium too late. |||||||||||||||||
|||||||||||||||| Too many Awards to list in Signature, sorry lords...|||||||||||||||||
|||||||||||||||| Listed on my page for your convenience and envy.|||||||||||||||||
Somewhere over the EXCO Rainbow
Master Skald, Order of the Silver Quill, Guild of the Skalds
Champion of the Sepia Joust- Joust I, II, IV, VI, VII, VIII
DictatorDog
Member
posted 11-15-14 05:52 AM EDT (US)     617 / 618       
Weird graphics bug !

System specs :
Windows 7 Home Premium (x64) Service Pack 1 (build 7601)
2,90 gigahertz Intel Core i5-4210H
HL-DT-ST DVDRAM GTA0N SCSI CdRom Device [Optical drive]
WDC WD5000LPVX-22V0TT0 [Hard drive] (500,11 GB) -- drive 0, s/n WD-WXQ1E34KPTL6, rev 01.01A01, SMART Status: Healthy
Intel(R) HD Graphics 4600 [Display adapter]
8 GB RAM
500,11 Gigabytes Usable Hard Drive Capacity
249,68 Gigabytes Hard Drive Free Space
No mods, etc.

When I launch the game and start a new game or go to the options menu, my screen gets all weird and gammy. It happens on a standard single-player game : http://postimg.org/image/k41s9g503/ as well as in the options menu : http://postimg.org/image/y4nwx38y5/ .
However, what's weird is that it works fine in the 'Graphics' and 'Player' tabs : http://postimg.org/image/gc5inkqrt/

What is going on ?

[This message has been edited by DictatorDog (edited 11-15-2014 @ 05:54 AM).]

Terikel Grayhair
Imperator
(id: Terikel706)
posted 11-20-14 05:08 AM EDT (US)     618 / 618       
Beats me.

I think it might be a setting though. A lot of times when a game has Anti-Aliasing on, it makes funky-looking screenshots (totally black) and during the game makes streaks or blocky feet on people, or other wierd things.

Check your in-game settings, sine this appears on some occasions like in the game or a pre-game menu, but not in others (Options, etc). It is definitely game-related, and that means check settings first.

If that doesn't work, try creating a thread in the Game forum- someone else might have experienced this and can give you better advice.

|||||||||||||||| A transplanted Viking, born a millennium too late. |||||||||||||||||
|||||||||||||||| Too many Awards to list in Signature, sorry lords...|||||||||||||||||
|||||||||||||||| Listed on my page for your convenience and envy.|||||||||||||||||
Somewhere over the EXCO Rainbow
Master Skald, Order of the Silver Quill, Guild of the Skalds
Champion of the Sepia Joust- Joust I, II, IV, VI, VII, VIII
« Previous Page  1 ··· 10 ··· 23 24 25  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Rise of Nations Heaven | HeavenGames