You must be logged in to post messages.
Please login or register

RoN Tech Support
Moderated by alincarpetman

Hop to:    
Welcome! You are not logged in. Please Login or Register.618 replies, Sticky
Rise of Nations Heaven » Forums » RoN Tech Support » Report Bugs here so they get fixed!
Bottom
Topic Subject:Report Bugs here so they get fixed!
« Previous Page  1 ··· 3 4 5 6 7 ··· 20 ··· 25  Next Page »
Scrubs
VIP
posted 05-21-03 02:25 PM EDT (US)         
I've noticed people complaining about not being able to play Rise of Nations because of bugs, patch problems... etc.

So... here's what the community can do to help BHG solve these issues and get them fixed.

1. Give a brief description of the problem. For example:
Game doesn't patch.

2. Give a detailed system analysis of you computer specs. To make this easier for people to find out what they have, go here and download the Belarc Advisor at www.belarc.com/free_download.html and/or just browse through your Device Manager.
For example:
1.8MGz Intel Pentium 4 (Win XP Pro. SP1 build 2600)
Dell OptiPlex GX240 MB with BIOS A03 03/01/2002
512MB RAM
40GB Hard Drive with 21.85GB Free Space.
NVIDIA GeForce4 Ti4400 with driver 4.3.4.5 03/20/2003
(Optional) Cable Modem w/Firewall... etc.
Rise of Nations retail (English version) build 01.13.04.1801
No mods, no cracks, no trainers... etc.

3. Give a more detailed description of the problem. For example:
When updating the patch through GameSpy, it will download 100% then bring me back to desktop and patch RoN until it reaches 37%, then it will stop and give me an "Invalid Patch File Error" and a "Retcode positive - 32769". I have the English version of the game.

4. Give reproduction steps on how to make it happen again. For example:
1. Launch the game.
2. Go to Multiplayer Game.
3. Go to GameSpy Internet Matchmaking.
4. Click "OK" when it says to upgrade to version 01.14.05.0902.
5. When the download is complete, log into GameSpy with your password.
6. Observe the game going to desktop and stopping at 37% during the patch process.

5. If it's a multiplayer game, be sure to specify if it was through GameSpy Arcade, GameSpy Internal, or LAN/IP. Then list the settings for the Multiplayer game. For example:
Teams of 3
Great Lakes
Large (5/6 player)
No Cannon Time
Custom
End Age: Gunpowder Age
Elimination: Conquest
Victory: Conquest
Tournament Play enabled.
3 Humans vs. 3 Computers (Moderate, Moderate, and Tough)
Nations in the game were:
Aztecs, Mongols, Chinese, Chinese, Egyptians, and Russians.

6. If it's a single player Quick Battle game, list the same steps as in #5. If it's a Conquer the World Single Player Campaign... list:
1. What your Nation is.
2. What difficulty setting you have.
3. What Age it was in.
4. What country you were attacking, and what battle type it was.
5. What build you're in... and what build you started your Campaign in. For instance, the retail is 01.13.04.1801, and the patch is 01.14.05.0902. Did you start a campaign in the retail version and save the campaign... and then upgrade to the patch and load the campaign?

If you see your bug listed here already from someone else, just give your #2. Computer Specs.

[This message has been edited by Scrubs (edited 05-21-2003 @ 05:29 PM).]

AuthorReplies:
Aginor
Member
posted 05-29-03 08:20 AM EDT (US)     101 / 618       
1. My problem is that sometimes my screen just blacks out in the middle of a game. When I press Escape I can hear the sound of the exit game screen coming up, but I don't know if it actually does (after all, my screen is black). I can also hear other game sounds, but I'm not sure if the game actually continues since I can't see it. This didn't happen every time btw (I've finished a couple of games) but it happened 3 times last night so I thought I should ask for some help. No error message comes up and no crashes to desktop occur. I'm forced to either use Ctrl-Alt-Del or to turn off my computer. Alt-tab doesn't work. It usually occurred in the Middle Ages or the Gunpowder Age, usually 30 minutes into a game.

2. My specs are:

1000 megahertz Intel Pentium III
ASUS TUSL2-C ACPI BIOS Revision 1007.A 06/08/2001
256 MB RAM
Directx 9.0a installed
Matrox Millennium G550 32 MB videocard (latest drivers)
DELL M990 [Monitor] (17.7"vis, s/n 1238P05UB00E, May 2000)
Soundblaster 4.1 digital soundcard
20,38 Gigabytes Usable Hard Drive Capacity
4,99 Gigabytes Hard Drive Free Space
ATAPI-CD ROM-DRIVE-52MAX [CD-ROM drive]
OS: Windows 98 SE (build 4.10.2222)
Rise of Nations retail version (I live in Europe, normal English version, no mods, no patches)
Firewall: ZoneAlarm Pro
Anti-virus: Norton Anti-virus 2002
Nothing is overclocked.

3. See 1

6. Quick Battle Game

Germans
Easy
Diplomacy with maximum amount of comp. opponents
Random Oceans
Huge map
All ages
Wonder victory disabled
Computer Nations: Random
Conquest and Territory victory enabled

Hope you can help .

[This message has been edited by Aginor (edited 05-29-2003 @ 08:41 AM).]

jbestimt
VIP
posted 05-29-03 08:38 AM EDT (US)     102 / 618       
Another update....
For AMD users who are seeing the lock up problem, please try installing the Large Page Minimum patch, http://www.amd.com/us-en/Processors/ProductInformation/0,,30_118_756_759^871^2367,00.html . A user on another forum had success vs. lockups.

The multiplayer lag issue is being addressed in patch 2. It is caused by a inadequate voltaged power supply that, in turn, causes the system clocks to go way out of sync.



Jason Bestimt
Programmer
Big Huge Games
kilaj1
Member
posted 05-29-03 11:04 AM EDT (US)     103 / 618       
I have that CTW problem. the suggestions in other post says you should change the color 16 bit to 32 bit or visa versa, well it did work..but after I took 2 countries, it came back and i changed the color depth again and same problems. I have a TNT2 32MB card, noticed in other post that people have that problem with this card.
rustymooshu
Member
posted 05-29-03 12:34 PM EDT (US)     104 / 618       
Hi friendly helper!

I keep getting a "gathering exceptional data", which forces my system to shut down, and at the very least ends my game. In fact this occurs with both the trial and bought game.

system specs:

PIII 733
256 RAM
TNT Riva 32mg Nvidia card
Soundblaster live

Me so frustrated

jbestimt
VIP
posted 05-29-03 01:50 PM EDT (US)     105 / 618       
kilaj1, the bug stems from generating the map that a CtW game is played on (from combining the indivdual country maps). Gotta be 32-bit until the patch comes out.

rustymooshu, when are you getting the exception? Start up? CtW? In game?


Jason Bestimt
Programmer
Big Huge Games
kilaj1
Member
posted 05-29-03 02:43 PM EDT (US)     106 / 618       
Thanks...bu thats the thing...it did work when I was in 32bit for about 2 maps, then the error came back.
rustymooshu
Member
posted 05-29-03 04:28 PM EDT (US)     107 / 618       

Hi friendly helper!
I keep getting a "gathering exceptional data", which forces my system to shut down, and at the very least ends my game. In fact this occurs with both the trial and bought game.

system specs:

PIII 733
256 RAM
TNT Riva 32mg Nvidia card
Soundblaster live

Me so frustrated


I am getting the exception anywhere from 5 to 60 minutes into a game. CTW? I don't think I get this, but then again what the heck is it. The only error message I get is:
Gathering exceptional data, which of course forces a shutdown of the game. Mind you, I also do experience the minimizing game that i think requires shutting down the opening movie, which I will try tonight. Sigh.. I wish I was better at computers. The prospect of changing files and stuff kinda freaks me out.. such a tech looser lol.

thanks again for your help all!

DS

rahba
Member
posted 05-30-03 03:16 AM EDT (US)     108 / 618       
I found a reproducible bug in the demo playback. I was watching the playback of a match where I had just defeated one of the AI civs. After conquering all of his territory his water based oil refineries were ceded to me. Next to each of the refineries were transports with his worker. The second I click on them during the demo playback the game crashes to the desktop with an exception error message.
Kharn
Member
posted 05-30-03 09:50 AM EDT (US)     109 / 618       
I found a bug (maybe) tonight. We were playing a 3v3, where midway through, someone's connection got dropped. The people decided to quit the game and not continue it. When I went back to view the demo, when I get to the part where the guy is about to drop from the game, RoN crashes and brings me back to the desktop. This is reproducable on my computer. I don't know if it was just a single instance of a corrupted demo, or if this is a larger issue of demos getting corrupted when a player gets dropped. Has anyone else experienced this? Has anyone been able to successfully view a demo after a game where a player got disconnected?

This was with the latest RoN patch downloaded through gamespy and all the latest video / audio drivers. I've been able to play all other demos perfectly fine.

[This message has been edited by Kharn (edited 05-30-2003 @ 09:59 AM).]

petachoks
Member
posted 05-30-03 03:48 PM EDT (US)     110 / 618       
Hello. I read the mouse flickering problem and how to solve it, but here is my question. I also have a flickering cursor, but it starts flickering about 30 minutes into the game. I can't understand why. If it works, it works, if it doesn't it doesn't but how can you explain it working half way and not working half way.
Before I read this tread here is how I fixed the problem. 30 minutes into the game when the mouse starts flickering I paused the game. Then I pressed AltTAB to exit to windows. From there I went to Display Properties and changed from 16 bits to 32 bits or vice versa. Then when I logged back into the game by pressing AltTAB, the mouse was fine.
Does your mouse start flickering right when you start the game or after a few minutes?

[This message has been edited by petachoks (edited 05-30-2003 @ 04:05 PM).]

gizmo007
Member
posted 05-30-03 05:50 PM EDT (US)     111 / 618       
My game works fine with the exception of locking up every once in awhile. But no matter what, every time I go into SOlo game - Conquer the world my game drops and I end up back on the desktop.
Does anyone know how to fix this problem?? Am I the only one with this problem?

I am disappointed after paying $50 for a game that doesn't work...perhaps you should have delayed releasing the game until everything was fixed. It looks like there are MANY problems with the game.

lavalamp
Member
posted 05-31-03 01:32 AM EDT (US)     112 / 618       
I think im having a common problem. Whenever i try to start the game, i get the globe splash screen, then the screen goes black, then im tossed back to the windows desktop with rise of nations sitting in the toolbar. It stays minimized and doesnt come back up no matter what i do. The strange thing is, the game worked perfectly fine the first few time I tried playing it.


My system:

Intel pentium 4, 1.7 ghz
512 RAM
Geforce4 ti 4600
soundblaster audigy 5.1
Windows ME

Thanks to anyone who replies.

ilsjaro
Banned
posted 05-31-03 12:05 PM EDT (US)     113 / 618       
The bug is back. "Debugger detected. Unload debugger and try again."
I managed to play one game smoothly, but when I tried to start up the game the next time, I got the same error message. I disabled the McAfee virus scanner, which at first seemed to help, but now I got the same error.
Another strange thing happened. A friend told me that in some cases it may help to alter the .ini file (skipping the intro movies). The only thing is that there are no .ini files?????? There should be a rise.ini and a rise2.ini. Both do not appear in the RON folders.
Is it possible that I've got a corrupted disc?

system:
P4 2.8, 1024MB DDR 333, ATI Radeon 9700 Pro, Soundblaster Audigy 2 Platinum. Gigabyte Intel 845PE motherboard, Socket 478
Windows XP Pro 5.1.2600 SP 1 build 2600
Latest ATI drivers (May 15, 2003)

COSIAN
Member
posted 05-31-03 01:24 PM EDT (US)     114 / 618       
Playing Quick Learn

Game crashes to desktop with no errors or indication of problem after a short time. Time varies between 10 and 30 minutes. Does not seem to be related to a specific action.

RON Version 01.14.05.0902
Win 2K Service Pak 3 with most available hot fixes installed
Installed DirectX9 that came with RON

1533 Mhz AMD Athalon
30 Gig Maxtor with 25 Gig free
52x24x52 CDRW
Chaintech 761-8231 at 133 Mhz VIA Chipset
Award BIOS 6.0 05/09/2001
512 Meg DDR 2100 / single chip
Realtek RTL8139 PCI Fast Ethernet
NVIDIA GEforce 4 MX 440 with 128 DDR AGP8X (Operating at 4X)
NVIDIA Drive 4.1.03 (I note there is 4.4.03 avail..will try)
On Board Audio CMI8738/C3DX PCI

rocket_magnet
Member
posted 05-31-03 01:37 PM EDT (US)     115 / 618       
to jbestimt
i have been getting the freeze/crash errors described by others, in solo battle, using british vs aztecs(easy), on british isles... but i am on win xp and it can happen anywhere in the sapce of 10 mins-30mins, i get a very horrible screeching noise through my speakers, which lead me to believe it was a sound problem, but even with my card disabeld i still crash any ideas?... heres the specs, running dx9.0a aswell, and 44.03 drivers

Windows XP Professional (build 2600)
ECS K7S5A 1.0
Processor a Main Circuit Board b
1666 megahertz AMD Athlon XP
128 kilobyte primary memory cache
256 kilobyte secondary memory cache Board: ECS K7S5A 1.0
Bus Clock: 66 megahertz
BIOS: American Megatrends Inc. 07.00T 04/02/01
Drives Memory Modules c,d
30.75 Gigabytes Usable Hard Drive Capacity
10.39 Gigabytes Hard Drive Free Space

HL-DT-ST DVD-ROM GDR8161B [CD-ROM drive]
SONY CD-RW CRX220E1 [CD-ROM drive]
3.5" format removeable media [Floppy drive]

Maxtor 6E030L0 [Hard drive] (30.75 GB) -- drive 0 384 Megabytes Installed Memory

Slot '0' has 256 MB
Slot '1' has 128 MB
Slot '2' is Empty
Slot '3' is Empty
Local Drive Volumes

c: (on drive 0) 30.75 GB 10.39 GB free
NVIDIA GeForce4 Ti 4200 [Display adapter]
Nokia 446Xt [Monitor] (17.7"vis, s/n 9909006920, February 1999)
Creative Game Port
Creative SB Audigy(audigy2 platinum)
MPU-401 Compatible MIDI Device
SiS 7012 Audio Driver
Standard Game Port

[This message has been edited by rocket_magnet (edited 05-31-2003 @ 01:39 PM).]

ilsjaro
Banned
posted 05-31-03 02:56 PM EDT (US)     116 / 618       
OK, using the fix from GCW (replacing nations.exe)does help with my initial problem (debugger detected). RON does start up now, but I do not get any further than the menue screens.
When I try starting the Learn, Quickplay or CTW, I see the loading bar fill up till the end and then my screen turns black. My cursor is still visible and working, but that's about it. The only way to get out of RON is by doing a hard reset using the power switch.

BTW the lost .ini files only appeared after 2 fresh installs, so I still think there is something seriously wrong with the disc or with the installation programme. I've never had this problem before. (It's not the CD-rom drive, as I have 2 - different brands -in my system and it's hard to believe that both are not working properly.)

pajy
Member
posted 05-31-03 05:15 PM EDT (US)     117 / 618       
hello Ilsjaro, what patch are you talking about.. can you tell me the website pls pls..

Thank you.. I think I might have the same problem as you

Many Thanks

crispee
Member
posted 05-31-03 06:37 PM EDT (US)     118 / 618       
Downloaded the 1.01 patch off Gamespot. Installed fine. But nothing has been fixed (at least the problems that I have). The game still freezes randomly 2-20 minutes into the game. I can't even get to the Classical age. tried with the sound off and it still crashed. I have an ATI Radeon 8500 with the latest drivers installed, Dell 8100, A09 BIOS, 512 RAM. The game even crashed while PAUSED!!! How that is possible I don't know.

I've had problems with games before but they were always solved by the latest graphics drivers or something else. This is by far the worst thing I have ever had.

MrAnon
Member
posted 05-31-03 07:08 PM EDT (US)     119 / 618       
ILSJARO: You can't see the .ini files because you have your folder options set to not display system files; .ini files are considered system files. The solution to this is to open Windows Explorer, then choose View>Folder Options>View and move the radio button under "Hidden Files" to "Show all files". Click OK all the way out and close Windows Explorer. When you reopen Windows Explorer you should be able to see your .ini files.

Your "debugger loaded" message tells me that something is running in the background and interfering with RoN. Press CTL-ALT-DEL to see what's running. Most of the things you'll see load at startup and help programs load faster, but nuke your available RAM and are not needed.

ALL: Look for the stuff running in the background on your machines! I haven't seen it mentioned by anyone yet, but for most of these problems that's the first thing I'd look for if you were paying me to troubleshoot it.

EclipseV
Member
posted 05-31-03 10:03 PM EDT (US)     120 / 618       
hi.


This is a csuggestion for BHG to improveth end of play options.

I have already posted a few thing on this thread, so i wont go into all ofthe problems, needless to say, i only hope that one of you is reading this.

as things are, whenever you are in a multiple player game like 4-8 players, you are not permitted to view any of the ensuing battles after you drop out or are defeated.

I would very much like this to be fixed...

if i can not chat, at least i can watch the game.

also maybe you could create an observer option.
and for this, it would be much better if observers were not included in tthe total player count.

this way you could do3v3 or 4v4 games and have 8-10 observers watch.

This woudl be a SUPREME ACCOMPLISHMENT for RTSS games...



Audentis Fortuna iuvat.
Peter_
Member
posted 06-01-03 09:23 AM EDT (US)     121 / 618       
That would be a supreme accomplishment if you wanted the most laggy game ever, yeah.
Magpie
Member
posted 06-01-03 09:55 AM EDT (US)     122 / 618       
Iíve been grappling with this game for the last three days.

Having managed to load it without any problems, it locks up three or four minutes into the game every time I try to play it.

Iíve updated the video drivers, downloaded Direct x 9.0a and disabled the anti-virus software, all without success.

System details:-

Athlon XP 2100 + Processor

NVIDIA GeForce Ti 4600 video card

Creative SB Audigy Audio sound card

512 meg installed memory

160.10 Gigabytes Usable Hard Drive Capacity
120.55 Gigabytes Hard Drive Free Space

All other games are running without difficulty.

What can I do to sort this problem out, apart from returning the game?

All offers of help gratefully received, as I am getting increasingly desperate.


JonesTheSteam
Member
posted 06-01-03 12:34 PM EDT (US)     123 / 618       
I have found what seem to be a few bugs when I play RoN that no-one else has mentioned.

I can install it and run it fine. But when playing the Conquer the World Campaign I have two problems.

1) I start a new battle, and my capital city has been created in the middle of water. This means that everyone is garrasoned inside the city, and you can't get them out. It's also impossible to build any other buildings. This has happened several times.

Also, and I suspect this is the same bug, I have had one battle where the enemy capital city has been created in the water. Which meant that I could attack it, but then when I came to taking it my infantry couldn't enter the city to capture it. Effectively making it impossible to win the battle (the victory condition being capturing the enemy capital in 90 minutes).

2) Whenever I try and use a Bonus Card the game will crash to the desktop. I can select which bonus card I want to play, but as soon as I start the battle the game just seems to stop - I don't get any error messages.

The above bugs have happened every time I have tried a different Conquer the World scenario, with every different race I have tried - so far I have been the British, The Maya, The Greeks and The Mongols.

My set-up:

Dell Optiplex GX 260
P4 2.8GHz
512MB
80GB HDD
Windows XP Pro

I am using the standard retail version of RoN.

COSIAN
Member
posted 06-01-03 06:57 PM EDT (US)     124 / 618       
Was crashing without errors or exception to desktop after 5-15 minutes of play in the Quick Learn. Fixed this problem by installing the latest drivers for my NVIDIA MX440 128 AGP 8x.

So I got into my first solo quick battle. Playing the Greeks against 1 Comp. Got to the industrial age and I have to problems to report.

First, I built my third university and after it was built, it disappeared. It is not visible on the map but it is there. I had launched build on 7 scholars before it disappeared and the scholars kept building and I ended up with the full complement of 21 scholars. I built a fourth awhile later and it did not disappear and worked correctly.

The second problem is a crash with a BHG RTS run time error.

UNIT LINKED LIST LOOPS <ADD>

I had saved my game a couple minutes before I got this error and tried to reload it. After a couple minutes....even if I don't do anything.....it crashes with this error.

I can submit the save game file if you need it.

Alex Poff
Member
posted 06-01-03 09:55 PM EDT (US)     125 / 618       
OK, I have updated my drivers (NVidia Riva TNT2) and changed bit rates to 32 and now I can play, but I just tried to load a saved game and the dang thing crashes to desktop, saying something like "exception error". Any ideas? Thanks
« Previous Page  1 ··· 3 4 5 6 7 ··· 20 ··· 25  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Rise of Nations Heaven | HeavenGames