You must be logged in to post messages.
Please login or register

RoN Tech Support
Moderated by alincarpetman

Hop to:    
Welcome! You are not logged in. Please Login or Register.618 replies, Sticky
Rise of Nations Heaven » Forums » RoN Tech Support » Report Bugs here so they get fixed!
Bottom
Topic Subject:Report Bugs here so they get fixed!
« Previous Page  1 2 3 4 5 ··· 10 ··· 20 ··· 25  Next Page »
Scrubs
VIP
posted 05-21-03 02:25 PM EDT (US)         
I've noticed people complaining about not being able to play Rise of Nations because of bugs, patch problems... etc.

So... here's what the community can do to help BHG solve these issues and get them fixed.

1. Give a brief description of the problem. For example:
Game doesn't patch.

2. Give a detailed system analysis of you computer specs. To make this easier for people to find out what they have, go here and download the Belarc Advisor at www.belarc.com/free_download.html and/or just browse through your Device Manager.
For example:
1.8MGz Intel Pentium 4 (Win XP Pro. SP1 build 2600)
Dell OptiPlex GX240 MB with BIOS A03 03/01/2002
512MB RAM
40GB Hard Drive with 21.85GB Free Space.
NVIDIA GeForce4 Ti4400 with driver 4.3.4.5 03/20/2003
(Optional) Cable Modem w/Firewall... etc.
Rise of Nations retail (English version) build 01.13.04.1801
No mods, no cracks, no trainers... etc.

3. Give a more detailed description of the problem. For example:
When updating the patch through GameSpy, it will download 100% then bring me back to desktop and patch RoN until it reaches 37%, then it will stop and give me an "Invalid Patch File Error" and a "Retcode positive - 32769". I have the English version of the game.

4. Give reproduction steps on how to make it happen again. For example:
1. Launch the game.
2. Go to Multiplayer Game.
3. Go to GameSpy Internet Matchmaking.
4. Click "OK" when it says to upgrade to version 01.14.05.0902.
5. When the download is complete, log into GameSpy with your password.
6. Observe the game going to desktop and stopping at 37% during the patch process.

5. If it's a multiplayer game, be sure to specify if it was through GameSpy Arcade, GameSpy Internal, or LAN/IP. Then list the settings for the Multiplayer game. For example:
Teams of 3
Great Lakes
Large (5/6 player)
No Cannon Time
Custom
End Age: Gunpowder Age
Elimination: Conquest
Victory: Conquest
Tournament Play enabled.
3 Humans vs. 3 Computers (Moderate, Moderate, and Tough)
Nations in the game were:
Aztecs, Mongols, Chinese, Chinese, Egyptians, and Russians.

6. If it's a single player Quick Battle game, list the same steps as in #5. If it's a Conquer the World Single Player Campaign... list:
1. What your Nation is.
2. What difficulty setting you have.
3. What Age it was in.
4. What country you were attacking, and what battle type it was.
5. What build you're in... and what build you started your Campaign in. For instance, the retail is 01.13.04.1801, and the patch is 01.14.05.0902. Did you start a campaign in the retail version and save the campaign... and then upgrade to the patch and load the campaign?

If you see your bug listed here already from someone else, just give your #2. Computer Specs.

[This message has been edited by Scrubs (edited 05-21-2003 @ 05:29 PM).]

AuthorReplies:
KRONOS1974
Member
posted 05-23-03 08:44 PM EDT (US)     51 / 618       
scrubs thanks for info--i am not sure how exactly to do that--can u give me some tips of perhaps a web site to explain this process?

Thanks
Kronos

Scrubs
VIP
posted 05-23-03 09:00 PM EDT (US)     52 / 618       
Peter_
Member
posted 05-23-03 09:06 PM EDT (US)     53 / 618       
Do you think you've got any idea why the error is coming up in the CTW loading process when you are about to attack yet?
Rise of Ham
Member
posted 05-24-03 08:12 AM EDT (US)     54 / 618       
Scrubs:its standard
patton12345
Member
posted 05-24-03 09:10 AM EDT (US)     55 / 618       
Hey Scrubs:
I managed to free up a gig on my partition. will that help?
Will the newest drivers for the Video Card help as well?

Thank you

OG_Zeus
Member
posted 05-24-03 10:26 AM EDT (US)     56 / 618       
i did that scrub but not working
EclipseV
Member
posted 05-24-03 11:00 AM EDT (US)     57 / 618       
BUG REPORT:

renaming your player name does not work under options menu.

if you choose rename, you can change the name in the menu above,
but then when you select that name. the original name will still show up in the botton and in the game.


Audentis Fortuna iuvat.
nativtynblack
Member
posted 05-24-03 12:15 PM EDT (US)     58 / 618       
Ravenfire...I had the same problem with an ATI Rage 128 Pro, the game would lock up after a few minutes. Here was my solution: this is with windows XP
Open up control panel, and go to display.
Click the settings tab and hit advanced.
Go to the troubleshooting tab.
Bring the slider for hardware acceleration down one notch.
Click apply and ok

This solved my ATI graphics lockup problem...best of luck!

Avenging_Comb
Member
posted 05-24-03 07:13 PM EDT (US)     59 / 618       
1) getting out of syncs and unable to join other online games now that i have RoN installed

2) P4 2.5Ghz
512MB RAM
40 Gig HDD
WinXP Pro
ATI M6 32MB RAM

3)I play mainly StarWars Galactic Battlegrounds Clone Campaigns... when i host a game, the game ALWAYS out of syncs.. if i try to JOIN another game on the MSN Gaming Zone, i can NEVER get in... I have also tried to IP into a game, and still cannot join... These problems with GBCC were NOT HAPPENING until i installed RoN

4)I have tried all of the above multiple times, and each time it is the same thing... I have NO problems with ron except during a game, about 20-30 minutes into it ppl start dropping...


thnx

Ceaserslegion
Member
posted 05-24-03 07:38 PM EDT (US)     60 / 618       
I have had a problem with the Campaign mode, but not the quick battle. Any answers.
Byrus
Member
posted 05-24-03 08:15 PM EDT (US)     61 / 618       
Bug

The game quits everytime I press any key. It just reverts back to my desktop. It doesn't matter if it's in the middle of the game, intro, etc.

I've got Dell 1.3Gz P4
Windows XP
Geoforce 2MX 440
256 Ram

Other games work fine (Generals, WC3, etc)

Please help! Thanks.

[This message has been edited by Byrus (edited 05-25-2003 @ 10:46 AM).]

bsmith
Member
posted 05-24-03 09:19 PM EDT (US)     62 / 618       
Plz help me to run the game!!!

1) I installed RON with no problem, but when i try to run it after the videos, a RON logo comes up but it freezes and i hafta restart my computer.
2)Pentium 4 1.6GHz
256MB
GeForce 4 MX 440
Sound Blaster live 5.1
40GB hard drive with 1 GB free space
3) I cant even get into the main manu of the game.
4) Start the game
5)n/a
6)n/a

Peter_
Member
posted 05-24-03 09:58 PM EDT (US)     63 / 618       
I think this makes them look really bad, releasing the game with loads of bugs on. I couldn't do it though, and it's a cool game still. Just wish it all worked..
cpremoe
Member
posted 05-25-03 00:50 AM EDT (US)     64 / 618       
Can't install RoN.
Double click ronsetup.exe

Error : Setup was unable to find (or could not read) the language specific setup resource dll, unable to continue. Please reboot and try again.

Rebooting didn't help

ATI Radeon 9500 Pro. Driver 6.14.1.6292 1/20/2003
WinXP w/ SP1
Intel P4 2.4
Lite-On LTR-48246S
DirectX 9.0

Did have the Demo installed fine. Uninstalled it before I tryed to install RoN.

crispee
Member
posted 05-25-03 02:27 AM EDT (US)     65 / 618       
Demo crashed. Bought the full retail version and it crashes as well. This feels worse than beta software.

P4, 1.2 GhZ, 512 RAM, Radeon 8500

I have DirectX 9.0a and the current ATI Radeon drivers as of today.

I have tried to reproduce the crash and it does every single time I play. Problem is, a different thing will cause it. click to research something, crash. Try to place a new city, crash. Move a unit, crash. Before that all is normal and good. No error messages, nothing.

The crash is a freeze. Only holding my power button down will solve it. Fun--nothing like a force shutdown to really make a game great.

there is no rhyme or reason to it. I've disabled the background music and it has not helped. Changed the bit depth to 16.

used MSCONFIG to disable background processes that may have interfered. Crashed even faster if you can believe it.

CTW crashes, the first tutorial crashes, the demo crashed. The box should have come with a check in it to pay me for testing this software.

the problem is I love the game, or at least the first 30 or so minutes as that is as far as I can get.

Please release a patch that will address this.

Dark Lord
Member
posted 05-25-03 01:36 PM EDT (US)     66 / 618       
1. After editing the Target to fix the flickering mouse bug, the mouse still flickers.

2. Operating System: Windows XP Home Edition Service Pack 1 (build 2600)

Processor: 650 megahertz AMD Athlon
128 kilobyte primary memory cache
512 kilobyte secondary memory cache

Drives: 15.37 Gigabytes Usable Hard Drive Capacity
8.98 Gigabytes Hard Drive Free Space

AOPEN CD-RW CRW2440 [CD-ROM drive]
HITACHI DVD-ROM GD-5000 [CD-ROM drive]
3.5" format removeable media [Floppy drive]

Memory Modules: 640 Megabytes Installed Memory

Video Card: ATI Radeon 9000 Pro

Sound Card: Santa Cruz

RAM: 640

3. I first noticed the flickering mouse issue the day I recieved RoN from Amazon through the mail, since I had it pre-ordered. I went to the website http://www.riseofnations.com and looked up known issues. I found the issue in there, and I found the cure. I tried to fix it, but it continued to flicker. Here is the new target that I have: "C:\Program Files\Microsoft Games\Rise of Nations\rise.exe" -nohwcursor

When playing the game, it's fine up untill about two minutes later. When something happens, the mouse begins to flicker endlessly, even after this fix.

4. 1. Launch the game.
2. Go to Solo Play
3. Go to quick game
4. Start any game
5. Play for about two minutes
6. Watch the mouse begin to flicker after something happens. (Not sure what happens to trigger it) It will flicker throughout the game.

6. 1. Any Nation
2. Any Difficulty
3. Any Age
4. Any Country
5. 01.14.05.0902

polspc
Member
posted 05-25-03 02:30 PM EDT (US)     67 / 618       
Can't even get to witness the problems that others are posting here. I can't even install the game properly!!! How weak is that, Microsoft really screwed the midget on this one. Looks really bad on them I'm sure. And so it should!

gets to the part in the install where it says "updating system settings" after all file copying is done and just hangs there indefinately. No uninstall options or repair options in the installer program either. I can't beleive I paid money for this game!!!!! Too bad because it probably rocks as a game.

I'll return it for my money back and download it with PRIDE from a local warez site after it's fixed guilt free. I can't even remember when was the last time I had a game this bad off the bat. I thought that was a thing of the past.

SHAME SHAME ON MICROSOFT GAMES!!!!!!!! That's 75 bucks canadian I'll be getting back from them for sure!!!!

ravenfire_72
Member
posted 05-25-03 03:31 PM EDT (US)     68 / 618       
Nativty, Yeah I got mine working now. Part of the problem may lie with ati's drivers. I was running the Cat 3.4's and was not having much success. I reinstalled the Cat 3.2's and its working now. As far as changing the level on the hardware acceleration I did not have to do that in this case. I have had to do that before though(SimCity 4).
Scrubs
VIP
posted 05-25-03 05:26 PM EDT (US)     69 / 618       
Dark Lord:

Go to your Rise of Nations folder and in the rise2.ini...

Set these to:
ForceHardwareCursor=1
ForceGDICursor=1
ForceBWCursor=1

Vyxx
Member
posted 05-25-03 07:04 PM EDT (US)     70 / 618       
I'm having alot the same problems as other lads on here, game is locking up after several minutes of play (sometimes even crashes when I'm selecting game settings (maps, ages, nations). Just adding my voice to the many, hopefully this great-looking game will EVENTUALLY get fixed....This site's news said a new patch is in the works, going to be maybe done testing thursday...can't wait

On my old computer, the game minimizes to task bar and I cannot restore it. Crashes when I attempt to play multiplayer, when loading game. System:
Win 98
Pentium III 550 Mhz
256 sdram
GeForce 4 MX 440

Now this is an old computer, so I don't expect it to run very well...but my new computer either CTD's or locks up (cannot get out with alt tab, altF4, ctrl alt dlt, esc)several minutes into the game, if I even make it that far (sometimes freezes when I'm selecting game options).
System:

Win XP
Athlon 2800+
512 400mhz DDRSDRAM
Radeon 9700

I've also tried lowering hardware acceleration (sound, video) on new computer, to no avail. Tried installing patch, if anything the problem worsened - I still haven't been able to play a full game, however. CTW is the same story.

Anybody know a solution? I've tried all the suggested troubleshooting methods on Microsoft's support site for slow/locking up games, such as: clean boot, lowering hardware acceleration, lowering AGP accel. Nothing seems to work...sent a support email to microsoft, they haven't replied yet and I don't hope for much considering their support publication thingy didn't help....any ideas? Thanks


~-----------------~

Are you suggesting coconuts are migratory?

Loftish
Member
posted 05-25-03 07:18 PM EDT (US)     71 / 618       
I'm getting the same error as Peter, Brodie00, and xarkxem. CTW won't work! I haven a Riva TNT2 graphics card, but I don't think this is the problem. The microsoft support site is totally unhelpful.

Does anyone know why CTW won't work???!!!!

Edit: Updated my drivers,and now it works!

[This message has been edited by Loftish (edited 05-26-2003 @ 11:26 AM).]

Mr Banana
Member
posted 05-25-03 09:23 PM EDT (US)     72 / 618       
Please how am I supposed to fix the multiplayer problem? I've downloaded all updates from windows update, they dont work. How can I download a patch to fix ctw if i cant even get a multiplayer game going to automatically download the update??? And has anyone noticed that the patch that they're working on SAYS NOTHING ABOUT MULTIPLAYER?????
Scrubs
VIP
posted 05-26-03 01:04 AM EDT (US)     73 / 618       
Don't worry, there'll be ways to download the patch and install it outside of GameSpy once they release the downloadable version.
OG_Zeus
Member
posted 05-26-03 07:29 AM EDT (US)     74 / 618       
when will it be online the standalone version?
shakee
Member
posted 05-26-03 10:31 AM EDT (US)     75 / 618       
1.
Game (Retail and Demo) does freeze after some time. It doesnīt matter if I play CTW or battle. Music work until the song is finished after the freeze then it stop too. Only Reset works.

2.
------------------
System Information
------------------
Time of this report: 5/26/2003, 16:21:22
Machine name: HOME
Operating System: Windows 2000 Professional (5.0, Build 2195) Service Pack 3
Language: German (Regional Setting: German)
System Manufacturer: VIA Technologies, Inc.
System Model: KT400-8235
BIOS: Phoenix-Award BIOS v6.00PG
Processor: AMD Athlon(tm) XP 2000+, MMX, 3DNow, ~1.7GHz
Memory: 512MB RAM
Page File: 170MB used, 820MB available
Windows Dir: C:\WINNT
DirectX Version: DirectX 9.0a (4.09.0000.0901)
DX Setup Parameters: Not found
DxDiag Version: 5.03.0000.0901 32bit Unicode

--------------------
DirectX Debug Levels
--------------------
Direct3D: 0/4 (n/a)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (n/a)
DirectMusic: 0/5 (n/a)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

---------------
Display Devices
---------------
Card name: RADEON 9100 SERIES
Manufacturer: ATI Technologies Inc.
Chip type: Radeon 9100 AGP (0x514D)
DAC type: Internal DAC(350MHz)
Device Key: Enum\PCI\VEN_1002&DEV_514D&SUBSYS_7149174B&REV_00
Display Memory: 64.0 MB
Current Mode: 1024 x 768 (32 bit) (60Hz)
Monitor: (Standardmonitor)
Monitor Max Res:
Driver Name: ati2dvag.dll
Driver Version: 6.14.0010.6343 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail
Driver Date/Size: 4/28/2003 22:39:48, 291584 bytes
WHQL Logo'd: n/a
WHQL Date Stamp: n/a
VDD: n/a
Mini VDD: ati2mtag.sys
Mini VDD Date: 4/28/2003 22:39:24, 625920 bytes
Device Identifier: {D7B71EE2-120D-11CF-3C6C-4351A1C2CB35}
Vendor ID: 0x1002
Device ID: 0x514D
SubSys ID: 0x7149174B
Revision ID: 0x0000
Revision ID: 0x0000
Video Accel: ModeMPEG2_D ModeMPEG2_C

-------------
Sound Devices
-------------
Description: SB Live! Audio [BC00]
Default Sound Playback: Yes
Default Voice Playback: Yes
Hardware ID: PCI\VEN_1102&DEV_0002&SUBSYS_80401102&REV_07
Manufacturer ID: 1
Product ID: 100
Type: WDM
Driver Name: ctaud2k.sys
Driver Version: 5.12.0001.0244 (English)
Driver Attributes: Final Retail
WHQL Logo'd: n/a
Date and Size: 3/22/2002 12:09:40, 835636 bytes
Other Files:
Driver Provider: Creative
HW Accel Level: Full
Cap Flags: 0x0
Min/Max Sample Rate: 0, 0
Static/Strm HW Mix Bufs: 0, 0
Static/Strm HW 3D Bufs: 0, 0
HW Memory: 0
Voice Management: Yes
EAX(tm) 2.0 Listen/Src: Yes, Yes
I3DL2(tm) Listen/Src: No, No
Sensaura(tm) ZoomFX(tm): No
Registry: OK
Sound Test Result: Not run

---------------------
Sound Capture Devices
---------------------
Description: SB Live! Audio [BC00]
Default Sound Capture: Yes
Default Voice Capture: Yes
Driver Name: ctaud2k.sys
Driver Version: 5.12.0001.0244 (English)
Driver Attributes: Final Retail
Date and Size: 3/22/2002 12:09:40, 835636 bytes
Cap Flags: 0x0
Format Flags: 0x0

-----------
DirectMusic
-----------
DLS Path: C:\WINNT\SYSTEM32\drivers\GM.DLS
DLS Version: 1.00.0016.0002
Acceleration: Enabled
Ports: SB Live! DirectMusic Synthesizer [BC00], Hardware (Kernel Mode), Output, DLS, Internal, Default Port
SB Live! Audio [BC00], Software (Kernel Mode), Output, DLS, Internal
Microsoft MIDI-Mapper [Emuliert], Hardware (Not Kernel Mode), Output, No DLS, Internal
SB Live! Sw Synth [BC00] [Emuliert], Hardware (Not Kernel Mode), Output, No DLS, Internal
SB Live! Synth A [BC00] [Emuliert], Hardware (Not Kernel Mode), Output, No DLS, Internal
SB Live! Synth B [BC00] [Emuliert], Hardware (Not Kernel Mode), Output, No DLS, Internal
SB Live! MIDI Port [BC00] [Emuliert], Hardware (Not Kernel Mode), Output, No DLS, External
Microsoft GS Wavetable SW Synth [Emuliert], Hardware (Not Kernel Mode), Output, No DLS, Internal
SB Live! MIDI Port [BC00] [Emuliert], Hardware (Not Kernel Mode), Input, No DLS, External
Microsoft Synthesizer, Software (Not Kernel Mode), Output, DLS, Internal
Registry: OK
Test Result: Not run

-------------------
DirectInput Devices
-------------------
Device Name: Maus
Attached: 1
Controller ID: n/a
Vendor/Product ID: n/a
FF Driver: n/a

Device Name: Tastatur
Attached: 1
Controller ID: n/a
Vendor/Product ID: n/a
FF Driver: n/a

Poll w/ Interrupt: No
Registry: OK

-----------
USB Devices
-----------
+ USB-Root-Hub
| Matching Device ID: usb\root_hub
| Service: usbhub
| Driver: usbhub.sys, 7/22/2002 12:05:04, 40112 bytes
|
+-+ USB-HID (Human Interface Device)
| | Vendor/Product ID: 0x046D, 0xC00C
| | Location: USB Mouse
| | Matching Device ID: usb\class_03&subclass_01
| | Service: HidUsb
| | Driver: hidclass.sys, 7/22/2002 12:05:04, 24752 bytes
| | Driver: hidparse.sys, 7/22/2002 12:05:04, 23056 bytes
| | Driver: hid.dll, 7/22/2002 12:05:04, 18192 bytes
| | Driver: hidusb.sys, 12/10/1999 14:00:00, 13904 bytes
| | Driver: pid.dll, 5/1/2002 18:51:36, 31744 bytes
| |
| +-+ HID-konforme Maus
| | | Vendor/Product ID: 0x046D, 0xC00C
| | | Matching Device ID: hid_device_system_mouse
| | | Service: mouhid
| | | Driver: mouhid.sys, 7/22/2002 12:05:04, 11728 bytes
| | | Driver: mouclass.sys, 7/22/2002 12:05:04, 22128 bytes

Game is NOT patched whatsoever. It happens even in the Demo...

3.
It freeze in every Detail Level and in 16/32 Bit. For the rest see 1.

4.
It does simply happen. I canīt reproduce it


BTW:

I have also a Notebook. But there are no such problems. Demo and Retail function properly.

Celeron 1200
Windows XP Sp1
256 MB RAM
ATI M6 grafic card
VIA chipset

EDIT:
----------------
Before I forget:

The Demo destroyed my XML Parser with every freeze. Before I could play again I must first run MSXMLENU.MSI in the Redist folder.

[This message has been edited by shakee (edited 05-26-2003 @ 10:40 AM).]

« Previous Page  1 2 3 4 5 ··· 10 ··· 20 ··· 25  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Rise of Nations Heaven | HeavenGames