You must be logged in to post messages.
Please login or register

RoN Tech Support
Moderated by alincarpetman

Hop to:    
Welcome! You are not logged in. Please Login or Register.618 replies, Sticky
Rise of Nations Heaven » Forums » RoN Tech Support » Report Bugs here so they get fixed!
Topic Subject:Report Bugs here so they get fixed!
« Previous Page  1 ··· 10 ··· 19 20 21 22 23 ··· 25  Next Page »
posted 05-21-03 02:25 PM EDT (US)         
I've noticed people complaining about not being able to play Rise of Nations because of bugs, patch problems... etc.

So... here's what the community can do to help BHG solve these issues and get them fixed.

1. Give a brief description of the problem. For example:
Game doesn't patch.

2. Give a detailed system analysis of you computer specs. To make this easier for people to find out what they have, go here and download the Belarc Advisor at and/or just browse through your Device Manager.
For example:
1.8MGz Intel Pentium 4 (Win XP Pro. SP1 build 2600)
Dell OptiPlex GX240 MB with BIOS A03 03/01/2002
40GB Hard Drive with 21.85GB Free Space.
NVIDIA GeForce4 Ti4400 with driver 03/20/2003
(Optional) Cable Modem w/Firewall... etc.
Rise of Nations retail (English version) build
No mods, no cracks, no trainers... etc.

3. Give a more detailed description of the problem. For example:
When updating the patch through GameSpy, it will download 100% then bring me back to desktop and patch RoN until it reaches 37%, then it will stop and give me an "Invalid Patch File Error" and a "Retcode positive - 32769". I have the English version of the game.

4. Give reproduction steps on how to make it happen again. For example:
1. Launch the game.
2. Go to Multiplayer Game.
3. Go to GameSpy Internet Matchmaking.
4. Click "OK" when it says to upgrade to version
5. When the download is complete, log into GameSpy with your password.
6. Observe the game going to desktop and stopping at 37% during the patch process.

5. If it's a multiplayer game, be sure to specify if it was through GameSpy Arcade, GameSpy Internal, or LAN/IP. Then list the settings for the Multiplayer game. For example:
Teams of 3
Great Lakes
Large (5/6 player)
No Cannon Time
End Age: Gunpowder Age
Elimination: Conquest
Victory: Conquest
Tournament Play enabled.
3 Humans vs. 3 Computers (Moderate, Moderate, and Tough)
Nations in the game were:
Aztecs, Mongols, Chinese, Chinese, Egyptians, and Russians.

6. If it's a single player Quick Battle game, list the same steps as in #5. If it's a Conquer the World Single Player Campaign... list:
1. What your Nation is.
2. What difficulty setting you have.
3. What Age it was in.
4. What country you were attacking, and what battle type it was.
5. What build you're in... and what build you started your Campaign in. For instance, the retail is, and the patch is Did you start a campaign in the retail version and save the campaign... and then upgrade to the patch and load the campaign?

If you see your bug listed here already from someone else, just give your #2. Computer Specs.

[This message has been edited by Scrubs (edited 05-21-2003 @ 05:29 PM).]

posted 05-08-06 04:55 PM EDT (US)     501 / 618       
I also have a sound...inconvenience, but there isn't even sound in the intro movies. (I have RoN: T&P)

1) start computer, login to windows XP account. (sound works at this time)

2) open My Games folder, open RoN: T&P

3) Visually, everything is fine. No sound at this point.

4) Exit out of game with no problem, but now my computer emits no sound whatsoever.

5) In replace of where a sound shold be, my speakers emit one single pop.

I've trie'd Cobra's method, umong others. I even emailed Microsoft and they dont know whats wrong. The same exact CD works on my little brother's computer with no problem.

Windows XP Home Edition Service Pack 2 (build 2600)
3.20 gigahertz Intel Pentium 4
MSI MS-StarForce GeForce FX 5700LE (NVIDIA GeForce FX 5700LE) [Display adapter]
SoundMAX Integrated Digital Audio

posted 07-06-06 11:53 AM EDT (US)     502 / 618       
RoN:TaP refuses to open GameSpy internal

I have Rise of Nations Gold edition running on Windows XP with all the latest patches. Until yesterday I had no problems with the internal GameSpy multiplayer.

However, yesterday I upgraded GameSpy Arcade (standalone program) to 2.0.3. Afterwards, when I try to use GameSpy internal from within TaP, nothing happens:

1. Run TaP
2. Click Multiplayer button
3. Click GameSpy button
4. Instead of getting the GameSpy login dialog, multiplayer menu is shown again (as before step 3); you can try clicking GameSpy button again but mutiplayer menu is displayed again (and again and again)

Note that GameSpy Arcade, the standalone program, works fine. It's the GameSpy internal in RoN:TaP that is failing to start.

I've tried uninstalling RoN, cleaning up and installing from scratch with patches. I also tried uninstalling and reinstalling GameSpy Arcade, with no luck (I also tried installing GameSpy Arcade version included with RoN Gold).

Please note that it is highly probable this is not a connectivity issue. If I run Rise of Nations from the Gold pack (same install directory, latest patch), I can login to GameSpy internal without problems (and can also join and host games).

Once again - I can use GameSpy internal from within RoN but not from within RoN:TaP. GameSpy internal worked even in RoN:TaP until yesterday when I upgraded GameSpy Arcade.

Is there a way to get RoN:TaP GameSpy internal to work?

Thank you,

posted 07-13-06 00:04 AM EDT (US)     503 / 618       
Not sure if anyone still needs this problem fixed...but I've tried a few different steps...

At any rate, I tried lots of stuff, everything all the forums suggested and Microsoft and BigHuge, etc...disabling accelleration, audio, whatnot...

Here's what fixed it for me: Installing the Microsoft reference drivers for the video card. The game runs fine on machine (Dual Core Athlon, GeForce 6600, 1GB), but my old machine (1.4GhZ, 512MB, GeForce 4 4200) kept getting the Gathering Exception Data error...

I uninstalled the the driver for the video card, and rebooted. When rebooting, Windows did the Add New Hardware stuff, and I did NOT put in any newer drivers...just let Windows install the "reference" (aka crappy) drivers...and it worked. (Note: If you play 3D-intense games, this may jack up your performance a lot.)

Hope that's the only thing that got it working for me - even though the original game worked on both computers.

posted 07-23-06 10:25 AM EDT (US)     504 / 618       
please help, i setup my old pc
128mb ram
20gb Hard Drive (13gb free)
ATI rage 128/ xpert (latest drivers)
16.0mb memory

i have tried patching and it hasn't helped...

Problem: the intro begins but the game crashes after, a messaging saying 'Rise of nations can't run in 256 colours
appears. problem is my computer is not on 256 colours, i switch between 16-bit and 32-bit but still it does the
same thing.

The Naminator
posted 07-23-06 11:40 AM EDT (US)     505 / 618       
go to C:\program files\Microsoft Games\Rise of Nations
right click on nations or patriots go to properties then to compatibility and check if it isnt running in 256 colors

posted 07-24-06 06:45 AM EDT (US)     506 / 618       
sorry, forgot to say... its on windows 98 so doesn't have the compatability tab. thanks anyway.
posted 09-01-06 01:42 PM EDT (US)     507 / 618       
I recently bought the expansion pack 'Thrones and Patriots' and am encountering a problem on the loading screen. The game installs fine but after the introsequence and on the loading screen, after 3o seconds, a window opens saying "Cant creat file state.dat,check disc space" and closes...iv tried re-installing it and everything..and I have loads of disc space left which is really confusing!!Please help!
posted 09-03-06 04:58 PM EDT (US)     508 / 618       

1. I got a problem with installing the game at my computer i have the RoF:gold edition. 1st CD goes up to 47% and then it says to change CD so i change and then on the 2nd CD it gets stuck at 74%.

2. My computer:

2.80 gigahertz Intel Celeron
16 kilobyte primary memory cache
256 kilobyte secondary memory cache

160.03 Gigabytes Usable Hard Drive Capacity
132.57 Gigabytes Hard Drive Free Space

_NEC DVD_RW ND-3530A [CD-ROM drive]

ST3160021A [Hard drive] (160.04 GB) -- drive 0, s/n 5JS4HBQE, rev 8.01, SMART Status: Healthy

Memory Modules:
768 Megabytes Installed Memory

NVIDIA GeForce FX 5200 [Display adapter]
Proview 565 [Monitor] (14.9"vis, s/n FGOJ4B0261730, November 2004)

Creative Sound Blaster AudioPCI (WDM)
Game Port for Creative

Virus Protection:
McAfee VirusScan Version 10.0.27
Scan Engine Version 5100
Virus Definitions Version 4843
Last Disk Scan on Saturday, August 26, 2006 10:29:24 AM
Realtime File Scanning On

3. As i said the 2nd CD gets stuck on 74% and the error is : market_3e_snow.tga could not be installed, make sure that your disk is not full and it is not used by another program. <I went on the microsoft website and i did all it said there but it still didint work>

4. 1.Insert the 1st CD
2.Start Installing
3.Change to 2nd CD
4.At 74% it gets stuck with an error of:market_3e_snow.tga

I only Got the game today so i couldent call the microsoft support center

I would really be thankful for all the help

posted 09-07-06 08:07 PM EDT (US)     509 / 618       
Hi !

I got a problem when I start a game. After few minutes my screen turn to white and i cant see anymore my toolbars.

You can go see a screen shot of this problem here :

1,85 gigahertz AMD Athlon XP (Windows XP Professional Service Pack 2 (build 2600))
Board: ASUSTeK Computer INC. A7N8X-VM Rev 1.xx
Bus Clock: 166 megahertz
BIOS: American Megatrends Inc. 8.00 08/15/2003
762 MB RAM
40,01 Gigabytes Usable Hard Drive Capacity
4,47 Gigabytes Hard Drive Free Space
NVIDIA GeForce4 MX Integrated GPU
Rise of Nations Gold

1. Launch Game
2. Start a game
3. After few time the screen turn to white and i cant see anymore the bars and the buttons.

[This message has been edited by Skyzomarco (edited 09-07-2006 @ 08:13 PM).]

posted 10-12-06 01:54 AM EDT (US)     510 / 618       
This may have been addressed earlier but I didn't have the time to sift through all of the posts. My original installation of RON Gold went perfectly, and the game worked perfectly. My son managed to crash my computer a few months ago, and after restoring my system, I have been totally unsuccessful trying to reinstall RON. Each time I try, I get several messages saying that It cannot install the game because several .dll files "cannot be found". Help!!!! How can I fix this, I love RON.
posted 10-16-06 08:59 AM EDT (US)     511 / 618       
Hi. Just wondered if there are any Mac users on here who've encounbtered the same problem as me? I'm using a 1.8GHz G5 PowerMac with OSX.4.7.

Since moving up from OSX.4 to OSX.4.7 I've found that the Gold Edition quits either at the main menu or the game settings menu. No warnings or anything-it loads up just fine, but the moment I click anything the whole thing quits without so much as a 'You're Screwed' box appearing. I've found no patches on the BHG site, so I was wondering if anyone else had any idea what might be causing it. If at all possible I'd rather not have to revert back to an older OS as its a work computer. Thanks for any help you can give.

posted 10-27-06 07:57 AM EDT (US)     512 / 618       
Hi Everyone,

Here's my problem: I purchased RON in Korea thinking that I would be able to change the language settings upon installing it (to English of course). I installed it on my girlfriends computer (which runs windows XP in Korean). Upon installing it, I could not select any languages and it installed the game in Korean. I can read Korean but I'd obviously like to install it in English. My girlfriend called Microsoft tech support and they said it's impossible to install an English version. Is that true?

So what I'm asking is if there is a way to change it to install English instead of Korean or...if there is a way to change languages inside the game? Or maybe, does anyone know if there is a way to download a patch to change it to an English version? Maybe there is a file I can change to change the language...I've searched the net, called tech support but can't seem to solve this problem...

I'd really love to play this game! If anyone can help me out, I'd be greatful! ^^ Somehow, I'm doubtful it will install English by default on my computer (which runs windows 2000 in English)...


[This message has been edited by gisa (edited 10-27-2006 @ 07:59 AM).]

posted 11-18-06 02:27 PM EDT (US)     513 / 618       
Hello Everyone!

This is my first post here but anyway i hope i can contribute with some good information! Here is a problem that i have found a kind of a "solution" fore.

My computer has these specifications:
CPU: 900 Mhz AMD Thunderbird (Win XP Pro. SP2 )
RAM: 384 RAM sdr Ram 133
GPU: NVIDIA GeForce4 mx 440
motherboard: Chaintech VIA
Soundcard: SB Live

After playing the game in about 15 minutes, the computer stops responding and a reboot is necessary. So far I know gametype and game version does not matter.

The problem is the soundcard i combination with Windows XP. The soundcard is old and i did not find any new drivers on the net at all. So I used the built-in soundcard on the motherboard instead and the game works perfect.

So i recommend to all users who has an old SB live card and have problem with ron to try to find new drivers
( not sure it works though ) or use a different soundcard.

posted 11-23-06 07:52 PM EDT (US)     514 / 618       
Hi guys,

1. I have a little graphics-bug.
2. I kick the computer-specs, because I tried it on three differnt computers and the bug was not impressed by it. Only importent Point: I've installed the last Patch that was released as .exe
3. The Bug looks like this: when I advance to Industrial Age the graphics of some auto-upgraded units don't change it's graphics. The Supplytruck, General, Caravan, and Fisherman don't change it's graphics.
4. For me its just plug and play.
5. / 6. The Bug appears in Solo Games (Quick Battles and Conquer the World Campain) I don't play Online.

Okay and here's the good news: I've got an idea on how to fix the bug, but not the ability.
I suppose in the arts-directory there should be a file named supplytruck.tga, but this file is missing. I hope the bug could be fixed by copying the file into the directory. But I need the file. Could anybody help me to get this file.

Thanks in advance

The Naminator
posted 11-23-06 08:32 PM EDT (US)     515 / 618,4539,,10

Check This.

-If your MEM grade is lower than C, you'll get the low-detail/non-upgrading unit art.
A=Be sure that thing is on A

Loaction of the file:

C:\Documents and Settings\User Name\Programs Dates\Microsoft Games\Rise of Nations
Its called rise2

I stole this sign!

[This message has been edited by The Naminator (edited 11-23-2006 @ 08:36 PM).]

posted 12-01-06 08:50 PM EDT (US)     516 / 618       
I am recieveing the "Gathering Exception". It seems to happen at different times. The first two times it happened I was able to send an error report. Since then it simply locks up the computer, and I have to pull the power. It happens really soon after i start a quick battle. A number of times it crashed after I left clicked on the map at the bottom. It use to happen right after the game started, and just last time I got all excited, just to have it crash a few minutes later.

I have:
AMD Athlon 1.34
512 MB ram
Windows XP SP2
Pny Nvidia Geforce4 Ti 4400
My mother board does have a VIA chipset, it is a gigabyte GA-7XD+ i believe.
RoN Gold (it crashes in also)

It was installed about 5 times. Twice on a fresh reformat. Followed just about every suggestion offered by microsoft and others to fix this... I have run RoN on this machine a few years ago, and dont recall any problems. But now after purchasing it... of course... does not work.

posted 12-16-06 12:07 PM EDT (US)     517 / 618       
*sigh*. I'm having real trouble here.

Every time I try to update RoN (Gold btw), my computer sorta crashes.

It's as if the program itself has crashed, but I can still see the overlay of the update screen. I can see the normal PC mouse, and when it changes to the drag cursor when it hovers above where the taskbar should be.

I can only fix this by hard reseting, otherwise the loading screen still hovers there, even if I use the windows key, or CTRL-ALT-DEL.

Something similiar happens when I try to test some of my own mods, except I can hear the alert chime.

Dell Dimension DC051
Celeron(R) CPU 3.06GHz
3.06 GHz, 504 MB of RAM
Im not sure about graphics or whatever, but its enough to run normaly and play well enough.

posted 12-18-06 09:11 PM EDT (US)     518 / 618       
I believe I was having the same problem. Whenever I told RON gold to check for updates, it would freeze with the RON menu background and the little box below the menu options remained.

When I tried it today, to find a better way to describe my problem, it seemed to do what it was supposed to. It said it was checking, found none, then let me hit ok to go back to the main menu.

Help! Someone stole this signature!!!
posted 03-03-07 10:36 PM EDT (US)     519 / 618       
k my problem is that half the games i try to play online on gamespy dont work, but half of them do. The half that dont just freeze on the connecting screen, and it just stays like that but the other half works fine.


posted 03-04-07 09:12 PM EDT (US)     520 / 618       
I'm having a graphics problem when I try to play RON. After the menu screen loads up the graphics immediatly change and look all distorted. It never gives me an error and I have the latest patch. I dont' know what to do, I have updated the driver for my graphics card and it hasn't changed a bit. Here are my machines specs:

500 megahertz Intel Pentium III Windows XP Professional Service Pack 2 (build 2600)
384 Megabytes Installed Memory
Board: Intel Corporation SE440BX-2 AA754552-205
BIOS: Intel Corp. 4S4EB2X0.86A.0024.P17 08/17/2000
HDD: 40.02 GB total 18.75 GB free
NVIDIA GeForce2 MX/MX 400 [Display adapter]
Princeton VF723 [Monitor] (15.7"vis, s/n JCAD1400412, April 2003)

Rise of Nations Version

Here is a screenshot of what it looks like when I start a game:

[This message has been edited by Gamer50655 (edited 03-04-2007 @ 09:14 PM).]

posted 03-17-07 10:55 PM EDT (US)     521 / 618       
Hi people..

I have a problem with the multiplayer of RON Gold edition..
When I create/host a game nobody can join my game.. My friend has the same problem. If he creates a game, I can also not connect.. When I try, it says: connecting... It stands there for an hour or so but nothing happens..

Does someone know what the problem can be?
Or does someone know if you need something extra to host a game?

Grz.. XeroX1990

The Naminator
posted 03-17-07 11:25 PM EDT (US)     522 / 618       
Some modems(routers) cause this problem or its the firewall, you can also try to connect with your old 56k modem this happens to me but it works when I use the dial-up.

I stole this sign!
posted 04-12-07 03:32 PM EDT (US)     523 / 618       
ello i have a problem everytime i start a match with quick match. when the other person accepted my request to play a match it goes to the second screen,but when its at the second screen i just see the background of rise of nations T&P and the ''A''button u allways see at your chat box.
i will have 2 wait and hopefully it will start the game.
please anybody help i got rise of nations T&P normal (not gold edition) i updated the game allready and my pc is fine i updated my drivers and things. im not sure if theres a second screen at quick match but if its there it wont appear i only see the background of rise of nations T&P

thnx allready

Greetzz leo_the_great

posted 05-15-07 05:48 AM EDT (US)     524 / 618       
i had this strange error after my nuke hit on one of the maps i made:

thats the exact resolution and such that the screen looked like and my PC crashed and had to restart after i clicked ok. my resolution before that was 1280 by 1024. and the white letters in the BG is nothing >.> ignore that. please do NOT ask... anyway, can you tell me what happend? this is winXP pro, i don't know anything about it really but i do know it's a piece of... crap >.> yet most things still work on it. this is the first wierd error other than Rise of Nations just randomly closing on me without warning or errors. same thing with MSN >.<
posted 05-20-07 10:06 PM EDT (US)     525 / 618       
Well I have the Rise of Nations: Gold Edition that contains both Rise of Nations and the Thrones and Patriots expansion pack.

My E Drive has 195GB of free space and RON takes up 1.5GB.

Ok so when I install it, it goes good and gets 80% done installing and then a window pops up saying:

"Rise of Nations Gold Setup encountered a disk error while writing to the file C:/Program Files/Microsoft Games/Rise of Nations/Thrones and Patriots/art/CTW_NewWorld_USA_back.tga. Make sure you hard disk is not full, and that the file is not in use."

Any help? Recommendations?

Anything appreciated

« Previous Page  1 ··· 10 ··· 19 20 21 22 23 ··· 25  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Rise of Nations Heaven | HeavenGames