You must be logged in to post messages.
Please login or register

RoN Tech Support
Moderated by alincarpetman

Hop to:    
Welcome! You are not logged in. Please Login or Register.618 replies, Sticky
Rise of Nations Heaven » Forums » RoN Tech Support » Report Bugs here so they get fixed!
Topic Subject:Report Bugs here so they get fixed!
« Previous Page  1 ··· 10 ··· 20 21 22 23 24 ··· 25  Next Page »
posted 05-21-03 02:25 PM EDT (US)         
I've noticed people complaining about not being able to play Rise of Nations because of bugs, patch problems... etc.

So... here's what the community can do to help BHG solve these issues and get them fixed.

1. Give a brief description of the problem. For example:
Game doesn't patch.

2. Give a detailed system analysis of you computer specs. To make this easier for people to find out what they have, go here and download the Belarc Advisor at and/or just browse through your Device Manager.
For example:
1.8MGz Intel Pentium 4 (Win XP Pro. SP1 build 2600)
Dell OptiPlex GX240 MB with BIOS A03 03/01/2002
40GB Hard Drive with 21.85GB Free Space.
NVIDIA GeForce4 Ti4400 with driver 03/20/2003
(Optional) Cable Modem w/Firewall... etc.
Rise of Nations retail (English version) build
No mods, no cracks, no trainers... etc.

3. Give a more detailed description of the problem. For example:
When updating the patch through GameSpy, it will download 100% then bring me back to desktop and patch RoN until it reaches 37%, then it will stop and give me an "Invalid Patch File Error" and a "Retcode positive - 32769". I have the English version of the game.

4. Give reproduction steps on how to make it happen again. For example:
1. Launch the game.
2. Go to Multiplayer Game.
3. Go to GameSpy Internet Matchmaking.
4. Click "OK" when it says to upgrade to version
5. When the download is complete, log into GameSpy with your password.
6. Observe the game going to desktop and stopping at 37% during the patch process.

5. If it's a multiplayer game, be sure to specify if it was through GameSpy Arcade, GameSpy Internal, or LAN/IP. Then list the settings for the Multiplayer game. For example:
Teams of 3
Great Lakes
Large (5/6 player)
No Cannon Time
End Age: Gunpowder Age
Elimination: Conquest
Victory: Conquest
Tournament Play enabled.
3 Humans vs. 3 Computers (Moderate, Moderate, and Tough)
Nations in the game were:
Aztecs, Mongols, Chinese, Chinese, Egyptians, and Russians.

6. If it's a single player Quick Battle game, list the same steps as in #5. If it's a Conquer the World Single Player Campaign... list:
1. What your Nation is.
2. What difficulty setting you have.
3. What Age it was in.
4. What country you were attacking, and what battle type it was.
5. What build you're in... and what build you started your Campaign in. For instance, the retail is, and the patch is Did you start a campaign in the retail version and save the campaign... and then upgrade to the patch and load the campaign?

If you see your bug listed here already from someone else, just give your #2. Computer Specs.

[This message has been edited by Scrubs (edited 05-21-2003 @ 05:29 PM).]

The Naminator
posted 05-21-07 03:55 PM EDT (US)     526 / 618       
Does it happens when the the cd drive is reading the same file?
Probably the cd is dirty or damaged.

I stole this sign!

[This message has been edited by The Naminator (edited 05-21-2007 @ 04:00 PM).]

posted 05-22-07 01:03 AM EDT (US)     527 / 618       
sorry, the other link was invalid x.x

there you go. can you tell me what was going on?
by e-mail please :P it takes forever to load this page with all these posts on here.
posted 06-29-07 03:27 PM EDT (US)     528 / 618       
Hi, i have a problem connecting to multiplayer games through gamespy (in game and through the actual gamespy arcade) i can log in ok and see games and chat etc but if i try to join a game i get "Connection failed for unknown reasons"

Ive pressed retry about 50 times and it doesnt help, ive installed drivers, rolled back drivers and directx, opened ports but none of that worked.

I have come across 1 thing that might help, when i run dxdiag.exe and then test directplay and try creating a session on 34987 (RoN default port host) i get: "DirectPlay test results: The tests were cancelled before completing."

any help would be much appreciated thanks

Also thought my system spec might help (from dxdiag):

System Manufacturer: VIAK8M
System Model: AWRDACPI
BIOS: Phoenix - AwardBIOS v6.00PG
Processor: AMD Sempron(tm) Processor 3000+, MMX, 3DNow, ~1.8GHz
Memory: 768MB RAM
Page File: 386MB used, 1103MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.2180 32bit Unicode
The Naminator
posted 06-29-07 04:10 PM EDT (US)     529 / 618       
Are you using a modem/router?
If you are using it try using 56kps(modem, That thing with a thick layer of dust).

I stole this sign!
posted 06-29-07 05:00 PM EDT (US)     530 / 618       
yes i am i have the BThomehub so i guess thats a router, and i dont have a modem any other suggestions?
The Naminator
posted 06-29-07 06:44 PM EDT (US)     531 / 618       
when you opened ports did you also open the routers ports?

I stole this sign!
posted 06-29-07 07:21 PM EDT (US)     532 / 618       
no how do i do that? im goin bed so ill reply in morning
The Naminator
posted 06-29-07 08:26 PM EDT (US)     533 / 618       
Well, I don't know it depends on the manufacturer, check the page of the manufacturer or the instructive.

I stole this sign!
posted 06-30-07 06:47 AM EDT (US)     534 / 618       
the ports were already open and i opened them through windows firewall but still the same
The Naminator
posted 06-30-07 01:50 PM EDT (US)     535 / 618       
the ports were already open and i opened them through windows firewall but still the same
You opened them "through" windows firewall?
Windows has a firewall most of modems have a firewall/virtual server too so you need to open both, are you using sonme antivirus program?

I stole this sign!
posted 06-30-07 02:59 PM EDT (US)     536 / 618       
yup ive turned norton and bitdefender and firewall off, its really confusing there doesnt seem to be a problem but there is :S
The Naminator
posted 06-30-07 06:58 PM EDT (US)     537 / 618       
Well.... in that case plan B

I stole this sign!
posted 07-02-07 01:00 PM EDT (US)     538 / 618       
i dont get what u mean mate you want me to upgrade or get new drivers? :S
The Naminator
posted 07-02-07 01:48 PM EDT (US)     539 / 618       
No, Its the troubleshooting forum of Heavengames maybe PCDania can help you.

I stole this sign!
posted 07-02-07 05:49 PM EDT (US)     540 / 618       
My game always seems to crash after approx the same amount of time playing it.
Laptop Specs:

Windows Vista Ultimate
512 Ram
40gb HD, 2.5 Free
Processor: 1.30 gigahertz Intel Celeron M
64 kilobyte primary memory cache
1024 kilobyte secondary memory cache
Intel(R) 82852/82855 GM/GME Graphics Controller (Microsoft Corporation - XDDM)
Realtek AC'97 Audio

Laptop screen goes black, sound goes off but disk, HD etc still running. Doesn't respond to Ctrl+Alt+Del or any other inputs

Any ideas?
The Naminator
posted 07-02-07 10:37 PM EDT (US)     541 / 618       
I don't know, I don't have vista but I heard that it has a xp mode, are you using it?

I stole this sign!
posted 07-03-07 10:07 AM EDT (US)     542 / 618       
The XP mode is for when you're installing a program so technically should only affect the way a program installs, not the way it runs.
The installation of the game went fine with no problems, which is what confuses me!
I have noticed my laptop getting quite hot when it cuts out, but no more than usual. Could this be causing it?
The Naminator
posted 07-03-07 10:55 AM EDT (US)     543 / 618       
Maybe its overheating I have the same problem recently with my laptop excepts that it shut downs, Is there somekind of message like ACPI or something?

I stole this sign!
posted 07-03-07 11:47 AM EDT (US)     544 / 618       
No the screen just goes black. Do you think there might be an error log somewhere?
Where would I look?
The Naminator
posted 07-03-07 07:14 PM EDT (US)     545 / 618       
Ask PCDania
I don't why that could happen

I stole this sign!
(id: PCD)
posted 07-04-07 03:46 PM EDT (US)     546 / 618       
Hi tartarian, got your mail.

The problem is most likely that you are using Intel graphics. At the time of the release of the game Intel graphics were not supported by the game. On many WinXP computer with Intel graphics the game works though as it also depends on the graphics driver used and how powerfull the CPU is. You could try check if there's an updated graphics driver for Vista or as The Naminator suggests, try compartibility mode for WinXP which makes Vista handle the game like WinXP would do.

"Cats are the only animals that are both uber, pwns and 1337 at the same time." -King Euric
By reading this fine print your soul is now the exclusive property of HeavenGames.
Turkish General
posted 07-17-07 07:10 AM EDT (US)     547 / 618       
new bug is in town...

i was playing a quick battle with 7 AI.
map:Nile Delta(Or Atlantic Sea Power)
std resources
etc. etc.
anyway,i saw some three strange transports near my island.i clicked at them to see what they were(cuz i needed every soldier available)and i saw this:
Gathering:+30 Timber
then i clicked the others.And i saw:
Gathering +30 Metal
to test it,i selected a worker in a woodcutters camp and garrisoned him in a city.and the +434 timber decreased.then,i moved the transport didnt say gathering+30 but the +434 timber did not other words..i had a fake woodcutter in a transport...if you have xfire,just add shockinfantry22 and i'll show the scrnshot.
posted 07-21-07 08:45 PM EDT (US)     548 / 618       
I got the game to day and while downloading it to my computer. it said "disk error make sure harddrive isnt full and not using the same program." i deleted at least 6,00 MB off the computer and i still get that messageon that same thing. 9% in i get that when i deleted 6,000 worth of MB plese help im getting ready to tell the site off!
The Naminator
posted 07-23-07 07:24 PM EDT (US)     549 / 618       
Check that the disc is clean and without scratches.

I stole this sign!
posted 07-26-07 12:49 PM EDT (US)     550 / 618       
"I am recieveing the "Gathering Exception". It seems to happen at different times. The first two times it happened I was able to send an error report. Since then it simply locks up the computer, and I have to pull the power. It happens really soon after i start a quick battle. A number of times it crashed after I left clicked on the map at the bottom. It use to happen right after the game started, and just last time I got all excited, just to have it crash a few minutes later.
I have:
AMD Athlon 1.34
512 MB ram
Windows XP SP2
Pny Nvidia Geforce4 Ti 4400
My mother board does have a VIA chipset, it is a gigabyte GA-7XD+ i believe.
RoN Gold (it crashes in also)

It was installed about 5 times. Twice on a fresh reformat. Followed just about every suggestion offered by microsoft and others to fix this... I have run RoN on this machine a few years ago, and dont recall any problems. But now after purchasing it... of course... does not work"

- i've got the exect same problem...any solution ?
« Previous Page  1 ··· 10 ··· 20 21 22 23 24 ··· 25  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Rise of Nations Heaven | HeavenGames