You must be logged in to post messages.
Please login or register

RoN Tech Support
Moderated by alincarpetman

Hop to:    
Welcome! You are not logged in. Please Login or Register.618 replies, Sticky
Rise of Nations Heaven » Forums » RoN Tech Support » Report Bugs here so they get fixed!
Topic Subject:Report Bugs here so they get fixed!
« Previous Page  1 2 3 4 5 6 ··· 10 ··· 20 ··· 25  Next Page »
posted 05-21-03 02:25 PM EDT (US)         
I've noticed people complaining about not being able to play Rise of Nations because of bugs, patch problems... etc.

So... here's what the community can do to help BHG solve these issues and get them fixed.

1. Give a brief description of the problem. For example:
Game doesn't patch.

2. Give a detailed system analysis of you computer specs. To make this easier for people to find out what they have, go here and download the Belarc Advisor at and/or just browse through your Device Manager.
For example:
1.8MGz Intel Pentium 4 (Win XP Pro. SP1 build 2600)
Dell OptiPlex GX240 MB with BIOS A03 03/01/2002
40GB Hard Drive with 21.85GB Free Space.
NVIDIA GeForce4 Ti4400 with driver 03/20/2003
(Optional) Cable Modem w/Firewall... etc.
Rise of Nations retail (English version) build
No mods, no cracks, no trainers... etc.

3. Give a more detailed description of the problem. For example:
When updating the patch through GameSpy, it will download 100% then bring me back to desktop and patch RoN until it reaches 37%, then it will stop and give me an "Invalid Patch File Error" and a "Retcode positive - 32769". I have the English version of the game.

4. Give reproduction steps on how to make it happen again. For example:
1. Launch the game.
2. Go to Multiplayer Game.
3. Go to GameSpy Internet Matchmaking.
4. Click "OK" when it says to upgrade to version
5. When the download is complete, log into GameSpy with your password.
6. Observe the game going to desktop and stopping at 37% during the patch process.

5. If it's a multiplayer game, be sure to specify if it was through GameSpy Arcade, GameSpy Internal, or LAN/IP. Then list the settings for the Multiplayer game. For example:
Teams of 3
Great Lakes
Large (5/6 player)
No Cannon Time
End Age: Gunpowder Age
Elimination: Conquest
Victory: Conquest
Tournament Play enabled.
3 Humans vs. 3 Computers (Moderate, Moderate, and Tough)
Nations in the game were:
Aztecs, Mongols, Chinese, Chinese, Egyptians, and Russians.

6. If it's a single player Quick Battle game, list the same steps as in #5. If it's a Conquer the World Single Player Campaign... list:
1. What your Nation is.
2. What difficulty setting you have.
3. What Age it was in.
4. What country you were attacking, and what battle type it was.
5. What build you're in... and what build you started your Campaign in. For instance, the retail is, and the patch is Did you start a campaign in the retail version and save the campaign... and then upgrade to the patch and load the campaign?

If you see your bug listed here already from someone else, just give your #2. Computer Specs.

[This message has been edited by Scrubs (edited 05-21-2003 @ 05:29 PM).]

posted 05-26-03 12:13 PM EDT (US)     76 / 618       
----- IN GAME CHAT -------

ATTENTION- this needs work.

the in game chat, ( and perhaps i am still learning how to do it) needs some work.

unlike other games, i game chat vanishes quickly and is unable (as fa as I know) to be redisplayed.

also, I had one game where my chat did not appear and i could not figure out how to turn it back on.

other games let you page up, but this uses that for a zoom key.

also, I will say it again, the end of the game needs addressed . right now, it is almost impossible to chat or review the map after the game.


please email if there is something i can do to fix this. i rarely read this post. thanks

posted 05-26-03 04:42 PM EDT (US)     77 / 618       
Recorded game versions incompatible -- causes abort to desktop or reboot because can't end game.

Version incompatibilibties affecting the playback of recorded games exist between the shipped version of RoN on the CD (US distribution) and the first patch downloaded from GameSpy. The problem will, if you are lucky, put you back on the desktop, or if unlucky, force you to reboot or red switch your machine.

Symptoms of the problem are as follows: when attempting to load a recorded game from a version of the game different from that currently installed on your machine, one of three things will happen:

1) Best case: the recorded game starts, but drops back to desktop, where the following error message is displayed in a window: "BHG RTS Run Time FATAL: unknown net command received" -- three buttons available, Ignore, Retry, Abort. Using any of the three will end execution of the game.

2) Worse: the recorded game starts, but hangs - music, movement cease. Mouse can be moved, but no obvious response to keyboard input. If you do Ctrl-Alt-Delete, while you will not see the task manager come up, it will be available, and you can reboot from there with Alt-U, R.

3) Worse #2: the recorded game does not start, but hangs during load with message to the effect that game is waiting for players. Same process as above (Ctrl-Alt-Delete, etc.) will succeed in rebooting machine.

My machine:
Windows XP Pro SP1,
NVidia driver 44.03
DirectX 9.0a
Norton Internet Security 2002 - up to date
ASUS A7V266-E mb
Atlon 1800+
1 g ram
80 g harddrive / about 30% used, FAT32
LeadTek ti4200

Suggested fix:
The next patch at a minimum should not allow the load of a recording created by a version of the game different from that loaded on the users machine. Warcraft III has built in this kind of check for their recorded games. That way, at least one won't have to deal with trying to safely reboot your computer.

posted 05-26-03 05:42 PM EDT (US)     78 / 618       
I am having the same multiplayer problems where i cant host or anything. It says Could not load directplay session, please check network connection. I have no firewall, I disabled windows firewall, I have no router, I downloaded and installed the windows updates. The only thing is that Im networked to another computer. The game also freezs up on me every once and a while to.

I have AMD 2000 xp
XP home
ABIT KD-7/ RAID mobo
Asus gf fx 5600
512 DDR kingston RAM

this is getting very annoying and im thinking of returning this game.

Red Scorpion
posted 05-26-03 06:18 PM EDT (US)     79 / 618       
Having problems playing Saved Games:

When re-loading a Saved Game my Control Numbers have all changed; eg., 9th Army = 64; 2nd Support = 56. Annoying, but not major problem. However, on one game, upon loading Saved Game all my cliffs were White (no graphics). As soon as I un-pause the game crashes to desktop. Tried this twice, crashed twice. Played alright when starting new game though. The most annoying thing is that I had just spent the best part of a day getting to the position I was at when I saved the game the previous night. Still got the saved game, put too much effort into it to just delete it. Can it be fixed?

1.9GHz Intel Pentium 4 (Win ME Build 4.90.3000)
Advent 256mb ddr333 RamRAM
120GB Hard Drive with 86.80GB Free Space.
NVIDIA GeForce4 Ti4200 (64mb)Rise of Nations retail (English version) build
No mods, no cracks, no trainers... etc.

Have posted same info on the Apolyton Forum & someone else has same problem. Any Suggestions? Is ruining gameplay as I can't start a battle if I know I'm not going to be able to finish it sameday.

The HoboJ
posted 05-26-03 06:53 PM EDT (US)     80 / 618       
My problem is the screen goes corrupted after a while of gameplay. I'll explain now: I play for a while in single player and unexpectedly the screen goes all checkerboardy with parts displaying the proper screen and others all jumbled and corrupted up. I got a 64mg ATI Radeon 7500 vid card. I've updated all my drivers. Everything on my comp exceeds the requirements.
posted 05-26-03 09:03 PM EDT (US)     81 / 618       
Hello Everyone.... Pls Pls.. any help will be appreciated.. I've tried everything...

My problem is I can install and do everything fine but when it comes to running it, the rise of nations screen comes up and then it just goes straight to windows xp sending error report to microsoft.

I cannot play the game at all... something in the error report about xml.. translatable string and lots of .dll errors. I'm not sure what's wrong. I've tried formatting my whole drive installing both Windows 2000 and XP all new drivers nothing seems to work. Please Please advise

My specs are

P4 2.4 GHz,
windows XP
1GB ram
Geforce 4 MX 440 AGP 8x
Creative Soundblaster 5.1 Live! with no driver.. but sound still seems to work

I've been at it for more that 8 hours.. please any help will be mucho appreciated

posted 05-26-03 09:30 PM EDT (US)     82 / 618       
When i got to start my game, it goes through the beginning videos but when it is done and the game is about to begin, a little message pops up that says gathering exceptions data, then rise of nations encounters a problem and closes, i have tried to do many things but still no luck. Someone please help me. It is not my video card because my friend has the game and he checked out my video card and says it is fine. I also have plenty of memory. I do not know what the problem is.
Please help me.
posted 05-26-03 09:51 PM EDT (US)     83 / 618       
I've tried more things to stop the freezes. I have an ATI Radeon 8500 so I tried going back to Catlyst 3.2 drivers as someone said that worked. Nope. 1 minute 10 seconds into a game and it freezes. I've lowered the hardware acceleration and that did not help. Upgraded the sound card drivers with no luck.

Then I tried seeing whether I could just start a game and let it run without doing anything. Got through about six minutes before it froze without me touching the keyboard.

I've never had anything like this that wasn't solved by a simple upgrade of drivers. I previously said this was beta software at best. I've downgraded my opinion to alpha release software.

This is much better than Civ III even but at least that is a rock solid game.

posted 05-26-03 10:48 PM EDT (US)     84 / 618       
notice how scrubs has helped people with most the problems except the two most biggest, people unable to play on-line and the game freezing.
posted 05-27-03 00:59 AM EDT (US)     85 / 618       
Having Failed to Establish Directplay but im not using a router im using a switch with 2 others computers I've tried everything mentioned on the forums 10x over and cannot figure out the problem.
posted 05-27-03 03:19 AM EDT (US)     86 / 618       
Hey scrubs, i installed drx 9.0a as you have told me. Damn game still freezes up. 5-20 min into a game--wham locks up. Only way to fix is to reboot by turning off cpu. This is getting to be a pain in the rear. This isnt a small issue, over 100 people have this problem on many different types of machines--where can i go to get this to work. 50$ and cant play really sucks!!

Not yelling at you, you have been most helpful here and we are grateful.

I just wanna play RON!!


posted 05-27-03 07:22 AM EDT (US)     87 / 618       
Bug: Game will force exit, show a "Exception!: Creating Exception..." window, then crash (Microsoft Error Report) directly after Logging in to Gamespy Internet Matchmaking.

My system specs:
Windows ME
ATI Radeon 9700 Pro (by Ati)
SB Live!
ASUS P4T-533C Motherboard
P4 2.53ghz
512mb Rambus 1066
Seagate Cheetah 36XP
Adaptec U2W SCSI PCI Card 2940
Latest Direct X 9 drivers/radeon/sound drivers

The patch installed fine. I can play single player perfectly. I've updated gamespy arcade to the newest version. I've noticed the main menu kind of lags. Not the mouse, but the highlighting (when you hover your cursor over an icon). My system never crashes on anything. Hope this gets fixed!

posted 05-27-03 08:13 AM EDT (US)     88 / 618       
Update: an hour has passed, and it now works. Somebody said it was the server's fault. Cool
posted 05-27-03 09:04 AM EDT (US)     89 / 618       
my game runs absolutely horribly. Even the menus lag, they highlight 1-2 seconds after the mouse cursor is over them, and the windows are choppy, as well as the background animation. The game itself is hardly playable its so bad. The demo version of the game ran great at highest graphics settings, and note that i can run any other game at highest quality (4x antialiasing at 1600x1200). Ive tried everything ive seen on the forums so far, but ive decided that its a coding error and the lag is unreasonable.

athlon xp 1900+
epox 8k3a+ mb
leadtek geforce4 ti4600
44.03 nvidia drivers
hercules game theater xp w/latest drivers
win2k pro sp 3
1 gig crucial ddr
fresh-from-the-box ron

posted 05-27-03 09:24 AM EDT (US)     90 / 618       
Have you tried to goto your video card settings and turning off Anti-Aliasing/Anistropic Filtering?
posted 05-27-03 09:47 AM EDT (US)     91 / 618       
filtering is off, i just turned antialiasing off and it had no effect.

[This message has been edited by codechino (edited 05-27-2003 @ 09:48 AM).]

posted 05-27-03 02:02 PM EDT (US)     92 / 618       
Dear Scrubs,
Windows XP Professional Service Pack 1 (build 2600)
2850 megahertz Intel Pentium 4
8 kilobyte primary memory cache
512 kilobyte secondary memory cache
Board: Gigabyte Technology Co., Ltd. 8PE667U 1.x
Bus Clock: 133 megahertz
BIOS: Award Software International, Inc. 6.00 PG 10/16/2002
203.84 Gigabytes Usable Hard Drive Capacity
172.25 Gigabytes Hard Drive Free Space
1024 Megabytes Installed Memory
SB AUDIGY 2 Platinum

When trying to start up the game, I get the error message:
A debugger has been detected. Unload the debugger and try again.
I'm clueless here. Hope you are not.

posted 05-27-03 02:49 PM EDT (US)     93 / 618       
I get some insane lag when I play online

Atholon 2100 xp
1gb ddr 2700
120gb hd with 8mb cache and 98gb free
geforce3 with 44.03 drivers
audigy with new beta drivers
256k cable modem
windows xp with sp1

and I dont have a firewall on or anti virus on but like 5 minutes into game it starts lagging like mad. I heard it was a lag bug and I'm sure it is cuz this game is infested with bugs.

[This message has been edited by ChristianSoldier (edited 05-27-2003 @ 02:50 PM).]

posted 05-27-03 08:12 PM EDT (US)     94 / 618       
Aside from the (already mentioned) problems of various lockups & crashes, I'd like to mention some possible bugs that are mentioned in other threads, but it'll be good to be listed here too, just in case the developers ever look up this thread to gather information for a future patch.

a) The "minimizing" problem. This is now a "known issue", but it also remains a bug - Big Huge can probably fix this in a future patch without too much trouble. Meanwhile you can use one of three options: the unoficial (illegal) no-cd patch -or- turn the skip intro movies flag to 1 in the ini file, -or- press the Escape key just before the game minimizes.

b) For some people the bit depths are not saved, if you change them in-game. The game seems only to take into account your current desktop resolution/bit depth and always starts in THAT particular bit-depth. Also: some people (including me) are not able for some reason to select an 800x600 resolution no matter what.

c) Another possible bug has to do with the fulscreen flag, and the window-resolutions in the ini file. It seems that for some people even if the option flag in the ini file is changed to have a non-fulscreen (windowed) game, the game still remains full-screen. The only thing that actually changes to a window, are the intro movies. This game definately needed a more robust programming code to handle the video issues - having to resort to editing ini files (without result I might add) is kind of "crude".

[This message has been edited by faelae (edited 05-27-2003 @ 08:20 PM).]

posted 05-28-03 08:22 AM EDT (US)     95 / 618       
I have the same problem that Loftish described on page 3, with the CTW, I have a TNT2 32MB card with updated drivers but it still does not work, senerios work though. what other drives need update?

I have a 1.7GHz celeron
1.5 GB of free space on HDD, tried RON on win2k Adv. ser. and win98, both have the same error.

[This message has been edited by kilaj1 (edited 05-28-2003 @ 08:24 AM).]

posted 05-28-03 09:50 AM EDT (US)     96 / 618       
Does anybody get an "out of sync" error when using the Lan Multiplayer mode?
We begin to play and about 3 minutes into the game it will give us an "Out of Sync Ammo" or a similar error and we have to quit the game. Is there a patch coming out soon to fix this?
We never had a problem like this when we played Ages of Empires the same way.
posted 05-28-03 03:17 PM EDT (US)     97 / 618       
Hi all, some notes and suggestions:

1) For those of you getting CTW crashes, connectivity issues, and install problems: please check the other sticky thread in this forum (and on other forums as well if need be), most of these issues have been addressed and have potential workarounds already, or will be fixed in a very near-future patch.

2) For the sub-thread about all building art looking the same: this is by design, and is due to your computing/video card level. If we detect a lower speed/memory/vidcard system, the game will display all the same civ art for all the players. This helps eliminate some memory usage and hopefully provide you with a fun,playable experience. Playing on higher-end systems will give the full art sets. There is a thread on manually overriding this here:,1215,0,10

just note that if the game becomes too sluggish, return the settings back to where they should be

3) For those of you with blinking cursor issues, a slight modification to Scrubs' posts: in your rise2.ini file, as he said, you can manually override the cursor type used. However, don't set all 3 to '1', instead change them one at a time to 1 (setting the other two to '0'), and find the setting that works with your video card. If you could do me a favor as well, if you perform this fix and it works, and you are on the latest version of your video card drivers, if you could post the following to this thread: your video card make and manufacturer (i.e. Nvidia GeForce2), driver number, which setting (hardware, GDI, black/white) fixed the blinking cursor, and the device ID of your card.

To get the device ID of your card:
Run Start->Settings->Control Panel->DirectX
click on the 'DXDiag' button to launch DXDiag
Click on the 'More Help' tab
Click on the 'MSInfo' button to launch MSInfo
Click on 'Display' under the 'Components' category
you will see a line that reads PNPDeviceID or something similar, then a bunch of text, find the 4 characters after "DEV_". This is your device ID. Likely a Hexidecimal number like 21A3 or 41E8, etc...

Please note that upgrading to the latest video drivers for your card will often fix the problem, and is the preferred solution. If we missed testing on some cards, then the above information will help me to add cards we missed to future patches.


Big Huge Games
posted 05-28-03 03:45 PM EDT (US)     98 / 618       
When I first got RoN I had some problems with my comp crashing out to Windows and/or rebooting itself. I upgraded my video driver and had absolutely no problems....for a week. Last night I was playing and it crashed to Windows 3 times in a row, I rebooted and same thing. I have not had this problem with any other games I've played, and my son, who is running the game on a slightly older comp and video card has no trouble at all. So anyway, last night I downloaded the latest sound card driver for my Audigy card. I'm hoping that will fix the problem. It seems weird though, that it ran great for a week and then started having trouble.Oh, I also tried changing resolutions, number of colors, etc..makes no difference. I love this game but it's frustrating when you're right in the middle and all of a sudden you're looking at your desktop.

Oh yeah, I looked at the troubleshooting FAQ and I have none of the equipment they list there that has issues. I have 512mb of ddr memory, Win XP pro, adequate power supply, GEForce2 Ultra, 1700+ Athlon.

posted 05-28-03 03:48 PM EDT (US)     99 / 618       
I keep on getting the exception error when ever I try to start the demo, could you tell me what's wrong?

Here is my Dxdiag txt,!enclosure=.efda205

posted 05-29-03 05:35 AM EDT (US)     100 / 618       
The "debugging"problem is solved. A friend of mine found out that before installing, you should switch off everything of McAfee. It worked and now RON is running smoothly.
« Previous Page  1 2 3 4 5 6 ··· 10 ··· 20 ··· 25  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Rise of Nations Heaven | HeavenGames