You must be logged in to post messages.
Please login or register

Throne & Patriots Expansion Pack
Moderated by alincarpetman

Hop to:    
Welcome! You are not logged in. Please Login or Register.80 replies, Sticky
Rise of Nations Heaven » Forums » Throne & Patriots Expansion Pack » Bug List v1.5
Topic Subject:Bug List v1.5
« Previous Page  1 2 3 4  Next Page »
posted 05-29-04 05:30 PM EDT (US)         
I'm bored because I didn't sign up for the MFO tourny and there's no games so lets put all of the bugs in one nice tidy place.

If you find a bug not listed here(make sure it's a real bug), post here and I will update as time goes on.

Bug list so far:

  • Building the Hanging Gardens incorrectly displays knowledge earned in Universities.
  • Nubian merchants still get +50% base resources from rares in allies territory. This was *supposed* to be changed in patch 1.03 as it is listed in the change list. It was never changed. Need clarification from BHG.
  • Gathered rare resources display at the left corner of the screen always shows the same value (for example, even if you have getting +100 Food from Buffalo Merchant, it will show +20 if you put the mouse down the icon)
  • If the Republic Government is researched, new government's patriots will not have the supply wagon effect when they are supposed to.
  • Granaries and Granary techs improve the food bonus that Iroquios woodcutters receive.
  • Artillery someimtes incorrectly show that they are taking attrition when they aren't. Usually happens when they are firing in enemy territory under the supply of a patriot.
  • A single merchant can take up the 'merchant space' for two rare resources that are close together. I believe it happens in scenarios/CTW missions where some rare resources are placed close together.
  • Numbered armies when loading a saved game are sometimes not named correctly (e.g. "20" instead of 1st army, "21" instead of 2nd army)
  • I have never seen this capital border bonus, capital cities seem to push(at least with small cities) as much as normal cities.
  • Dutch merchants deployed on a rare resources do not gather resources while attacking.
  • Despot patriot gives +15 resources instead of +50 wealth when killing a caravan.
  • Aztecs get +15/30/45/60 resources instead of +50 wealth when killing a caravan.
  • CTW: Can pick a nation in a scenario, then hit the arrow keys to change scenarios, thus being able to select any nation in a campaign ie playing Lakota in Cold War in which case you have no country or anything.
  • Warring states little picture is the same as British Isles. Those maps are very different, and the picture doesn't look like any of them.
  • Persian UU says Ancient age I, Classical age II, Classical age III, and Classical age IV.
  • The Roman Unique Unit's upgrade description is incorrectly displayed. When placing the cursor above a Roman Hoplite's Icon, it will display "Greek Mercenary" rather then Legionares. This happens with the Phalanx and Spanish Scutari too.
  • Dutch military patriots get +7 armor and a little more hp. 327 Aztec Comrade with 2 general upgrades: 327hp. Dutch Comrade with 2 general upgrades: 537hp. Gigi has found that the Dutch supply patriots get an hp bonus as the dutch supply wagons get an hp bonus.
  • Single Player: Lakota AI builds farms and granaries and does not know he can build anywhere. AI plays properly if you set the map to 'reveal all'.
  • Main battle tank bug: Main battle tank is researched, units are upgraded, but the upgrade is still available for research and can be researched infinitely with no real effect.
  • MP: Number of games played and record is displaying wrong information.
  • Quick library research panel only displays the prices for technologies when you have a friendly unit or structure selected. We would like it to always display the prices.
  • Taking a Russian capital with the Despot patriot gives both players +500 all. Bug or not?
  • If you capture a wonder as America, your first wonder built is not built instantly
  • American temples, from Industrial Age on, loses its unique architecture and gets the European one
  • No way to cancel razing of an assimilating city
  • Descriptions of enemy units display the wrong upgrades (shows YOUR civ upgrades, not ITS civ ones). For example, if you're Egyptian and click an enemy Mongol Horde, its description will show like it was able to upgrade to a Royal mameluke
  • Most Egyptian and Turkish units are European-styled (i think that Muslim style should be the most compatible with them)
  • Nubian and Bantu Information age tanks have the wrong artwork set.
  • Alternate names for non-Library (see data/alternatenames.bhs) techs don't function (at least here)
  • Indians/Persians merchant huts don't have the proper architecture (huts are Latin-styled instead)
  • An annoying path (C:\Scenario) appears at root directory every time I save a scenario at Scenario Editor.
  • Japanese archers: Research heavy archer for the japanese in medieval, then you can upgrade to crossbowmen in gunpowder/medieval
  • Buildings don't always upgrade their architecture with age advances. Mostly happens in Medieval->Gunpwder and Enlightenment->Industrial
  • XML error notifications causes the RON window to block the screen even with many Alt-tabs (only the cursor appears normally). At these situation, only forcing standby mode, logoff, Windows user change, shutdown or restart the pc
  • Help text of Roman cities don't display that they provide wealth income
  • Infinite resources setting should say that it starts with many more citizens than normal
  • Weird Stuff(Possible bugs, hard to reproduce):

  • Technology stopping. Mostly happens with ages and future techs. I think it has something to do with libraries being damaged. Maybe has something to do with capital and/or the senate

  • With the Forbidden City built and my capital taken I cannot rebuild the senate, theus never getting future governments. I think I should be able to rebuild the senate in the forbidden city.

    Post any new bugs or mistakes. Don't post stuff like mp keeps crashing or out of sync errors.

    [This message has been edited by xxFlukexx (edited 10-27-2004 @ 00:18 AM).]

  • AuthorReplies:
    posted 06-07-04 08:37 PM EDT (US)     26 / 80       
    yeah i remembered Supercollider doesn't make unit upgrades instantly


    Japanese archers: One time in a mp game I researched heavy archer for the japanese in medieval, then could upgrade to crossbowmen in gunpowder. Can't reproduce it in sp.

    at least here, it was the inverse: crossbowmen that were "upgraded" to heavy archers
    and at SP games

    These are really bugs or mistakes:


    - Most Egyptian units are European-styled (i think that Muslim style should be the most compatible with them)
    - American Temple, from Industrial Age on, lose its unique architecture and gets the European one
    - Architecture of buildings may delay to change after Age advancing (especially Enlightenment to Industrial)

    [This message has been edited by Hrrr (edited 06-08-2004 @ 07:50 PM).]

    posted 06-08-04 10:30 PM EDT (US)     27 / 80       


    Technology stopping. Mostly happens with ages and future techs. I think it has something to do with libraries being damaged. Maybe has something to do with capital and/or the senate

    i think this is not a bug. you must raze their libraries to avoid their technological rise. A pretty nice atitude is to raze their libraries to prevent them from researching Missile Shield, for example

    posted 06-10-04 11:19 AM EDT (US)     28 / 80       
    Japanese don't get Heavy Archers.

    Go up to Medieval Age (or Gunpowder Age) and have MIL 3 or MIL 4 researched, then research Heavy Archers. When the research is done, they will still have Crossbowmen (or whatever type of FA you had before the upgrade) instead of Heavy Archers.

    posted 06-10-04 07:13 PM EDT (US)     29 / 80       
    this bug doesn't happens always, capitan
    for example: when Medieval Age is the starting on

    More bugs:

    - Persians may have two cities named Persepolis at the same time

    - Turks' nation power doesn't affect Bomb Vessels/Ketch

    - not only Egyptian units are off-styled, Turkish ones are also.

    - Senator Patriot loses his power of increasing building armor after Democracy is researched

    - Sometimes when I Alt-Tab the game and go back to it some minutes after, two musics (game soundtracks) may play simultaneously

    - Architecture of buildings may delay to change after Age advancing (especially Enlightenment to Industrial)

    - There are only four names for computer American rulers (George Washington, Thomas Jefferson, Abraham Lincoln and Theodore Roosevelt)

    [This message has been edited by Hrrr (edited 06-11-2004 @ 12:00 PM).]

    posted 06-10-04 08:18 PM EDT (US)     30 / 80       
    Dunno what you mean Hrrr, it always happens to me when I'm Japanese. Crossbowmen are the best type of FA you can get with them. You can upgrade to Heavy Archers, but it won't actually upgrade them.

    [This message has been edited by El_Capitan_ (edited 06-10-2004 @ 08:19 PM).]

    posted 06-10-04 09:12 PM EDT (US)     31 / 80       
    Ok, here's what happens with the Japanese archers:
    You research crossbowmen in medieval, but then you can upgrade them to heavy archers. But japanese archers still are crossbowmen. Heavy archers=crossbowmen so it makes no difference. Didn't happen to maya so I guess it's only with the japanese. Just waste some resources if you research both
    Seraph in Absentia
    (id: One_Dead_Villy)
    posted 06-16-04 02:46 AM EDT (US)     32 / 80       
    I just noticed that (at least on my market gold version of TaP) that the nubian and bantu info age tank is now a challenger and not a desert t80. i know why it gets messed up on my (its the unitrules.xml's CTW tanks thats causing it)

    [This message has been edited by One_Dead_Angel (edited 06-19-2004 @ 08:27 AM).]

    posted 06-17-04 04:13 AM EDT (US)     33 / 80       
    I found this thread while doing a search about a problem I had tonight.

    I am brand new to the game and was playing my girlfriend on our Lan. I played American, she played Dutch. We played a standard game and I took her Captial which had only become her capital after she built her senate in that city. I didn't actually destroy her senate though, it become mine and I ended up owning 2 senate buildings.

    The assimilation timer counted down, but I saw no capital victory timer anywhere. Once the city assimilated it was no longer marked with the capital Star and she had no other capitals on the map anywhere. So i tried to raze it but it said something like "You can not raze another players capital until you have defeated them".

    She ended up just resigning, because we coulding figure out what the problem was.

    But, before she resigned I razed her senate. I destroyed her original captial, all to no avail. I then let her take the city back over and it became her capital again. Thats when she resigned and we just figured the game was bugged some how.

    posted 06-18-04 04:32 PM EDT (US)     34 / 80       
    Hmmmm, you said you played a standard game, are you sure you set Elimination to Capital and not Conquest?

    Only other thing I can think of is that she built the Forbidden city.

    If neither of the above are the case, I'd like to see the .rec so I can confirm if it's a bug.

    posted 06-24-04 09:28 PM EDT (US)     35 / 80       
    The Taj Mahal in T&P reduces the caravan limit by one. If that's a feature, it's not listed in the wonder description.
    posted 07-07-04 01:28 AM EDT (US)     36 / 80       
    Iv'e only got the demo version(waited for the full to arrive through the mail) and in coop AI games sometimes the game glitches and keeps on saying no rare resources here and making an error tone. It is really annoying.

    I am LuNatic, Dark lord of the sif
    ~Fear Me Mortals~
    [-GREEM-] Best. Clan. Ever.
    a box of teeth
    (id: dark_one)
    posted 07-08-04 03:19 PM EDT (US)     37 / 80       
    -When i play my computer randomly crashes and says Exception! in a window and then collecting Exception! data and ron quits.
    -The bug with microsoft support that it doesnt include rise of nations should be fixed
    posted 07-09-04 10:24 AM EDT (US)     38 / 80       
    the library technology research bar on the top centre of the screen (new feature added in the expansion) sometimes displays how much each library tech cost, sometimes doesn't. It's weird. Theoretically, it should always display the cost of each tech when mouse pointer is moved to respective tech.
    posted 07-09-04 10:32 AM EDT (US)     39 / 80       
    as I described in the "BHG, please read this to improve the game" topic, the description of the science level tech doesn't include all the technologies that can be researched in the later science levels if end age is set to earlier ages than info age.,4211,0,20
    posted 07-09-04 08:23 PM EDT (US)     40 / 80       
    check out my post of "This is a Bug!" in General Discussions,4247,0,10
    posted 07-10-04 07:50 AM EDT (US)     41 / 80       
    NorthWind: I'll test that out in the next couple of days.

    dark_one: Yeah, that happens. It may happen one in every hundred games online but it sometimes does that(gamespy and RoNs code doesn't seem to get along all the time). If this happens a lot to you, you should reinstall and then update your drivers, blah blah blah.

    -Library Tech prices are only shown if you have a building or unit selected(already noted)
    -I don't 100% get your second post. I think that giving sci techs age requirements would make it so you pretty much always researched the same order.
    -If the editor is treating prerequisites as something other than a prerequisite, then they should either modify the description or fix the error. ODA says that prereq1,2,3 may be not a strict prereq so who knows what's going on there.

    P.S. Been not playing RoN lately much, CoH(City of Heroes has pulled me in and won't let me go) I hope they'll release a patch soon.

    posted 07-10-04 11:02 PM EDT (US)     42 / 80       
    OD Core Group
    posted 07-12-04 00:10 AM EDT (US)     43 / 80       
    Very minor problem, not really worth mentioning, but I noticed one of the Lakota's cities name is Mnisota, as opposed to Minisota.

    Help HG get rid of Firebird
    posted 07-18-04 01:40 AM EDT (US)     44 / 80       
    "If the Republic Government is researched, new government's patriots will not have the supply wagon effect when they are supposed to."

    Is this a bug? I'm not so sure. I too thought this was a bug at first. However, on reading what is promised when a subsequent government is researched, it appears that only the previous GOVERNMENT's benefits get inherited, not the Patriot unit's benefits.

    So if you had researched Republic, your government gave you Comm +50. If you then research Democracy, you would have Comm+50 AND 20% cheaper non-library techs.

    But your Senator Patriot (who provided healing, bribing, and building defence) upgrades to a President Patriot who now gives production, building defence, and healing benefits. i.e. bribing is gone, replaced with production.

    Is this right?

    posted 07-21-04 09:27 PM EDT (US)     45 / 80       
    I was able to get two merchants on the same resource by using auto explore. Each gave me resources.
    OD Core Group
    posted 07-23-04 03:04 PM EDT (US)     46 / 80       
    When I ordered a merchant to pick up a ruin next to a rare resource, he instead deployed next to the ruin and harvested the rare reasource. I was then able to send a second merchant and order him to the resource, and got two bonuses from it.

    Help HG get rid of Firebird
    Crazed Ewok
    (id: The Crazed Ewok)
    posted 07-29-04 01:24 AM EDT (US)     47 / 80       
    I have no doubt that this is NOT a bug, but I find it annoying and not really good...

    if I were to build a senate in a game that STARTS in the modern age and research a government, my patriot would look like a patriot from a medieval senate...I mean, come on. I don't think Hitler walked around flanked by two flag barrers and riding a horse with armor on him. Maybe a optional d/l of new unit graphics that'll replace the patriots with a slightly-different unit graphic than other high-government patriots (like capitalist, monarchy, etc) in the later ages...anyone agree/understand what I'm saying?


    American temples, from Industrial Age on, loses its unique architecture and gets the European one

    Yea, I noticed that bug too...I like the colonial church

    C hairman of the FMT, Mectator, and Seraph
    r esident of Unity RPG, Anti-Heroes, and Indolents
    a seraph at SWGBH and EAWH
    z apping spammers and stealing their shoes
    e w o k "Don't waste your breath trying to figure out my logic" - Seacker
    d ependent on daily tea infusions

    [This message has been edited by The Crazed Ewok (edited 07-29-2004 @ 01:26 AM).]

    posted 07-29-04 03:56 AM EDT (US)     48 / 80       
    Yeah Gladiator, thats how it works. you keep the government power but not the patriot bonuses.

    I am LuNatic, Dark lord of the sif
    ~Fear Me Mortals~
    [-GREEM-] Best. Clan. Ever.
    posted 08-04-04 10:22 PM EDT (US)     49 / 80       
    The game has been out over two months and still no patch? C'mon, I thought Big Huge learned their lessons with the v1.03 patch?
    Mallozzi IBO
    posted 08-08-04 01:40 PM EDT (US)     50 / 80       
    The Roman Unique Unit's upgrade description is incorrectly displayed. When placing the cursor above a Roman Hopolite's Icon, it will display "Greek Mercenary" Rather then Legionares.

    A proud guildsmen of the International Baccalaureate Organization
    « Previous Page  1 2 3 4  Next Page »
    You must be logged in to post messages.
    Please login or register

    Hop to:    

    Rise of Nations Heaven | HeavenGames